首页

  • 安装

    Discuz! X1 环境搭建和安装方法介绍

  • 升级/转换

    其它版本到 Discuz! X1 的升级/转换方法介绍

  • 前台使用

    Discuz! X1 前台功能使用方法介绍

  • 后台使用

    Discuz! X1 后台功能使用方法介绍

  • 常用功能

    Discuz! X1 比较常用的功能介绍

  • 工具

    Discuz! X1 使用和转换工具介绍


安装

Discuz! X1 安装相关

  • Linux 系统环境搭建推荐教程
  • Windows 系统环境搭建推荐教程
  • CentOS 5 服务器 Nginx 环境推荐教程
  • Discuz! X1 安装说明
返回主目录


Linux 环境搭建推荐教程

安装 —— Linux 环境搭建推荐教程

一、系统约定

软件源代码包存放位置：/usr/local/src

源码包编译安装位置(prefix)：/usr/local/software_name

脚本以及维护程序存放位置：/usr/local/sbin

MySQL 数据库位置：/var/lib/MySQL（可按情况设置）

Apache 网站根目录：/home/www/wwwroot（可按情况设置）

Apache 虚拟主机日志根目录：/home/www/logs（可按情况设置）

Apache 运行账户：www:www

二、系统环境部署及调整

1、检查系统是否正常

# more /var/log/messages（检查有无系统级错误信息）

# dmesg（检查硬件设备是否有错误信息）

#cat /proc/cpuinfo (检查CPU频率是否正常)

#top (按1检测CPU核数是否正常，内存大小是否正常)

# ifconfig（检查网卡设置是否正确）

# ping www.163.com（检查网络是否正常）

2、关闭不需要的服务

# ntsysv

以下仅列出需要启动的服务，未列出的服务一律推荐关闭：

atd

crond

irqbalance

microcode_ctl

network

sendmail

sshd

syslog

关闭SElinux：修改/etc/selinux/config文件中的SELINUX= 为 disabled

3、更换快速源

# cd /etc/yum.repos.d/

# mv CentOS-Base.repo CentOS-Base.repo.old

# wget http://centos.ustc.edu.cn/CentOS-Base.repo.5

# mv CentOS-Base.repo.5 CentOS-Base.repo

# yum update

4、使用 yum 程序安装所需开发包（以下为标准的 RPM 包名称）

# yum -y install ntp make openssl openssl-devel pcre pcre-devel libpng libpng-devel libjpeg-6b libjpeg-devel-6b freetype freetype-devel gd gd-devel zlib zlib-devel gcc gcc-c++ libXpm libXpm-devel ncurses ncurses-devel libmcrypt libmcrypt-devel libxml2 libxml2-devel imake autoconf automake screen sysstat compat-libstdc++-33 curl curl-deve

5、定时校正服务器时钟，定时与中国国家授时中心授时服务器同步

# crontab -e

加入一行：

*/30 * * * * ntpdate 210.72.145.44 > /dev/null 2>&1

6、下载程序包

请到各程序官方网站下载最新的稳定版本存放到/usr/local/src/目录

Apache 当前稳定版 2.2.15

http://apache.securedservers.com/httpd/

PHP 当前稳定版5.2.13

http://cn.php.net/releases/

Mysql 当前稳定版5.0.86

http://dev.mysql.coml/

Zend 当前稳定版3.3.3

http://downloads.zend.com/

Memcache 当前稳定版2.2.5

http://pecl.php.net/package/memcache/

Memcached 当前稳定版1.4.5

http://memcached.googlecode.com

文中的配置文件和脚本限于篇幅，请到以下地址下载

Apache控制脚本

http://c.sihost.net/jb/httpd

Apache配置文件

http://c.sihost.net/jb/httpd.conf

以上列出的程序最新稳定版下载列表

http://c.sihost.net/lamp_tools.list

在 /usr/local/src目录下执行

wget http://c.sihost.net/lamp_tools.list

wget -i lamp_tools.list

7、创建web运行用户

#groupadd www

#useradd -g www www

#mkdir -p /home/www/wwwroot

#chmod +w /home/www/wwwroot

# chown www:www /home/www/wwwroot -R

8、重新启动

# init 6

三、编译安装L.A.M.P环境

1、安装MySQL

# cd /usr/local/src

# tar zxvf mysql-5.0.86-linux-i686-icc-glibc23.tar.gz

# mv mysql-5.0.86-linux-i686-icc-glibc23 /usr/local/

# ln -s /usr/local/mysql-5.0.86-linux-i686-icc-glibc23/ /usr/local/mysql

#groupadd mysql

#useradd -g mysql mysql -d /home/mysql -s /sbin/nologin

#chown -R mysql:mysql /usr/local/mysql

#chown -R mysql:mysql /usr/local/mysql-5.0.86-linux-i686-icc-glibc23/

# cd /usr/local/mysql

# ./scripts/mysql_install_db --user=mysql

#cp ./support-files/mysql.server /etc/rc.d/init.d/mysqld

# chmod 755 /etc/rc.d/init.d/mysqld

# chkconfig --add mysqld

# chkconfig --level 3 mysqld on

# cp ./support-files/my-huge.cnf /etc/my.cnf

# mv /usr/local/mysql/data /var/lib/mysql

# chown -R mysql:mysql /var/lib/mysql

编辑/etc/my.cnf

在 [mysqld] 段增加

在 [mysqld] 段修改

将 log-bin 注释

service mysqld start

# bin/mysqladmin -u root password password

其中引号内的 password 是要设置的 root 密码

2、编译安装Apache

# cd /usr/local/src/

# tar jxvf httpd-2.2.15.tar.bz2

# cd httpd-2.2.15/

# ./configure --prefix=/usr/local/apache --enable-module=rewrite --disable-access --disable-auth --disable-charset-lite --disable-include --disable-log-config --disable-env --disable-setenvif --disable-mime --disable-status --disable-autoindex --disable-asis --disable-cgid --disable-cgi --disable-negotiation --disable-dir --disable-actions --disable-userdir --disable-alias --enable-so --enable-mods-shared=' access auth auth_anon auth_dbm auth_digest dav dav_fs actions alias asis autoindex cache cern_meta cgi charset_lite deflate dir disk_cache env expires file_cache headers include info log_config logio mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias'

# make

# make install

# cd /usr/local/src/

# mv /usr/local/apache/conf/httpd.conf /usr/local/apache/conf/httpd.conf.old

# cp -f /usr/local/src/httpd.conf /usr/local/apache/conf/httpd.conf

# cp -f /usr/local/src/httpd /etc/init.d/httpd

# chmod 755 /etc/init.d/httpd

# chkconfig --add httpd

# chkconfig httpd on

3、编辑安装PHP所需的支持库

Libiconv

# cd /usr/local/src/

# tar zxvf libiconv-1.13.1.tar.gz

# cd libiconv-1.13.1/

# ./configure --prefix=/usr/local

# make

# make install

# cd ..

Libmcrypt

# tar zxvf libmcrypt-2.5.8.tar.gz

# cd libmcrypt-2.5.8

# ./configure

# make

# make install

# /sbin/ldconfig

# cd libltdl/

# ./configure --enable-ltdl-install

# make

# make install

# cd /usr/local/src/

Mhash

# tar zxvf mhash-0.9.9.9.tar.gz

# cd mhash-0.9.9.9/

# ./configure

# make

# make install

# cd ..

# ln -s /usr/local/lib/libmcrypt.la /usr/lib/libmcrypt.la

$ ln -s /usr/local/lib/libmcrypt.so /usr/lib/libmcrypt.so

$ ln -s /usr/local/lib/libmcrypt.so.4 /usr/lib/libmcrypt.so.4

$ ln -s /usr/local/lib/libmcrypt.so.4.4.8 /usr/lib/libmcrypt.so.4.4.8

# ln -s /usr/local/lib/libmhash.a /usr/lib/libmhash.a

# ln -s /usr/local/lib/libmhash.la /usr/lib/libmhash.la

# ln -s /usr/local/lib/libmhash.so /usr/lib/libmhash.so

# ln -s /usr/local/lib/libmhash.so.2 /usr/lib/libmhash.so.2

# ln -s /usr/local/lib/libmhash.so.2.0.1 /usr/lib/libmhash.so.2.0.1

$ ln -s /usr/local/bin/libmcrypt-config /usr/bin/libmcrypt-config

# tar zxvf mcrypt-2.6.8.tar.gz

# cd mcrypt-2.6.8

# /sbin/ldconfig

# ./configure

# make

# make install

4、编译安装PHP

# cd /usr/local/src

# tar zxvf php-5.2.13.tar.gz

# cd php-5.2.13

# ./configure --prefix=/usr/local/php --with-config-file-path=/usr/local/etc --enable-mbstring --enable-ftp --with-gd --with-jpeg-dir=/usr --with-png-dir=/usr --enable-magic-quotes --with-mysql=/usr/local/mysql --with-pear --enable-sockets --with-ttf --with-freetype-dir=/usr --enable-gd-native-ttf --with-zlib --enable-sysvsem --enable-sysvshm --with-libxml-dir=/usr --with-apxs2=/usr/local/apache/bin/apxs --with-iconv-dir=/usr/local --with-xmlrpc --enable-xml --enable-shmop --enable-zip --with-mhash --with-mcrypt --enable-discard-path --enable-bcmath --enable-inline-optimization --with-curl --with-curlwrappers --enable-mbregex --with-openssl

# make ZEND_EXTRA_LIBS='-liconv'

# make install

# ./libtool --finish /usr/local/src/php-5.2.13/libs

# cp php.ini-dist /usr/local/etc/php.ini

# echo 'ulimit -SHn 65535' >> /etc/rc.local

# service httpd start

5、安装PHP扩展模块（Discuz! X1 用户选装）

Memcache

# cd /usr/local/src

# tar zxvf memcache-2.2.5.tgz

# cd memcache-2.2.5/

# /usr/local/php/bin/phpize

# ./configure --with-php-config=/usr/local/php/bin/php-config

# make

# make install

修改php.ini文件，路径/usr/local/etc/

查找：

修改成：

在此句下面一行

添加：extension = "memcache.so"

查找：

修改成：

保存。

Memcached

# cd /usr/local/src

# tar zxvf libevent-1.4.13-stable.tar.gz

# cd libevent-1.4.13-stable

# ./configure --prefix=/usr/lib

# make

# make install

# cd ../

# tar zxvf memcached-1.4.5.tar.gz

# cd memcached-1.4.5

# ./configure --prefix=/usr/local --with-libevent=/usr/lib/

# make

# make install

# /usr/local/bin/memcached -d -u www -m 128

-p 监听的TCP端口 (缺省: 11211)

-d 以守护进程方式运行 以守护进程方式运行 Memcached Memcached

-u 运行运行 Memcached的账户 非root用户

-m 最大的内存使用单位是MB 缺省是64MB

-c 软连接数量缺省是1024

-v 输出警告和错误信息

-vv 打印客户端的请求和返回信息

-h 打印帮助信息

-i 打印memcached和libevent的版权信息

6、安装Zend Optimizer

# cd /usr/local/src

# tar zxvf ZendOptimizer-3.3.3-linux-glibc23-i386.tar.gz

# cd ZendOptimizer-3.3.3-linux-glibc23-i386

# ./install

Please specify the location for installing

Zend Optimizer:

这里填写Zend的安装路径，按下面写即可

/usr/local/Zend

Confirm the location of your

php.ini file:

这里填写的是php.ini的路径，按下面写即可

/usr/local/etc

Are you using Apache Web server?

这里选YES

Apache的控制组件路径

/usr/local/apache/bin/apachectl

是否重启Apache，YES，回车

7、查看确认L.A.M.P环境信息、提升 PHP 安全性

保存以下内容为info.php到/home/www/wwwroot/，检查phpinfo中的各项信息是否正确。

确认 PHP 能够正常工作后，编辑/usr/local/etc/php.ini进行设置提升PHP安全性。

找到：

disable_functions =

在等号后添加下面的函数名字

四、服务器安全性设置

设置系统防火墙

# vi /usr/local/sbin/fw.sh

将以下脚本命令粘贴到 fw.sh 文件中。

#!/bin/bash

# Stop iptables service first

service iptables stop

# Load FTP Kernel modules

/sbin/modprobe ip_conntrack_ftp

/sbin/modprobe ip_nat_ftp

# Inital chains default policy

/sbin/iptables -F -t filter

/sbin/iptables -P INPUT DROP

/sbin/iptables -P OUTPUT ACCEPT

# Enable Native Network Transfer

/sbin/iptables -A INPUT -i lo -j ACCEPT

# Accept Established Connections

/sbin/iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT

# ICMP Control

/sbin/iptables -A INPUT -p icmp -m limit --limit 1/s --limit-burst 10 -j ACCEPT

# WWW Service

/sbin/iptables -A INPUT -p tcp --dport 80 -j ACCEPT

# FTP Service

/sbin/iptables -A INPUT -p tcp --dport 21 -j ACCEPT

# SSH Service

/sbin/iptables -A INPUT -p tcp --dport 22 -j ACCEPT

# chmod 755 /usr/local/sbin/fw.sh

# echo '/usr/local/sbin/fw.sh' >> /etc/rc.local

# /usr/local/sbin/fw.sh

康盛创想（北京）科技有限公司 © 2001 - 2010 Comsenz Inc.
问题和建议请反馈至：doc@comsenz.com


Windows 环境搭建推荐教程

安装 —— Windows 环境搭建推荐教程

一、系统约定

环境软件下载后存放位置：X:\Server_Tools

环境软件安装位置：X:\Server_Core

PHP安装位置：X:\Server_Core\PHP

MySQL安装位置：X:\Server_Core\MySQL

Zend Optimizer安装位置：X:\Server_Core\Zend

IIS网站站点根目录：X:\wwwroot

MySQL 数据库位置：X:\Database

php.ini存放位置：X:\Windows\php.ini

my.ini 存放位置：X:\Server_Core\MySQL\my.ini

二、系统环境检查以及准备所需软件

1、检查系统是否已安装IIS

单击：“开始”－“管理工具”。

检查是否存在“Internet 信息服务(IIS)管理器”，由于操作系统盘中会自带IIS，所以建议安装操作系统时，把IIS默认安装上。如果未安装，可以到网络上下载对应操作系统版本的IIS。

2、查看磁盘分区容量并确定使用策略

打开“我的电脑”，查看除C区外各个磁盘分区的可用空间容量，使用容量较大的磁盘分区作为WEB根目录，且MySQL数据库存储目录(Database)，尽量不要与WEB根目录同在一个磁盘分区内。较小的磁盘分区可以作为服务环境软件的安装目录分区。

注：如果客户有特殊要求则按客户要求进行部署。

3、下载环境软件

将所有软件均下载存放于Server_Tools文件夹中，下载地址：

mysql-essential-5.0.67-win32.msi

http://dev.mysql.com/downloads/

php-5.2.8-Win32.zip

http://php.net/downloads.php

ZendOptimizer-3.3.3-Windows-i386.exe

http://www.zend.com/en/products/guard/zend-optimizer

PHPMyAdmin-3.1.0-all-languages.zip

http://www.phpmyadmin.net/home_page/downloads.php

注意事项：php版本选择5.2.x，小版本号越新越好，暂时不要用php5.3版本，没有特殊原因，不要用php4了，php官方不再提供php4支持，MySQL版本选择5.0.x，小版本号越新越好，没有特殊原因不用其他版本，包括5.1，可能会有bug，php尽量使用非安装的绿色版本，MySQL尽量用安装版本。

三、环境部署

1、安装MySQL

1）安装软件

进入X:\Server_Tools文件夹，双击mysql-essential-5.0.67-win32.msi；

选择Custom自定义安装

点击“Change”更改MySQL安装目录

待文件复制安装完毕后，进行MySQL设置界面，单击Finish。

选择Detailed Configuration进行详细配置

选择MySQL运行模式：Server Machine

选择MySQL数据库默认存储方式：Non-Trans Only ( MYISAM)

设定MySQL最大连接数：一般设置为128 - 512之间的整数。

设定MySQL网络参数，注意：不要启用Strict Mode！那个Add firewall的选项仅在需要外连MySQL的时候勾选上，也就是说给防火墙加个出入站的策略。

设定MySQL默认字符集：以用户站点语言为准，默认我们填gbk。

Windows环境设定

修改设定root用户密码，root密码请设置的比较复杂些。

注意：非必要情况下，不要启动远程连接模式！

完成MySQL的安装，并启动MySQL服务。

2）测试MySQL工作是否正常

打开cmd命令提示符窗口，输入命令：mysql –u root –p

输入刚才安装时设置的密码后，如果能够正常进入MySQL控制台则说明MySQL安装正常。

3）更改MySQL数据库存放目录

打开cmd命令提示符窗口，输入命令：net stop mysql 停止MySQL服务运行；

打开X:\Server_Core\MySQL\my.ini，

找到：Datadir = “X:\Server_Core\MySQL\data”

修改为：Datadir = “X:\Database”

将X:\Server_Core\MySQL\data 文件夹复制到X:\，并重命名X:\Database；

打开cmd命令提示符窗口，输入命令：net start mysql 启动MySQL服务。

重新测试MySQL是否工作正常。

4）移动LibMySQL动态链接库到系统目录

将X:\Server_Core\MySQL\bin\libmySQL.dll 文件复制到 C:\Windows\System32目录下。

2、安装PHP

1）解压缩

解压缩下载的php-5.2.8-Win32.zip文件，并将其复制到：X:\Server_Core\PHP ；

2）修改php.ini

进入X:\Server_Core\PHP文件夹，将php.ini-dist 重命名为 php.ini ；

打开php.ini文件，找到：

extension_dir = "./"

将其改为：

extension_dir = "X:\Server_Core\PHP\ext"

找到：Windows Extensions

在Windows Extensions下方的动态模块配置中，需要打开以下模块支持：（去掉模块配置每行前面的分号即可）

php_gd2.dll

php_mbstring.dll

php_mcrypt.dll

php_mhash.dll

php_ming.dll

php_mysql.dll

php_openssl.dll

php_sockets.dll

php_xmlrpc.dll

php_zip.dll

找到：

disable_functions =

改为：

disable_functions =passthru,exec,system,chroot,scandir,chgrp,chown,shell_exec,proc_open,proc_get_status,ini_alter,ini_alter,ini_restore,dl,pfsockopen,openlog,syslog,readlink,symlink,popepassthru,stream_socket_server

保存php.ini文件，并将其复制到C:\Windows

3、IIS与PHP的整合配置

1）建立网站

启动IIS管理器，并新建一个网站（虚拟主机）；

输入网站名称，改名称仅为IIS中的标识

网站IP地址不用填写，端口如没有特殊要求则保持80即可，最后正确输入网站域名。

在网站分区中建立wwwroot以及下级站点文件夹bbs

对于PHP应用，需要给予该站点“读取”和“运行脚本”的权限。

至此，已经成功的新建了一个站点。

2）IIS与PHP的整合配置

打开刚刚建立的网站属性

在站点属性窗口中，单击“主目录”页签，单击“配置”按钮，在新弹出的“应用程序配置”对话框中，单击“添加”按钮，加入PHP的ISAPI支持，选择可执行文件：X:\Server_Core\PHP\php5isapi.dll、扩展名为.php、限制动作为：GET,POST。单击“确定”添加，并在“应用程序配置”窗口中查看.php扩展是否加载成功。若成功，则单击“确定”关闭配置窗口，回到站点属性主窗口。

单击“文档”页签，在默认内容文档中添加index.htm、index.html、index.php三个文件，并将所有默认文档排序，顺序按照下图所示。完成后，单击“确定”，关闭站点属性配置窗口，回到IIS管理器主界面。

右键单击“Web 服务扩展”，添加PHP扩展支持。

在如下图所示的“新建WEB服务扩展”对话框中，“扩展名”填写PHP，“文件”选择X:\Server_Core\PHP\php5isapi.dll，并设置该PHP扩展默认为允许。

重启IIS服务

至此，IIS与PHP的整合已经完毕。

3）测试PHP是否安装正确

进入X:\wwwroot\bbs\目录，新建一个phpinfo.php文件，内容为：

phpinfo();

?>

打开IE浏览器，输入：http://www.domain.com/phpinfo.php；

注：www.domain.com为你的服务器域名，本机可以填写localhost

如果能够正常显示PHP支持信息则表明配置整合成功。

4、安装Zend Optimizer

进入X:\Server_Tools文件夹，双击下载的ZendOptimizer-3.2.6-Windows-i386.exe文件，安装过程非常友好，也比较简单，因而此处不再进行截图说明。但需注意以下几点：

Zend Optimzer的安装目录要指定为X:\Server_Core\Zend；

在安装过程中提示php.ini的位置是，注意观察是否为C:\Windows，如果不是必须手动指定为C:\Windows；

安装过程中提示IIS网站根目录的位置，指定为：X:\wwwroot；

Zend Optimizer安装完成后会自动重启IIS服务，重启完成后需要再次打开IE浏览器窗口，查看phpinfo.php支持信息，观察是否包含了Zend Optimizer支持信息，如果没有，则说明Zend Optimizer没有安装成功！

四、网站安全

1、独立账号运行

1）首先给IIS当前站点创建独立的运行用户

比如：web，创建方法为：

开始-运行-cmd

命令为：net user web web /add

2）将IIS当前站点的运行用户设置成web这个帐号

右键点击当前站点属性，选择目录安全性选项卡

点击“身份验证和访问控制”框内的“编辑”按钮，浏览选择web用户，填上密码web，确认后，确定退出。

2、配置网站账号权限

1）为IIS当前站点的网站根目录设置访问权限

只给sysytem，administrator，web权限，web用户权限只给 读取和运行、列出文件夹权限、读取。

2）配置程序目录权限

已经安装好Discuz!论坛程序的，还需要在IIS的当前站点中设置脚本的运行权限。

按图示分别设置目录的脚本运行权限。Discuz!7.2的具体目录为：

admin、attachments、forumdata、images、include、install、ipdata、modcp、templates、uc_client

其他产品按照这个要求：对于设置的可写目录（777属性），都设置禁止脚本运行权限。

最后，修改 php.ini 文件，将 phpinfo 函数加入到 disable_functions 中。


CentOS 5 服务器 Nginx 环境推荐教程

安装 —— CentOS 5 服务器 Nginx 环境推荐教程

一、系统约定

软件源代码包存放位置 /usr/local/src

源码包编译安装位置(prefix) /usr/local/software_name

脚本以及维护程序存放位置 /usr/local/sbin

MySQL 数据库位置 /var/lib/mysql（可按情况设置）

网站根目录 /home/www/wwwroot（可按情况设置）

虚拟主机日志根目录 /home/www/logs（可按情况设置）

运行账户 www:www

二、系统环境部署及调整

1、检查系统是否正常

# more /var/log/messages （检查有无系统级错误信息）

# dmesg （检查硬件设备是否有错误信息）

# ifconfig（检查网卡设置是否正确）

# ping www.163.com （检查网络是否正常）

# cat /proc/cpuinfo (检查CPU频率是否正常)

# top (按1检测CPU核数是否正常，内存大小是否正常)

2、关闭不需要的服务

# ntsysv

以下仅列出需要启动的服务，未列出的服务一律推荐关闭：

atd

crond

irqbalance

microcode_ctl

network

sendmail

sshd

syslog

关闭SElinux：修改/etc/selinux/config文件中的SELINUX= 为 disabled

3、更换yum国内源

# cd /etc/yum.repos.d

# mv CentOS-Base.repo CentOS-Base.repo.save

# wget http://centos.ustc.edu.cn/CentOS-Base.repo.5

# mv CentOS-Base.repo.5 CentOS-Base.repo

# yum clean all

4、服务器时间检查和设置

#data (检查时间是否正确，是否是中国时间CST)

#cp -f /usr/share/zoneinfo/Asia/Shanghai /etc/localtime (如果时区不对，则执行，时间正常的跳过)

#yum -y install ntp (安装ntp对时工具)

#chkconfig ntpd on (让对时服务开机启动)

5、使用 yum 对系统进行更新并且安装必要软件包

#yum update –y

#yum -y install make openssl openssl-devel pcre pcre-devel libpng libpng-devel libjpeg-6b libjpeg-devel-6b freetype freetype-devel gd gd-devel zlib zlib-devel gcc gcc-c++ libXpm libXpm-devel ncurses ncurses-devel libmcrypt libmcrypt-devel libxml2 libxml2-devel imake autoconf automake screen sysstat compat-libstdc++-33 curl curl-devel

6. 重新启动系统

# init 6

三、编译安装L.A.M.P环境

1、下载软件(截止到09年10月的最新版本)

# cd /usr/local/src

#wget http://sysoev.ru/nginx/nginx-0.7.63.tar.gz

#wget http://download.scientificlinux.net/nginx

#wget http://download.scientificlinux.net/php-fpm.conf

#wget http://download.scientificlinux.net/nginx.conf

#wget http://download.scientificlinux.net/fcgi.conf

#wget http://download.scientificlinux.net/php-5.2.10.tar.gz

#wget http://download.scientificlinux.net/php-5.2.10-fpm-0.5.13.diff.gz

#wget http://download.scientificlinux.net/ZendOptimizer-3.3.3-linux-glibc23-i386.tar.gz （32位系统）

#wget http://download.scientificlinux.net/ZendOptimizer-3.3.3-linux-glibc23-x86_64.tar.gz (64位系统)

#wget http://download.scientificlinux.net/mysql-5.1.39-linux-i686-glibc23.tar.gz (32位系统)

#wget http://download.scientificlinux.net/mysql-5.1.39-linux-x86_64-glibc23.tar.gz (64位系统)

2、安装MySQL

cd /usr/local/src

tar zxvf mysql-5.1.39-linux-i686-glibc23.tar.gz

mv mysql-5.1.39-linux-i686-glibc23 /usr/local/

ln -s /usr/local/mysql-5.1.39-linux-i686-glibc23/ /usr/local/mysql

groupadd mysql

useradd -g mysql mysql

chown -R mysql:mysql /usr/local/mysql

chown -R mysql:mysql /usr/local/mysql-5.1.39-linux-i686-glibc23/

cd /usr/local/mysql

./scripts/mysql_install_db --user=mysql

cp ./support-files/mysql.server /etc/rc.d/init.d/mysqld

chmod 755 /etc/rc.d/init.d/mysqld

chkconfig --add mysqld

chkconfig --level 3 mysqld on

cp ./support-files/my-huge.cnf /etc/my.cnf

mv /usr/local/mysql/data /var/lib/mysql

chown -R mysql:mysql /var/lib/mysql

编辑/etc/my.cnf

在 [mysqld] 段增加

datadir = /var/lib/mysql

skip-innodb

wait-timeout = 10

max_connections = 512

max_connect_errors = 10000000

在 [mysqld] 段修改

max_allowed_packet = 16M

thread_cache_size = CPU个数*2

将 log-bin 注释

service mysqld start

bin/mysqladmin -u root password 'password_for_root'

其中引号内的password_for_root是要设置的root密码

3、安装Nginx

cd /usr/local/src/

tar zxvf nginx-0.7.63.tar.gz

cd nginx-0.7.63

./configure --prefix=/usr/local/nginx --conf-path=/usr/local/nginx/conf/nginx.conf --with-http_realip_module --with-http_addition_module --with-http_gzip_static_module --with-http_random_index_module --with-http_stub_status_module --with-http_sub_module --with-http_dav_module

make

make install

cp /usr/local/src/nginx /etc/init.d/nginx

chmod 755 /etc/init.d/nginx

chkconfig --add nginx

chkconfig nginx on

4、安装PHP和Zend

cd /usr/local/src

tar zxvf php-5.2.10.tar.gz

gzip -cd php-5.2.10-fpm-0.5.13.diff.gz | patch -d php-5.2.10 -p1

cd php-5.2.10

./configure --prefix=/usr/local/php5 --with-config-file-path=/usr/local/etc/cgi --enable-mbstring --enable-ftp --with-gd --with-jpeg-dir=/usr --with-png-dir=/usr --enable-magic-quotes --with-mysql=/usr/local/mysql --with-pear --enable-sockets --with-ttf --with-freetype-dir=/usr --enable-gd-native-ttf --with-zlib --enable-sysvsem --enable-sysvshm --with-libxml-dir=/usr --enable-force-cgi-redirect --enable-fastcgi --with-xmlrpc --enable-zip --enable-fpm

make

make install

mkdir -p /usr/local/etc/cgi/

cp php.ini-dist /usr/local/etc/cgi/php.ini

编辑/usr/local/etc/cgi/php.ini

找到disable_functions =这行，在=号后面加上exec,system,passthru,shell_exec,escapeshellarg,escapeshellcmd,proc_close,proc_open,dl,popen,show_source

找到; cgi.fix_pathinfo=0这行去掉前面;号，如果这行=号后面不是0，则修改成0

mv -f /usr/local/src/php-fpm.conf /usr/local/php5/etc/php-fpm.conf

groupadd www

useradd -g www www

echo 'ulimit -SHn 65535' >> /etc/rc.local

echo '/usr/local/php5/sbin/php-fpm start' >> /etc/rc.local

cd /usr/local/src

tar zxvf ZendOptimizer-3.3.3-linux-glibc23-i386.tar.gz

cd ZendOptimizer-3.3.3-linux-glibc23-i386

./install

(注意第一个要填的路径是Zend安装路径，第二个是php.ini所在的路径，即/usr/local/etc/cgi)

(不要选重启apache)

5、启动Nginx和php

mv -f /usr/local/src/fcgi.conf /usr/local/nginx/conf/

cp -f /usr/local/src/nginx.conf /usr/local/nginx/conf/nginx.conf

mkdir -p /home/www/wwwroot

ulimit -SHn 65535

/usr/local/php5/sbin/php-fpm start

service nginx start

在/home/www/wwwroot放入一个index.php，内容为

打开浏览器访问，即可看到phpinfo页面

6、设置系统防火墙

编辑/usr/local/sbin/fw.sh

复制以下内容进去

#!/bin/bash

# Stop iptables service first

service iptables stop

# Load FTP Kernel modules

/sbin/modprobe ip_conntrack_ftp

/sbin/modprobe ip_nat_ftp

# Inital chains default policy

/sbin/iptables -F -t filter

/sbin/iptables -P INPUT DROP

/sbin/iptables -P OUTPUT ACCEPT

# Enable Native Network Transfer

/sbin/iptables -A INPUT -i lo -j ACCEPT

# Accept Established Connections

/sbin/iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT

# ICMP Control

/sbin/iptables -A INPUT -p icmp -m limit --limit 1/s --limit-burst 10 -j ACCEPT

# WWW Service

/sbin/iptables -A INPUT -p tcp --dport 80 -j ACCEPT

# FTP Service

/sbin/iptables -A INPUT -p tcp --dport 21 -j ACCEPT

# SSH Service

/sbin/iptables -A INPUT -p tcp --dport 22 -j ACCEPT

退出编辑，执行以下命令

# chmod 755 /usr/local/sbin/fw.sh

# echo '/usr/local/sbin/fw.sh' >> /etc/rc.local

# /usr/local/sbin/fw.sh


Discuz! X1 安装说明

安装 —— Discuz! X1 安装说明

Crossday Discuz! Board（以下简称 Discuz!，中国国家版权局著作权登记号 2008SR11708）是康盛创想(北京)科技有限公司（英文简称Comsenz）推出的一套通用的社区论坛软件系统。作为国内最大的社区软件及服务提供商，Comsenz旗下的 Discuz! 产品，无论在功能、稳定性、负载能力、安全保障等方面都居于国内外同类产品领先地位，是全球成熟度最高、覆盖率最大的论坛软件系统之一。

说明：本文档用于帮助您全新安装完整的 Discuz! X 社区软件。

一、下载 Discuz! X 官方版到本地或者服务器上

下载地址：http://www.comsenz.com/downloads/install/discuzx#down_open

二、解压并上传 Discuz! X 程序到服务器且修改相应目录权限

1、上传 Discuz! X1 Beta 程序到服务器上

解压缩得到如下图所示的三个文件：

upload 这个目录下面的所有文件是我们需要上传到服务器上的可用程序文件；

readme 目录为产品介绍、授权、安装、升级、转换以及版本更新日志说明；

utility 目录为论坛附带工具，包括升级程序。

将其中 upload 目录下的所有文件使用 FTP 软件以二进制方式（常见 FTP 软件二进制的设置方法http://faq.comsenz.com/viewnews-373）上传到空间。如下图所示：

2、设置相关目录的文件属性，以便数据文件可以被程序正确读写

使用 FTP 软件登录您的服务器，将服务器上以下目录、以及该目录下面的所有文件的属性设置为 777，Win 主机请设置 internet 来宾帐户可读写属性。

./config/config_global.php

./config/config_ucenter.php

./config

./data

./data/avatar

./data/imagecache

./data/plugindata

./data/sysdata

./data/request

./data/template

./data/threadcache

./data/attachment

./data/attachment/album

./data/attachment/forum

./data/attachment/group

./data/log

./uc_client/data/cache

./uc_server/data/

./uc_server/data/cache

./uc_server/data/avatar

./uc_server/data/backup

./uc_server/data/logs

./uc_server/data/tmp

./uc_server/data/view

关于目录权限修改可以参考：http://faq.comsenz.com/viewnews-183

三、安装过程

上传完毕后，开始安装 Discuz! X 社区软件，在浏览器中运行 http://www.domain.com/install/ 开始全新安装（其中 http://www.domain.com 为你的站点访问地址）

阅读授权协议后点击“我同意”，系统会自动检查环境及文件目录权限，如下图所示：

检测成功，点击“下一步”，即进入检测服务器环境以及设置 UCenter 界面，如下图所示：

可以选择全新安装 Discuz! X (含 Ucenter Server)或者仅安装 Discuz! X (手工指定已经安装的 Ucenter Server)

如果选择手工指定已经安装的 UCenter Server 的话，您的 UCenter 是1.5版本的话，需要对 UCenter1.5 升级到 UCenter 1.5.1 版本，使用 Discuz! X 里面的 uc_server/ 目录覆盖您以前的 UC Server 目录即可。

建议您选择全新安装 Discuz! X，即连 UCenter 一起安装，如果您之前已经安装好 UCenter 1.5.1 版本可以选择仅安装 Discuz! X。这里以全新安装 Discuz! X 为例。

点击“下一步”，进入安装数据库的界面，如下图所示：

填写好 Discuz! X 数据库信息及管理员信息。

附加数据：为测试数据，可以不选择安装，主要是演示专题和完整地区数据。点击“下一步”，系统会自动安装数据库直至完毕，如下图所示：

安装成功后，会出现如下的界面：

填写好联系方式后点击“提交”，也可以点击“跳过本步”直接完成安装。

安装完毕后进入 Discuz! X 首页查看网站：

至此，Discuz! X 已经成功地安装完毕！您可以登录 Discuz! X 站点并开始设置了。


升级/转换

Discuz! 升级相关

  • Discuz! X1 Beta到Discuz! X1
  • Discuz!7.2/UCHome2.0/SupeSite7.5到Discuz!X1
返回主目录


Discuz! X1 Beta到Discuz! X1 升级说明

升级 —— Discuz! X1 Beta到Discuz! X1 升级说明

说明：本文档用于帮助您将原有的 Discuz! X1 Beta 版本升级到 Discuz! X1 正式版本。

在您开始升级之前，请务必逐条仔细阅读以下的注意事项：

1、升级之前，为了确保无误，强烈建议您备份原有数据，我们无法对升级前没有备份的用户提供任何技术支持

2、升级程序放置在发行版本的 utility/update.php，此程序需要上传到 install 目录中，并确保 install/data 中的 sql 文件完整。

3、升级到 Discuz! X 正式版本中您在 Discuz! X1 Beta 安装的某些插件或者模板数据需要您自行升级

4、升级成功后，请您删除 update.php 程序，以避免可能的安全问题

一、升级前的准备

1、下载 Discuz! X1 官方版到本地或者服务器上

下载地址：http://www.comsenz.com/downloads/install/discuzx#down_open

解压缩得到如下图所示的三个文件：

upload 这个目录下面的所有文件是我们需要上传到服务器上的可用程序文件；

readme 目录为产品介绍、授权、安装、升级、转换以及版本更新日志说明；

utility 目录为论坛附带工具，升级程序存放在 utility/update.php。

2、关闭站点

用管理员登录站点后台 => 全局 => 站点信息 => 论坛关闭：选择“是”，如图：

3、备份数据

1）站点程序及其附件的备份

推荐您把站点目录下的所有目录和文件下载或者拷贝到你要备份的地方。

我们常用的对站点程序及其附件的备份方法为：在原站点根目录下新建一个目录 oldX1，然后把所有文件全部备份一份到 oldX1 目录中。

2）数据库备份

独立主机直接到 MySQL 的 data 目录拷贝一份当前 Discuz! X1 Beta 版本使用的数据库即可，记得拷贝之前停止 MySQL 服务，否则会造成备份数据的损坏。

虚拟主机用户推荐直接在站点后台进行备份，用管理员登录 Discuz! X1 Beta 后台 => 站长 => 数据库 => 备份：推荐备份“站点全部数据”，如图：

如果要对备份数据再做其他要求可以点击上图中的“更多选项”根据需要进行选择：

4、上传 Discuz! X1 程序到您的站点目录覆盖旧程序。

二、升级站点数据（以虚拟主机上的升级步骤做演示）

1、上传 utilities 目录中的 update.php 文件到 install 目录中，并确保 install/data 中的 sql 文件完整目录下。

2、在浏览器中运行 http://www.domain.com/install/update.php 开始升级（其中 http://www.domain.com 为你的站点访问地址）

点击“准备完毕，升级开始”链接进行升级。

3、

升级过程全部为自动，无需人工操作，您只要耐心等待就可以了。

4、数据库结构删除

您可以选择删除与标准数据库相比是多余的的数据表和字段，这里特别要说明的是：pre_ucenter开头的表是不可以删除的，如果删除的话站点就无法访问了。其它的表和字段可以删除，您也可以忽略多余的表和字段。

5、完成升级

点击“直接进入下一步”即可完成升级，如下图所示：

升级/转换过程全部为自动，无需人工操作，请您耐心等待。

三、升级后的善后操作

1、使用创始人帐号登录，进入后台更新缓存。

2、删除 install/update.php 程序，以免给您的站点带来隐患。


Discuz!7.2/UCHome2.0/SupeSite7.5到Discuz! X1 正式版本升级/转换说明

说明：本文档用于帮助您将原有社区产品升级或者转换到 Discuz! X1 正式版本。

在您开始升级/转换之前，请务必逐条仔细阅读以下的注意事项：

1、升级之前，为了确保无误，强烈建议您备份原有数据，我们无法对升级前没有备份的用户提供任何技术支持

2、通常情况下，我们的升级程序放置在发行版本的 ./utilities/convert 目录中，此程序可以独立于产品运行

3、我们不能保障升级或者转换到 Discuz! X 产品当中所有的数据都是有效的，某些插件或者自行开发的功能数据需要您自行转换

4、大多数情况下，您升级到 Discuz! X 产品以后，需要进入后台进行一系列重新设置，否则某些功能可能无法正常使用。

5、 除非有特殊的声明，我们的转换程序不会改变您原有的数据格式和设置，他会将原有数据重新复制一份，并做格式转换。所以，在转换开始之前，您应当检查您的数据库存储空间是否够用。假设您原有数据是 100M，您至少需要 110M 以上的数据剩余空间，否则可能无法转换成功。

6、升级成功后，请您删除 convert 程序，以避免可能的安全问题。

一、升级前的准备

1、下载 Discuz! X1 正式官方版到本地或者服务器上

下载地址：http://www.comsenz.com/downloads/install/discuzx#down_open

解压缩得到如下图所示的三个文件：

upload 这个目录下面的所有文件是我们需要上传到服务器上的可用程序文件；

readme 目录为产品介绍、授权、安装、升级、转换以及版本更新日志说明；

utility 目录为论坛附带工具，我们这次升级程序存放在 ./utilities/convert 目录中此程序可以独立于产品运行。

2、进入您原来的系统，关闭您的站点。

1）关闭论坛

用管理员登录论坛后台 => 全局 => 站点信息 => 论坛关闭：选择“是”，如图：

2）关闭UCHome

用管理员登录 UCHome 后台 => 基本设置 => 站点信息 => 站点关闭访问：选择“是”，如图：

3）关闭SupeSite

用管理员登录 SupeSite 后台 => 系统管理 => 系统设置 => 暂时关闭站点 => 选择站点关闭，如图：

3、备份数据

1）论坛程序及其附件的备份

推荐您把论坛目录下的所有目录和文件下载或者拷贝到你要备份的地方，如果您没有对论坛程序和模板做过很大的改动，那么只要备份 attachments （附件目录）就可以了。

我们常用的对论坛程序及其附件的备份方法为：在原论坛根目录下新建一个目录 oldbbs，然后把所有文件全部移动到 oldbbs 目录中。

2）UCHome程序及其附件的备份

推荐您把 UCHome 目录下的所有目录和文件下载或者拷贝到你要备份的地方，如 oldhome。

3）SupeSite程序及其附件的备份

推荐您把 SupeSite 目录下的所有目录和文件下载或者拷贝到你要备份的地方，如 oldss。

4）数据库备份

可以单独备份各个应用的数据，也可以直接在 UCenter 后台备份所有应用的数据，单独备份以论坛为例：

独立主机直接到 MySQL 的 data 目录拷贝一份当前 Discuz! 使用的数据库即可，记得拷贝之前停止 MySQL 服务，否则会造成备份数据的损坏。

虚拟主机用户推荐直接在论坛后台进行备份，用管理员登录论坛后台 => 工具 => 数据库 => 备份：推荐备份“论坛全部数据”，如图：

如果要对备份数据再做其他要求可以点击上图中的“更多选项”根据需要进行选择：

在 UCenter 后台对所有数据进行备份，如果是独立主机直接到 MySQL 的 data 目录分别拷贝一份当前所有应用使用的数据库即可，记得拷贝之前停止 MySQL 服务，否则会造成备份数据的损坏。

虚拟主机用户登录 UCenter 后台 => 数据备份，如下图所示：

4、上传 Discuz! X1 程序到您的站点目录。

5、正确安装 Discuz!X （如果您的 UCenter Server 是独立安装的，您需要提供他的访问路径和创始人密码）也可以全新安装。

全部安装图文教程 如果全新安装的话需要把之前的 UCenter 数据导入到现在的 UCenter 数据库中。

二、升级数据（以虚拟主机上的升级步骤做演示）

1、上传 utilities 目录中的 convert 程序到您的站点。

2、在浏览器中运行 http://www.domain.com/convert 开始升级/转换（其中 http://www.domain.com 为你的论坛访问地址）

3、选择产品转换程序，convert 程序当中集成了多种程序可以转换到 Discuz! X，请您根据系统进行选择。

注意：如果有 Discuz! 和 UChome 同时需要升级，请务必先升级 Discuz!论坛，我们先升级 Discuz! ，点击修改，对要升级的数据库信息进行设置，如下图所示

3.1 设置服务器信息

数据源服务器设置 (原始版本的数据库)：可以对照之前版本的 config.inc.php 文件中的数据库信息进行填写

目标服务器设置 (已正确安装 Discuz! X 的数据库)：填写刚刚安装好的 Discuz! X 的数据库信息。

填写完成后，点击“保存服务器设置”。

3.2、配置转换过程

默认全选即可

3.3、执行数据转换

升级/转换过程全部为自动，无需人工操作，请您耐心等待。

3.4、转换完成

会提示您本次升级开始时间和升级结束时间以及升级累计执行时间，如果数据较少，升级是比较快的。升级/转换完成后如下图所示：

4、升级 UCHome

特别警示：

由于UCHome与Discuz!部分功能进行了整合性融合，因此UCHome的部分功能，在整合到Discuz! X后将会部分丢失；

其中包括：

由于新增专题功能，原UCH热闹功能将不再支持；

UCH 投票、UCH 活动将与论坛投票贴、活动贴的形式融合为一体，活动相册、活动群组功能将不再支持；

UCH 群组将以新的群组功能存在，原群组相册、群组活动功能将不再支持；

个人资料进行了新的调整，UCH 原个人资料中的学校、工作信息将需要重新填写；

UCH 的全站实名功能不再支持；

请根据自己建站需求，权衡决定是否将 UCHome 转换升级到Discuz! X。

点击 UCenter Home 2.0 右侧的“开始”链接，进行数据库的配置。

数据源服务器设置 (原始版本的数据库)：可以对照之前版本的 config.php 文件中的数据库信息进行填写

目标服务器设置 (已正确安装 Discuz! X 的数据库)：填写刚刚安装好的 Discuz! X 的数据库信息。

填写完成后，点击“保存服务器设置”。

4.1、配置转换过程

默认全选即可，点击“开始转换”。

4.2、执行数据转换

用户组配置：这里对应列出了UCHome 中的用户组转到 Discuz! X 的用户组，可以根据自己站点的情况进行选择。

积分配置：来源积分指的是 UCHome 中的积分，目标积分指的是转到 Discuz! X 对应的积分下，比如 UCHome 中的积分对应Discuz! X 中的金钱，这里站长可以根据自己站点的情况进行自由选择。

数据转换配置：源数据包括投票和活动，转到 Discuz! X 对应的版块下面。

设置完成并保存后，开始自动转换，如下图所示：

4.3、转换完成

会提示您本次升级开始时间和升级结束时间以及升级累计执行时间

5、升级 SupeSite

特别警示：

Discuz! X1 中并未具备 SupeSite 7.5 中的全部功能，此转换程序，仅转换SupeSite 7.5中的资讯分类、资讯文章数据到 Discuz! X 产品的文章系统中。其他数据将不进行转换。因此，数据转换后，Discuz! X 产品存在原有 SupeSite 功能丢失和数据丢失问题，请自行权衡决定是否转换升级。

点击 SupeSite 7.5 右侧的“开始”链接，进行数据库的配置。

数据源服务器设置 (原始版本的数据库)：可以对照之前版本的 config.php 文件中的数据库信息进行填写

目标服务器设置 (已正确安装 Discuz! X 的数据库)：填写刚刚安装好的 Discuz! X 的数据库信息。

填写完成后，点击“保存服务器设置”。

5.1、配置转换过程

默认全选即可，点击“开始转换”。

5.2、执行数据转换

开始自动转换，无需人工干预。

5.3、转换完成

会提示您本次升级开始时间和升级结束时间以及升级累计执行时间

三、升级后的一些善后操作

论坛的善后操作：

1、编辑新论坛的 config/config_global.php 文件，设定好创始人

2、直接访问新论坛的 admin.php

3、使用创始人帐号登录，进入后台更新缓存

4、新系统增加了很多设置项目，包括用户权限、组权限、论坛板块等等，您需要仔细的重新设置一次

5、转移旧附件目录（在转移之前，您的帖子将会无法找到任何附件）

a)进入 old/attachments/ 目录

b)将所有文件移动到 新论坛目录/data/attachment/forum/ 目录中

6、转移用户头像（独立安装 UCenter 的用户不需要这个步骤）

a)进入 old/uc_server/data/avatar/ 目录

b)将所有文件移动到 新论坛目录 uc_server/data/avatar/

7、删除 convert 程序，以免给您的论坛安装带来隐患

8、待测试新论坛的所有功能均正常后，可以删除旧的程序备份和数据备份

9、如果使用过分类信息，需要重新整理一次分类信息（后台->更新统计->分类信息整理）。

UCHome的善后操作：

1、编辑新Discuz! X的 config/config_global.php 文件，设定好创始人

2、直接访问新Discuz! X的 admin.php

3、使用创始人帐号登录，进入后台更新缓存

4、新系统增加了很多设置项目，包括用户权限、组权限、论坛板块等等，您需要仔细的重新设置一次。

5、转移旧附件目录到新产品根目录（在转移之前，您的动态、日志、评论、留言等内容中的图片无法正常显示）

a)进入 old/attachment 目录

b)将所有文件移动到 新Discuz! X产品 /data/attachment/album/ 目录中

c)同时，修改一下 Discuz! X的代码

让日志内容中的已经插入的图片地址，通过字符串替换，改为最新的图片地址，解决日志内容图片无法显示的问题。

方法如下：

打开Discuz! X的 ./source/include/space/space_blog.php 程序

找到：

$blog['message'] = blog_bbcode($blog['message']);

在下面增加一行代码：

SupeSite的善后操作：

1、编辑新Discuz! X 的 config/config_global.php 文件，设定好创始人

2、直接访问新 Discuz! X 的 admin.php

3、使用创始人帐号登录，进入后台更新缓存

4、新系统增加了很多设置项目，包括用户权限、组权限、论坛板块等等，您需要仔细的重新设置一次。

5、转移旧附件目录到新产品根目录（在转移之前，您的资讯内容中的图片无法正常显示）

a)将 old/attachments 目录和目录下的文件 全部移动到 新 Discuz! X 产品的根目录中

6、转移旧图片目录到新产品根目录（在转移之前，您的资讯内容中的表情无法正常显示）

a)将 old/images 目录和目录下的文件 移动到 新Discuz! X产品的根目录中

7、删除 convert 程序，以免给您的 Discuz! X安装带来隐患。


前台使用

Discuz! X1 前台使用

  • 门户
  • 门户管理
  • 广场
  • 群组
  • 家园
返回主目录


Discuz! X1 前台使用 — 门户

如何 DIY：门户是整合站点精品信息并以一个统一的界面展示的信息平台，是一个网站的门面。通过门户展示的内容可以让用户了解网站的风格，定位，并进一步点击链接访问网站更多内容。通过门户功能可以发布文章资讯，通过模块可以聚合包括会员、帖子、日志、图片、附件等各类站内信息。


如何DIY

门户 —— 如何DIY

论坛的帖子、UCHome 的日志，都可以直接推送到门户的文章库里面。Disucz! X1 的门户系统灵活而强大，站长可以通过 DIY 功能聚合网站包括会员，帖子，日志、图片等信息，并以多种样式展示；也可以自己发布文章，管理资讯频道；还可以通过 DIY 功能将有相同主题的内容聚合在一个专题页面。

下面我们主要讲解如何使用 DIY 功能。

DIY自己的首页，建立框架是第一步。

一、tab框架

1、在 DIY 页面下，点击框架，选择 tab 框架，如下图所示：

2、选中 tab 框架，按住鼠标，把 tab 框架拖到要加入框架的位置，如下图所示：

3、添加好tab框架之后，点击编辑 => 标题，编辑框架标题的属性，如下图所示：

4、点击编辑 => 样式，编辑背景和边框的属性，如下图所示：

至此一个tab框架就添加好了，可以继续添加模块，自定义设置完善框架。

tab 框架的效果，如下图所示：

二、1:1:1框架

1、在 DIY 页面下，点击框架，选择 1:1:1 框架，如下图所示：

2、选中1:1:1框架，按住鼠标，把1:1:1框架拖到要加入框架的位置，如下图所示：

3、添加好1:1:1框架之后，点击编辑 => 标题，编辑框架标题的属性，如下图所示：

4、点击编辑 => 样式，编辑背景和边框的属性，如下图所示：

5、至此一个1:1:1框架就添加好了，可以继续添加模块，自定义设置完善框架。

1:1:1框架的效果，如下图所示：

三、框架嵌套

DIY 页面提供了100%框架，1:1 框架，1:2 框架，2:1 框架，1:3 框架，3:1 框架，1:1:1 框架，tab 框架，8 中框架种类，可以通过框架的嵌套，可以更好的设计出个性化的专题。

本例中，建立了一个 3:1 框架，在 3:1 框架3的部分中添加了一个 1:1 框架，在 3:1 框架 1 的部分中添加了一个专题类模块，然后在 1:1 框架中添加了图片类模块和会员类模块。建立之后的效果，如下图所示：

添加了框架之后，还需要添加模块，让整个专题栏目显示的更加完善，内容也更加丰富。

四、模块的使用

本例中在 1:1:1 框架中添加模块

打开专题 DIY 页面，点击模块，选择帖子类模块，按住鼠标，将模块拖到要放置模块的位置，如下图所示：

1、编辑模块标题：

点击模块右侧的编辑 => 标题，如下图所示：

出现如下图所示的内容，填写相关内容，确定即可：

模块标题：输入要显示的模块标题，如：最新帖子。

链接：输入点击模块名称要跳转的链接地址，如http://localhost/dzx/forum.php

图片：输入显示在模块名称前面的模块图标地址，如：./static/image/common/star_level1.gif

位置：设置模块名称的显示位置，偏左或偏右

偏移量：设置模块名称显示位置的偏移量

字体：设置模块名称字体显示的大小

颜色：设置模块名称的字体颜色

背景图片：输入显示在模块名称处的图片地址，如./static/image/common/star_level1.gif

背景颜色：设置模块名称位置的背景颜色

设置后的效果，如下图所示：

2、编辑背景和边框属性

点击模块右侧的编辑 => 样式，如下图所示：

出现如下图所示的内容，填写相关内容，确定即可

链接：设置模块中的内容的字体大小

边框：设置模块边框的粗细，样式和颜色

外边距：设置边框的外边距

内边距：设置边框的内边距

背景颜色：设置模块的背景颜色

背景图片：输入模块背景的地址，如：./static/image/common/star_level1.gif

指定class：输入自己编写的样式名称，如 pbnv

这样一个模块就建立好了，可以用同样的方法添加更多的模块，设置后的效果如下图所示：


Discuz! X1 前台使用 — 门户管理

发布文章：可以通过前台的门户管理直接发布资讯。资讯可以让站点的内容变的更加充实饱满，资讯数量较多的站点也是吸引会员的一个重要因素，同时也可以增加站点中的人气。

管理文章：有些文章发布完了以后，需要进行编辑、删除、推送等操作，可以在门户管理中直接操作。

模块管理：DIY 站点首页的时候，可以增加各类想调用的模块，然后可以对这些模块进行管理。


发布文章

门户管理 —— 发布文章

默认情况下站点管理员可以在门户管理中直接发布，普通会员需要在后台添加发布文章的权限，位置是：

Discuz! X管理后台 => 用户组 => 会员用户组 => 选择允许发布文章的用户组，点编辑 => 门户相关 => 发布文章 => 选择“是”即可。

管理员也可以在后台 => 门户 => 文章分类 => 在相应的分类下直接发布文章。 发布文章的同时也可以上传附件，上传完毕后，需要插入到文章内容中才可以显示。

自动获取：这里可以输入帖子 tid 号或者日志的 tid 号直接获取之前在广场发布的帖子和在空间发布的日志。

文章来源：这里可以手动输入文章来源于哪里。

跳转URL：这里可以输入文章跳转的URL地址。

来源地址：比如填写了文章来源后，可以在这里输入来源的地址。

原作者：填写文章的原作者。

封面图片：这里可以上传文章的封面图片。

摘要：简单说明该文章的摘要。

添加相关文章ID ：这里可以添加和这篇文章内容相关的文章的 id 号。

文章发表后在首页的显示效果如下图所示：


管理文章

门户管理 —— 管理文章

点击首页的门户管理，即可对文章进行管理，如下图所示：

说明：要在后台设置好权限才可以对这里的文章进行管理，具体位置在：Discuz! X管理后台 => 用户 => 用户组或者管理组里，找到要开启这个权限的用户组，编辑权限，门户管理权限，允许管理文章：选择“是”即可。

这里可以对单独某一篇或者某几篇文章进行管理，也可以进行批量管理。

1、放入回收站

即不直接删除，而是放入到回收站中，好处是如果是误删除了，还可以还原。

2、直接删除

该操作不可恢复，可以彻底将所选择的文章进行直接删除操作。

3、推送

可以把选择的文章推送到某一模块下，如下图所示：


模块管理

门户管理 —— 模块管理

点击首页的门户管理，即可对模块进行管理，如下图所示：

这里需要注意的是，模块管理权限需要在后台进行开启，具体位置在：Discuz! X管理后台 => 用户 => 用户组或者管理组里，找到要开启这个权限的用户组，编辑权限，门户管理权限，允许管理文章：选择“是”、允许创建专题：选择“是”、允许管理专题：选择“是”、允许DIY选择“是”即可。

功能的使用：

一、模块属性

可以点击模块后面的属性，修改模块的属性和数据，如下图所示：

以活跃群组的模块为例进行介绍：

自定义内容：可以点击“编辑”填写这个模块的自定义内容，填写完成后，可以点击模块后面的查看来查看效果，如下图所示：

模块标识：指的是 DIY 添加模块的时候，该模块的标识名。#84 类似这样的名称为系统自动生成的模块名。

数据来源：根据所选择的模块不同，数据来源也是不相同的，比如活跃群组，数据来源分为：最新群组、热门群组、指定群组和高级自定义。

群组类别：这里会显示所有群组的分类，可以指定选择某一个或者某几个分类。

指定群组：这里可以填写指定群组的名称。

设置群组名称最大长度：默认为 80 个字节。

介绍长度：默认为 255 个字节。

群组排序方式：选择群组的排序方式，分别为按默认顺序、按话题数倒序、按总发贴数倒序、按今日发贴数倒序、按成员数倒序、按创建时间倒序、按等级倒序、按共同积分倒序和按活跃度倒序，您可以选择自己想要的排序方式进行排序。

显示条数：指该模块的调用总共显示多少条数据。

数据缓存更新：选择该模块数据的缓存时间，可以选择 10 分钟、30分钟、1小时、12小时、一天、一周、一月，如果不想更新缓存，直接选择不更新。

显示样式：有 12 种样式可供选择。

模块标识：即填写该模块的标识。

二、模块数据

可以点击模块后面的数据，添加和编辑模块的数据，如下图所示：

1、添加数据

同样以活跃群组的模块为例进行介绍：

从数据源获取：这里按默认就可以。

显示位置：只在模块调用中的显示位置，也可以固定显示的位置。

开始时间：格式类似 2010-6-7 13:52 留空表示立即开始。

失效时间：填写的格式同上，留空表示不失效。

群主链接：填写群主的链接地址，如：forum.php?mod=group&fid=22

群组名称：填写群组的名称。

群组图片：可以选择远程图片，填写图片的地址或者直接选择上传图片。

群组介绍：填写群组的介绍。

群组图标：填写群组的图标地址，如：static/image/common/nophoto.gif

创始人：填写创始人用户名称。

创始人UID：填写创始人的 UID 号。

总发贴数：填写群组的总发帖数。

今日发贴数：填写群组的今日发贴数。

总话题数：群组的总话题数量。

成员数：群组的成员数量。

创建时间：填写群组的创建时间。

群组等级：填写群组的等级也可以留空。

群组公共积分：填写群组的公共积分。

群组活跃度：填写群组活跃度，也可以不填。

2、编辑数据

直接点击模块右方的编辑按扭即可对该模块进行编辑，编辑后提交即可。

3、删除数据

可以直接点击模块右方的删除按扭删除已经添加好的数据。如下图所示：

4、屏蔽数据

直接点击模块右方的屏蔽按扭可以屏蔽现有的数据。


Discuz! X1 前台使用 — 广场

主题和帖子管理：主要包括主题管理中的删除、升降、置顶、高亮、精华、鉴定、开关、移动、分类、复制、合并、分割、修复和帖子管理中的警告、屏蔽、删除、置顶。

版主管理界面：把版主等管理人员的管理权限及管理选项集中到一起，使其对站点的内容进行管理时，操作更集中和便捷。 。

如何使用框架：DIY 广场页面，添加框架是第一步。只有拥有 DIY 权限的管理组才能进行此操作。

如何使用模块：在 DIY 广场页面时，添加了框架之后，还需要添加模块，让整个框架显示的更加完善，内容也更加丰富。

如何将论坛帖子、群组话题推送到首页：将论坛帖子，群组话题推送到首页，可以让会员在首页就能快速的浏览到更多的内容。


广场 —— 主题和帖子管理

主题管理可以在帖子列表页和帖子内容页分别操作：

帖子列表页的操作：

帖子内容页的操作：

帖子管理可以在用户帖子的右下方进行操作：

下面分别介绍各个操作：

一、主题管理

1、删除主题

删除主题时，如要填写删除理由，可以选择已有的理由，也可以自定义填写，然后点击“确定”删除主题。

2、升降主题

提升主题：可以将主题提升到主题列表前面，方便大家看到；下沉主题：可以下沉某些早期的帖子。

3、置顶主题

通过置顶主题，可以使重要主题更加醒目，提高主题的关注度。

可选择置顶类型和置顶有效期。本版置顶：只在本版块置顶位置显示；分类置顶：在该分类下的所有版块置顶显示；全局置顶：在论坛全部版块置顶显示。

4、高亮主题

高亮主题，可以使得该主题更加醒目，提高阅读率。高亮选项可选高亮颜色、字体和高亮有效期。

5、精华主题

对于精彩的帖子，可以设置其为精华帖子，对帖子的作者而言是一种鼓励，并且能更好的推广优秀帖子。设置精华主题可选三种精华级别及设置有效期。

6、鉴定主题

可以根据主题内容给予该主题鉴定图章，比如：精华帖，优秀帖，爆料贴等。使得会员对该主题有一目了然的了解。经过鉴定的主题会在帖子的右上方显示鉴定图章。

7、开关主题

当一个主题已经没有讨论意义的时候，管理员可以选择手动关闭主题，时间上可以永久关闭或选定有效期关闭。主题被关闭后，将不能再被回复；同样，如果需要继续讨论时，可以选择打开该主题。

8、移动主题

当帖子发错版块时，可以通过移动主题来进行正确归类。移动主题有直接移动和保留转向两种选择，直接移动，则帖子被移动到新版块中，原版块中不留痕迹；若保留转向，则会在原版块中保留一个移动标记，会员在原版块中同样可以通过点击移动标记访问到被移动到新版块中的帖子。

9、分类主题

当版块中开启了主题分类后，对于分类错误的主题可以对其进行重新分类。

10、复制主题

如果需要重复发表相同的主题，可以采用复制主题的方式，将主题快速复制到其他版块。

11、合并主题

如果两个主题有相似的内容，为了统一讨论，可以对主题进行合并，合并后，两个主题将成为一个主题。

12、分割主题

可以将一个主题分割成两个或更多主题，前提是该主题有回复。

13、修复主题

当查看某个帖子的时，发现这个帖子有问题或是回复打不开等等一些情况，可以通过“修复主题”功能使该主题恢复正常。

二、帖子管理

1、警告帖子

当帖子里有不符合要求的内容时，可以对该帖子进行警告，被警告的帖子会在或上方显示警告图标。

2、屏蔽帖子

当帖子中含有敏感内容时，可以通过屏蔽的方式隐藏该帖的内容，被屏蔽的内容只有版主级别以上的管理人员可以查看，普通会员查看时，只会显示“该帖被管理员或版主屏蔽”。

3、删除帖子

删除回帖，操作同删除主题.

4、置顶帖子

此顶置顶不同于主题置顶，如果将回帖置顶，该回帖将会显示在主题帖的下方的“回帖推荐”处。


版主管理界面

广场 —— 版主管理界面

Discuz! X1 中，版主级别以上的管理人员，都可以由版块上方的管理面板按钮进入到前台的版主管理界面。

版主管理面板，把版主等管理人员的管理权限及管理选项集中到一起，使其对站点的内容进行管理时，操作更集中和便捷。其中的管理选项操作和在站点的其他地方单独操作某选项时，结果是一样的。

如图所示，管理面板左侧为对帖子和管理，包括管理主题、帖子和主题回收站中的帖子；右侧为根据管理人员的管理权限显示的管理选项，以站点的管理员为例，选项就包括内部留言、审核、禁止用户、禁止IP、用户权限、编辑用户、主题管理、推荐主题、版块编辑、公告、管理日志、管理统计等。

各管理选项的含义：

1、内部留言：给管理员、版主或超级版主留言；

2、审核：审核管辖范围内的主题；

3、禁止用户：禁止违规用户；

4、禁止IP：禁止违规用户的IP；

5、用户权限：设置用户在某一版块内的权限；

6、编辑用户：修改用户头像，修改用户个人签名或个人介绍；

7、主题管理：对站点内的帖子进行管理；

8、推荐主题：推荐管理范围内的优秀主题，以提高该主题的阅读率；

9、版块编辑：编辑管辖版块的版块介绍和版块规则；

10、公告：添加论坛公告；

11、管理日志：查看论坛管理日志；

12、管理统计：查看管理人员的管理记录；


如何使用框架

广场 —— 如何使用框架

一、添加框架

1、点击在广场页面右上方的 DIY 按钮，如下图所示：

2、点击框架，选择一个自己想要插入的框架的样式(默认有 100% 框架，1:1，1:2，2:1,1:3,3:1，1:1:1，tab 框架，共八种框架可以选择)。如下图所示：

3、用鼠标按住要插入的框架类型，拖到想要插入的地方，松开鼠标，即可看到框架已经被插入到相应的位置。如下图所示：

二、编辑框架：

1、点击框架右侧的编辑 => 标题，如下图所示：

1)框架标题：设置的此框架的标题。

2)链接：设置点击此框架名要跳转到的页面地址。

3)图片：设置显示在框架标题处的图片地址。如 http://localhost/dzx/static/image/common/bg_doing_ico.jpg

4)位置：设置框架标题的显示位置(偏左或偏右)，偏移量可以自己设置。

5)字体：设置框架标题的字体大小及颜色。

6)背景图片：设置框架标题处的背景图片地址及平铺样式。如 http://localhost/dzx/static/image/common/bg_doing_ico.jpg

7)背景颜色：设置框架标题处的背景颜色。

2、点击框架右侧的编辑 => 样式，如下图所示：

1)字体：设置整个框架的下模块区域的大小

2)链接：设置框架下添加的模块中显示的内容标题的字体大小。

3)边框：设置边框的线条的粗细，样式及颜色，可以四条边框分别设置。

4)外边距：设置外边距，可以四条边分别设置。

5)背景颜色：设置框架下插入的模块的背景颜色。

6)背景图片：设置框架的背景图片及平铺方式。

7)指定 class：可以在下拉菜单中选择要用的样式。

3、点击框架右侧的编辑 => 删除，即可删除添加的框架，如下图所示：

注意：删除框架后，框架下添加的模块也一并删除。请慎用。

4、点击框架右侧的编辑 => 导出，可以导出框架设置，如下图所示：

三、框架的嵌套

DIY 页面提供了 100% 框架，1:1 框架，1:2 框架，2:1 框架，1:3 框架，3:1 框架，1:1:1 框架，tab 框架，8 中框架种类，可以通过框架的嵌套，可以更好的设计出个性化的页面。

如建立了一个 3:1 框架，在 3:1 框架 3 的部分中添加了一个 1:1 框架，在 3:1 框架 1 的部分中添加了一个专题类模块，然后在 1:1 框架中添加了图片类模块和会员类模块。建立之后的效果，如下图所示：


如何使用模块

广场 —— 如何使用模块

一、模块的添加

1、打开广场 DIY 页面，点击模块，如下图所示：

2、选择要添加的模块类型，按住鼠标，将模块拖到要放置模块的位置，如下图所示：

3、拖动到想添加的位置后，会弹出模块属性窗口，来设置模块的属性，添加的模块类型不同，要设置的属性也不同，以图片类为例，如下图所示：

4、设置完模块属性，点击确定后，会弹出编辑模块标题的窗口，来设置模块标题。如下图所示：

设置好后，点击确定，可以看到，模块已经成功的添加在框架中，如下图所示：

二、编辑模块

1、点击模块右上方的编辑 => 标题，如下图所示：

1)模块标题：输入要显示的模块标题，如：最新相册。

2)链接：输入点击模块名称要跳转的链接地址，如http://localhost/dzx/home.php

3)图片：输入显示在模块名称前面的模块图标地址，如：./static/image/common/star_level1.gif

4)位置：设置模块名称的显示位置，偏左或偏右，以及偏移量。

5)字体：设置模块名称字体显示的大小及字体的颜色

6)背景图片：输入显示在模块名称处的图片地址，如./static/image/common/star_level1.gif

7)背景颜色：设置模块名称位置的背景颜色

2、点击模块右上方的编辑 => 样式，如下图所示：

字体：设置模块中显示的内容的区域大小

链接：设置模块中的内容的字体大小

边框：设置模块边框的粗细，样式和颜色

外边距：设置边框的外边距

内边距：设置边框的内边距

背景颜色：设置模块的背景颜色

背景图片：输入模块背景的地址，如：./static/image/common/star_level1.gif

指定class：在下拉菜单中选择要设置的样式

三、删除模块

点击模块右上方的编辑 => 删除，即可删除模块，如下图所示：

四、更新模块

点击模块右上方的编辑 => 删除，即可更新模块中的内容，如下图所示：


如何将论坛帖子、群组话题推送到首页

广场 —— 如何将论坛帖子、群组话题推送到首页

一、通过文章推送把论坛帖子和群组话题，推送到首页文章类模块展示。

1、在首页添加一个任意类型的框架，例如 1:1 框架，如下图所示：

2、在添加的框架中，添加一个文章类模块，数据来源于最新文章，如下图所示：

3、进入广场 => 版块，点击要推送的文章，点击帖子下方的文章推送，如下图所示：

4、在弹出的推送对话框中，选择帖子要推送到的，文章分类，如市场活动，如下图所示：

5、在弹出的发布文章的页面中，可以做一些编辑，然后点击提交即可，如下图所示：

6、推送成功后，再访问首页，会看到文章类模块中已经显示了推送的论坛帖子，如下图所示：

可以用相同的方法推送群组话题。

二、通过在首页 DIY 添加帖子类模块将论坛帖子推送到首页。

1、在框架中添加一个帖子类模块，如下图所示：

2、当再访问首页时，会看到论坛帖子已经成功的展示在首页，如下图所示：

三、通过在首页 DIY 添加群组帖子模块，将群组帖子推送到首页。

1、在框架中添加一个群组帖子类模块，如下图所示：

2、当再访问首页时，会看到群组帖子已经成功的展示在首页，如下图所示：


Discuz! X1 前台使用 — 群 组

创建群组：群组功能是一个非常强大的功能，可以发新话题、发布投票、发布悬赏、发布活动、发布商品等。

管理群组：群组普通成员可被群主设置成管理成员、明星成员或者被踢出等。


创建群组

群 组 —— 创建群组

1、启用群组

功能所在位置：

Discuz! X后台 => 群组 => 群组设置，如下图所示

是否开启群组功能：选择“是”即可。

群组图标文件大小(kb)：默认为 512

选择管理用户组（在群组中具有与论坛中相对应的管理权限）：这里可以选择哪个用户组可以管理群组，默认情况下只有站点管理员可以管理。

搜索引擎优化：即群组的 SEO 设置。

页面描述：此描述内容用于搜索引擎优化，放在 meta 的 description 标签中

关键词：这里填写群组的关键词，便于搜索引擎收录。

2、设置用户组权限

如果会员没有权限是不能创始群组的，所以要给有权限创始群组的会员设置权限。

Discuz! X后台 => 用户 => 用户组 => 找到想设置有权创建群组的用户组 => 点编辑 => 群组相关 => 允许建立群组的数量：填写非 0 数字即可，范围 1-255，0 为不允许建立群组。

3、创建群组

登录 Discuz! X 站点，进入群组页面，点击右侧的创建群组即可，如下图所示：

群组名称：填写要创建的群组名。

所属分类：选择群组的分类，如自由联盟、地区联盟、兴趣联盟。

群组简介：填写群组的简单介绍。

浏览权限：选择群组的浏览权限，所有人都可以浏览或者仅会员可以浏览。

加入方式：群主可以选择会员的加入方式，分别为：自由加入、审核加入和邀请加入。

说明：

自由加入：可以直接加入群组。

审核加入：申请加入后需要群主进行审核通过。

邀请加入：只能是群主进行邀请才可以加入。

特别注意：除群组名称和分类暂时不能修改外，其它项目在创建完成后仍可修改。


管理群组

群 组 —— 管理群组

关于群组的一些特性：

群组名称是不能重复的，是要经过后台关键词过滤的

群组是不能解散的，只有管理员可以在后台删除。

群主不能移动帖子，但管理员可以。

群组普通成员可被群主设置成管理成员、明星成员或者被踢出。

下面主要介绍如何管理群组。

进入群组页面，打开要修改的群组，点击“管理群组”如下图所示：

可以对群组进行设置，也可以审核成员，管理成员，主题分类，群组转让等操作。

1、群组设置

可以修改群组名称、推荐到版块，修改所属分类等，如下图所示：

群组名称：这里可以直接修改群组名称

推荐到版块：可以把群组推荐到论坛的某个版块

所属分类：即修改群组的分类

群组简介：选填项，简单说明该群组

浏览权限：可以设置为所有人均可浏览和仅加入的成员可以浏览。

加入方式：分为自由加入、审核加入、邀请加入和关闭。

自由加入即所有人都可以加入。

审核加入即加入后需要群主进行审核通过。

邀请加入即只能邀请加入该群。

关闭加入即该群不允许加入。

群组图片：上传群组图片后会自动缩略成 644 X 150 像素大小的图片，效果如下图所示：

群组图标：上传后会自动缩略成 48 X 48 像素大小的图片，效果如下图所示：

2、成员审核

当加入方式改为审核的时候，会员加入该群组需要进行审核通过。

3、成员管理

这里可以直接把成员踢出，或者加入某个用户组。

群组成员类型分为：

管理类：创始人，群主，副群主

成员类：明星成员，普通成员

如下图所示：

4、主题分类

这里设置是否启用主题分类功能，您需要同时设定相应的分类选项，才能启用本功能，如下图所示：

5、群组转让

需要在该群组中有两个或者两个以上的管理成员才可以进行转让。

转让资格：

只能转让给本群组的管理成员

接收者要具备可再创建新群组的资格。

注意：群组转让成功后，您依然是该群的群主，但不再是群组创始人，所以可自由退出该群组。

转让后无法直接恢复群，需被接收者主动操作才可以再次转回，请谨慎操作。同时转让的时候需要输入登录密码。


Discuz! X1 前台使用 — 家 园

我的中心：通过我的中心，可以快捷方便的进行发布记录、上传相册图片、发布日志等操作。

装扮空间：装扮空间功能是 Discuz! X1 的新特性，可以进入家园的个人空间，DIY 自己的首页。包括版式/布局、风格、模块以及自定义装扮。

feed动态新特性：加强了以“人”为中心的功能，不再仅仅以展示信息为主。

个人设置：对会员的一些全局设置，包括个人资料、修改头像、积分和用户组、隐私筛选、邮件提醒和密码安全。


我的中心

家 园—— 我的中心

Discuz! X1版本通过我的中心，可以快捷方便进行操作，如发表日志不要进入空间中进行发布，在首页我的中心就可以快速的发布，我的中心是用户的中心，这里包括了与用户相关的大部分信息和设置，其中有记录、相册、日志、分享、帖子、群组、活动、投票、悬赏、辩论、商品、收藏、好友、任务、道具、勋章以及漫游应用等信息。

如下图所示：

您可以直接在这里发布记录、上传相册图片、发布日志、添加分享、发布帖子、创建群组、发起活动、发起投票、发布悬赏、发起辩论、出售商品、查看收藏、查看邀请好友、查看任务、直接进入道具中心、查看勋章、以及添加和进入漫游应用。


装扮空间

家 园—— 装扮空间

一、位置

会员进入家园首页，点击个人资料下方的装扮主页，如下图所示：

也可以点击右侧的“装扮安间”链接，如下图所示：

找到位置后就可以尽情的 DIY 自己的空间首页了。

二、开始 DIY

分为版式、风格、模块以及自定义。如下图所示：

三、版式/布局

1、选择版式/布局

共有 15 种布局，分别为1:2:1 、1:1:2、2:1:1、2:2、1:3、3:1、1:4、4:1、2:2:1、1:2:2、1:1:3、1:3:1、3:1:1、3:2、2:3

布局即整个页面的比例，比如 1:2:1 的布局，效果如下图所示：

可以选择自己想要的版式/布局。

2、托拽

当鼠标变为 [image] 时可以自由托拽模块的位置。

比如把个人资料托到页面的最右侧，如下图所示：

四、风格

默认有 8 种风格可供选择，包括默认的风格，如下图所示：

点击上图中的风格名称即可选中该风格。如下图所示：

五、模块

默认列出了 11 种模块以及音乐盒和自定义的 5 个模块。

1、选择模块

在要显示的模块名称前面打勾即可选中该模块并显示在首页，如下图所示：

如果不想显示该模块直接去掉模块名称前面的对勾即可。

2、添加模块

这里以添加音乐盒为例，在音乐盒前面打对勾，音乐盒便会显示在首页下方，如下图所示：

3、编辑模块

添加好模块后，鼠标放在该模块右侧就会出现编辑链接，如下图所示：

点击属性即可对该模块进行编辑

1）添加音乐：

注意:仅支持 mp3 格式添加，即:必须是以http://开始，以.mp3结尾。

如 http://www.bjecr.net/upFile/bbs/mp3/1272598371606.mp3

曲目名：填写歌曲的名称，为空则自动生成名字。

封面：完整模式才有效果，建议选择60*60的jpg图片，这里可以填写图片的 url 地址，或者绝对路径。如果不填默认为 static/image/common/nophotosmall.gif

效果如下图所示：

2）当前播放列表：

会列出已经添加好的所有音乐，如下图所示：

这里可以删除音乐，以及调整音乐的播放前后顺序，同时也可以批量删除音乐。

3）播放器配置

模块名称：可以编辑修改模块的名称，比如可以把音乐盒改为其它的名字。

显示模式：有完整模式和列表模式。

开始模式：分为自动和手动，如果选择手机，那么播放音乐需要手动点击才能开始播放，默认为自动播放，即访问主页的时候会自动播放列表中的音乐。

播放模式：随机顺序和列表顺序。随机顺序即随机播放，列表顺序指按音乐的前台顺序进行播放。

界面颜色：面板背景颜色指的是音乐盒背景色

字体按钮颜色：指的是播放器按钮的颜色。

播放曲目颜色：指播放列表中，音乐名称的颜色。

效果如图：

面板背景：完整模式才有效果，建议选择200*180的jpg图片，效果如图：

同时也可以编辑其它模块，比如主题数想多显示一些，这里都可以修改。

4、添加自定义模块

可以自定义模块标题和内容

其中自定义内容支持 BBCODE IMG 代码，最大 1000 字。比如添加自我介绍，效果如图：

六、自定义装扮

如果相册中有图片会列出相册中的图片，也可以上传新的图片如下图所示：

1、编辑背景

可以选择相册中的图片做为背景图，也可以在右侧选择背景颜色。

图片平铺：可以选择平铺、直接使用、横向平铺和纵向平铺。

图片位置：有 9 个位置可供选择。

背景滚动：背景可滚动显示，也可固定。

背景颜色：指背景的颜色，可以点击后台框选择，也可以手动输入#6DFFA4 类似这样的颜色代码。

2、编辑头部

选择喜欢的图片做为头部图片，效果如下图所示：

3、编辑标题栏

选择喜欢的图片或者颜色做为标题栏图片或者颜色，效果如下图所示：

4、编辑内容区

选择喜欢的图片或者颜色做为内容区的背景图片或者颜色，如果如下图所示：

也可以一键恢复原装皮肤，即恢复为默认。


feed动态新特性

家 园—— feed 动态新特性

与 UCenter Home 的动态（feed）相比较，新版个人空间的动态加强了以“人”为中心的功能，不再仅仅以展示信息为主。具体体现在动态的更新就是“会员”动态的更新，这个会员无论是发了日志、传了照片还是发起投票等行为，都体现为：“会员头像”+“动态”，让会员真实感受到人与人之间的“联系”无处不在。Discuz! X1 动态如下图所示：


个人设置

家 园—— 个人设置

个人设置是对会员的一些全局设置，包括个人资料、修改头像、积分和用户组、隐私筛选、邮件提醒和密码安全。

下面详细说明每一个设置的功能。

个人资料：个人资料分为基本资料、联系方式、教育情况、工作情况、个人信息和广场信息。

修改头像：会员可以在这里上传自己的头像，支持摄像头，如果您的电脑上安装有摄像头的话可以直接拍照。

积分和用户组：可以在这里查看会员的积分、所在用户组、积分交易记录和积分规则。

隐私筛选：可以在这里进行个人隐私设置、个人动态发布设置和动态筛选。

邮件提醒：系统会在您超过设置的天数内没有登录站点时，自动给您发送提醒邮件。

密码安全：可以重新设定密码，重新填写 Email 地址等。


个人资料

家园 —— 个人设置 —— 个人资料

登录 Discuz! X站点 => 设置 => 个人资料：

个人资料分为基本资料、联系方式、教育情况、工作情况、个人信息和广场信息。

基本资料如下图所示：

真实姓名：填写用户的真实姓名。

性别：选择性别。

出生日期：选择出生日期。

出生城市：选择出生的城市。省分、城市。

居住城市：选择居住城市。

情感状态：填写情感状态。

交友目的：填写交友的目的。

血型：选择血型。

联系方式如下图所示：

固定电话：填写固定的电话号码如座机号码。

手机：填写手机号码。

支付宝帐号：填写正确的支付宝帐号。

QQ号：填写自己的 QQ 号码。

MSN帐号：填写自己的 MSN 帐号信息。

阿里旺旺帐号：填写正确的阿里旺旺帐号。

教育情况如下图所示：

毕业学校：填写毕业的学校名称。

学历：选择学历

工作情况如下图所示：

职业：填写自己的职业，如网络、IT 等等

公司：填写所在职的公司名称。

职位：填写自己的职位名称。

年收入：填写年收入的情况。

个人信息如下图所示：

证件号类型：选择证件号的类型，其中包括身份证、护照和驾驶证。

证件号：填写证件号吗，如果证件号类型选择的是身份证，这里填写身份证号码。

邮寄地址：填写具体的邮寄地址。

邮编：填写正确的邮编号。

个人主页：填写个人主页地址。

自我介绍：填写简单的自我介绍。

兴趣爱好：填写自己的兴趣爱好如游泳、看书、爬山等。

广场信息如下图所示：

自定义头衔：自定义头衔需要在后台设置相应的权限才可以，自定义头衔填好后会显示在广场里帖子中用户头像的下方，如下图所示：

个人签名：填写个人签名，会显示在每个自己发表的帖子的下方。

可以以图片的形式显示，也可以把字体变粗，改变字体颜色、添加超链接等多种形式。

时区：如果发现当前显示的时间与你本地时间相差几个小时，那么你需要更改自己的时区设置。比如服务器在国外的情况。

以上的信息都可以设置隐私权限为公开、仅好友可见或者保密。同时您也可以在后台，用户栏目中添加要显示的用户信息，也可以信息用户信息是否为选填或者必填项。


修改头像

家园 —— 个人设置 —— 修改头像

会员可以在这里上传自己的头像，支持摄像头，如果您的电脑上安装有摄像头的话可以直接拍照。

从本地选择头像图片，上传，如下图所示：

上传好头像后，直接点击确定即可，如下图所示：

这样头像就上传成功了。


积分和用户组

家园 —— 个人设置 —— 积分和用户组

可以在这里查看会员的积分、所在用户组、积分交易记录和积分规则。

我的积分：列出来会员所有的积分项，如威望、金币、体力、激情等，同时还可以在这里转账和积分充值。

用户组：在这里可以查看自己所在用户组的权限，也可以查看其它用户组的权限，如下图所示：

积分记录：这里可以所有进行过交易的积分记录，其中包括主题付费、主题收益、附件收益、悬赏付费、悬赏收益、转账与兑换和收益记录，如下图所示：

积分规则：这里可以查看所有得到和被删除积分的情况，可以查看全局规则，也可以查看具体的某一个版块的规则，如下图所示：


隐私筛选

家园 —— 个人设置 —— 隐私筛选

可以在这里进行个人隐私设置、个人动态发布设置和动态筛选。

个人隐私设置：可以在这里完全控制哪些人可以看到你的主页上面的内容，如个个主页、好友列表、留言板等。

个人动态发布设置：系统会将您的各项动作反映到个人动态里，方便朋友了解你的动态。你可以控制是否在下列动作发生时，在个人动态里发布相关信息。

动态筛选

筛选规则一：屏蔽指定用户组的动态

你可以决定屏蔽哪些用户组的动态，屏蔽用户组内的组员所发布的动态都将被屏蔽掉。

同时也可以在自己的好友列表中，对好友进行分组，并可以对用户组进行改名。

筛选规则二：屏蔽指定好友指定类型的动态

点击一下首页好友动态列表后面的屏蔽标志，就可以屏蔽指定好友指定类型的动态了。

这里会列出您已经屏蔽的动态类型识别名和好友名，也可以选择是否取消屏蔽。

筛选规则三：屏蔽指定好友指定类型的通知

点击一下通知列表后面的屏蔽标志，就可以屏蔽指定好友指定类型的通知了。

这里会列出您已经屏蔽的通知类型和好友名，你可以选择是否取消屏蔽。


邮件提醒

家园 —— 个人设置 —— 邮件提醒

需要在后台 => 全局 => 空间设置 => 基本设置中填写邮件通知更新天数才会有邮件提醒功能，同时该功能也需要您设置好邮件，保证系统可以正常的收发邮件。这里填写的邮件通知更新天数设置为多少，那么系统会在您超过这个数字没有登录站点时，自动给您发送提醒邮件，你可以选择只接受某些类别的提醒，如下图所示：

邮件发送频率：可以选择实时发送、每天发送一次和每周发送一次，也可以在这里直接修改发送的邮箱地址。


密码安全

家园 —— 个人设置 —— 密码安全

这里可以重新设定密码，为了安全建议您每隔一段时间设置一次新密码。

也可以重新填写 Email 地址，安全提问信息，如下图所示：


后台使用

Discuz! X1 后台使用

  • Discuz! X1后台—全 局
  • Discuz! X1后台—界 面
  • Discuz! X1后台—内 容
  • Discuz! X1后台—用 户
  • Discuz! X1后台—门 户
  • Discuz! X1后台—论 坛
  • Discuz! X1后台—群 组
  • Discuz! X1后台—扩 展
  • Discuz! X1后台—插 件
  • Discuz! X1后台—工 具
  • Discuz! X1后台—站 长
返回主目录


Discuz! X1 后台使用 — 全 局

站点信息：是论坛常用功能和全局配置的总开关。通常论坛安装完毕，您首先需要对站点信息进行配置，比如网站名称的修改、添加备案信息和统计代码等。

注册与访问：给站长提供了灵活自由的注册机制和访问限制。比如设置注册方式是普通注册还是邀请注册，新用户注册是否需要审核或者 Email 验证等。

优化设置：针对于本论坛设置有效的 SEO 参数、设置搜索引擎优化、内存优化等。

站点功能：针对对论坛的一些常见功能进行合理化的配置，从而提供给用户所需功能。包括管理相关、主题热度、主题评价等其他设置。

空间设置：通过空间设置可以对空间中的实名认证、视频认证、隐私设置等项进行设置。

用户权限：基于全站用户的基本权限的控制。在这里可以针对全站用户做一些基本设置，比如是否允许查看会员列表、帖子最大和最小字数限制、投票最大选项数、评分限制等。

积分设置：Discuz! X1 对广场，群组和家园的积分实现了统一，用户可以通过发表主题、发表日志、访问空间等动作获得站点的积分。

防灌水设置：方便站长通过这里的各项设置防止用户或者注册机恶意灌水，破坏站点的环境。

时间设置：为了满足不同用户的需求，我们允许站长自定义时间格式等。另外我们提供了一个以时间为条件的权限控制策略，以便站长管理论坛更轻松便捷。

上传设置：对论坛和空间的附件进行存放管理，水印管理，同时提供了远程附件的功能，为您站点的附件提供更加合理的存放和显示方案。

搜索设置：提供了三种搜索方式，普通搜索、sphinx 全文检索和 Manyou 搜索。

地区设置：可以直接编辑、添加地区，方便快捷。


站点信息

全局 —— 站点信息

这个功能主要涉及到后台基本设置与论坛的前台显示效果有关的一系列设置。下面主要介绍一下这个功能的使用方法和注意事项。

一、功能的位置：后台 => 全局 => 站点信息，如下图所示：

二、各项设置的方法及作用

1、站点名称：设置之后将显示在导航条和标题中。设置后效果如下图所示：

2、网站名称：设置之后将显示在页面底部的联系方式处。设置后效果如下图所示：

3、网站 URL：设置之后将作为链接显示在页面底部，如下图所示：

4、管理员邮箱：设置之后将出现在页面底部的“联系我们”，另外将作为系统发邮件的时候的发件人地址，如下图所示：

5、网站备案信息代码：页面底部可以显示 ICP 备案信息。如果网站已备案，在此输入您的授权码，它将显示在页面底部，如果没有请留空，设置后的效果如下图所示：

6、显示授权信息链接：选择“是”将在页脚显示商业授权用户链接，链接将指向 Discuz! 官方网站，用户可通过此链接验证其所使用的 Discuz! 是否经过商业授权，设置后的效果如下图所示：

7、关闭站点：暂时将站点关闭，其他人无法访问，但不影响管理员访问、选择“是”后，其他人再访问站点时，会显示如下图所示内容：

8、关闭站点的原因：填写站点关闭时出现的提示信息。当关闭站点后，其他人访问会显示在提示信息中，如下图所示：

9、网站第三方统计代码：在这里可以将您在第三方网站申请到的统计代码复制进去。效果如下图所示：


注册与访问

全局 —— 注册与访问

作为网站的大门，注册与访问只允许符合相关条件的用户注册和访问，通过这一项功能，可以有效的防止灌水机的危害。

一、注册相关设置：进入后台 => 全局 => 注册与访问 => 注册，如下图所示：

1、允许新用户注册：设置是否允许游客注册成为站点会员，您可以根据站点需求选择注册方式。

1)关闭注册：禁止游客注册成为站点会员。

2)只开放普通注册：允许符合条件的新会员注册成论坛用户。

3)只开放邀请注册：只允许持有邀请码的新用户注册，此时需要进行邀请的相关设置。如下图所示：

4)开放普通注册和邀请注册：可以同时使用“普通注册”和“邀请注册”这两种注册方式。

2、注册链接文字：设置站点注册页的链接文字，默认为“注册”。如设置为“点击这里注册”，显示效果如下图所示：

3、用户信息保留关键字：用户在其用户信息(如昵称、自定义头衔等)中无法使用这些关键字。每个关键字一行，可使用通配符 "*"。

4、新用户注册验证：选择“无”用户可直接注册成功；选择“Email 验证”将向用户注册 Email 发送一封验证邮件以确认邮箱的有效性；选择“人工审核”将由管理员人工逐个确定是否允许新用户注册。

5、不受审核限制的 IP 列表：当用户处于本列表中的 IP 地址时，注册后无需审核。每个 IP 一行，既可输入完整地址，也可只输入 IP 开头，例如 "192.168."(不含引号) 可匹配 192.168.0.0～192.168.255.255 范围内的所有地址，留空为不设置。

6、同一 IP 注册间隔限制(小时)：同一 IP 在本时间间隔内将只能注册一个帐号，0 为不限制。

7、同一 IP 在 24 小时允许注册的最大次数：同一 IP 地址在 24 小时内尝试注册的次数限制，建议在 30 - 100 范围内取值，0 为不限制。

8、限时注册的 IP 列表：当用户处于本列表中的 IP 地址时，每 72 小时将至多只允许注册一个帐号。每个 IP 一行，既可输入完整地址，也可只输入 IP 开头，例如 "192.168."(不含引号) 可匹配 192.168.0.0～192.168.255.255 范围内的所有地址，留空为不设置。

9、发送欢迎信息：可选择是否自动向新注册用户发送一条欢迎信息，如果发送，可以选择发送短消息或者是 Email。

10、欢迎信息标题：设置系统发送的欢迎信息的标题，不支持 HTML，不超过 75 字节。

11、欢迎信息内容：设置系统发送的欢迎信息的内容。

需要注意的是：标题内容均支持变量替换，可以使用如下变量：

{username} : 用户名

{time} : 发送时间

{sitename} : 站点名称

{bbname} : 站点名称

{adminemail} : 管理员 Email

12、显示网站服务条款：选择“是”，需要进一步设置服务条款的详细内容，新用户注册时显示网站服务条款，只有同意网站服务条款，才能完成注册。如下图所示：

二、访问控制相关设置：进入后台 => 全局 => 注册与访问 => 访问控制，如下图所示：

1、新手见习期限(小时)：新注册用户在本期限内将无法发帖和短消息，不影响版主和管理员，0 为不限制。

2、允许访问站点的 IP 列表：只有当用户处于本列表中的 IP 地址时才可以访问本站点，列表以外的地址访问将视为 IP 被禁止，仅适用于诸如企业、学校内部站点等极个别场合。本功能对管理员没有特例，如果管理员不在此列表范围内将同样不能登录，请务必慎重使用本功能。每个 IP 一行，既可输入完整地址，也可只输入 IP 开头，例如 "192.168."(不含引号) 可匹配 192.168.0.0～192.168.255.255 范围内的所有地址，留空为所有 IP 除明确禁止的以外均可访问。

3、允许访问管理中心的 IP 列表：只有当管理员(超级版主及版主不在此列)处于本列表中的 IP 地址时才可以访问站点管理中心，列表以外的地址访问将无法访问，但仍可访问站点前端用户界面，请务必慎重使用本功能。每个 IP 一行，既可输入完整地址，也可只输入 IP 开头，例如 "192.168."(不含引号) 可匹配 192.168.0.0～192.168.255.255 范围内的所有地址，留空为所有 IP 除明确禁止的以外均可访问管理中心。

4、允许发表的域名列表：当用户组禁止发表 URL ，或者 URL 不解析时，处于本列表中的域名下的 URL 仍然可以正常发表，正常解析，每行一个域名，默认为本站域名可以正常发表。


优化设置

全局 —— 优化设置

论坛后台全局 => 优化设置 可以分别设置“搜索引擎优化”、“内存优化”、“论坛页面缓存设置”以及“服务器优化”来优化论坛的运行。

一、搜索引擎优化

随着网站数量的增多，网站的宣传越来越多地依赖搜索引擎的搜索结果。搜索引擎一般都使用一种称为搜索引擎机器人的技术，这种机器人会根据一定规则的在 Internet 上访问站点，并把有价值的页面收集到搜索引擎的缓存数据库保存。搜索机器人对静态页面的处理能力要强于动态页面。如果一个站点都是 .html 页面，那么它被搜索引擎全文搜到的可能性就要比 .PHP 的页面高几个数量级，因此而来的访问量也会高出很多。Discuz!X 提供了 URL静态化、标题附加字、 Meta Keywords、 Meta Description 以及 其他头部信息。

1、URL静态化

从 Discuz!X 开始，可以根据用户需求来设置静态格式，可以将 首页专题页、首页文章页、论坛主题列表页、论坛主题内容页、群组主题列表页、用户个人主页 以及 全站动态页面 根据需求选择开启并且设置个性化的静态显示格式。形成类似 http://www.discuz.net/forum-33-1.html 和http://www.discuz.net/thread-1670193-1-1.html 等形式的超级链接，从而使论坛内容更容易被搜索引擎挖掘，提高被收录的机率。

这个功能对服务器环境有特殊要求，独立主机用户需要对 Web 服务器增加相应的 Rewrite 规则，因此需要服务器权限才可使用。对于虚拟主机用户，需要向您的空间服务商进行咨询空间是否支持 Rewrite 以及是否支持对站点目录中 .htaccess 的文件解析，只有满足这两条件，URL 静态化功能才会生效。Discuz!X 的静态规则在后台设置处可以点击 查看当前的 Rewrite 规则 找到。

2、标题附加字

网页标题通常是搜索引擎关注的重点，本附加字设置将出现在标题中论坛名称的后面，如果有多个关键字，建议用 "|"、","(不含引号) 等符号分隔。设置之后该文字将显示在浏览器网站标题后面。如下图中 “Discuz！论坛官方”后面的文字。

3、Meta Keywords

Keywords 项出现在页面头部的 Meta 标签中，用于记录本页面的关键字，多个关键字间请用半角逗号 "," 隔开。

4、Meta Description

Description 出现在页面头部的 Meta 标签中，用于记录本页面的概要与描述。

5、其他头部信息

如需在 中添加其他的 HTML 代码，可以使用本设置，否则请留空。

二、内存优化

从 Discuz!X 开始，系统提供的内置的内存优化方式。支持的内存优化接口有 Memcache, eAccelerator, Xcache 三种，优化系统将会依据当前服务器环境依次选用接口。

启用内存优化功能将会大幅度提升程序性能和服务器的负载能力, 内存优化功能需要服务器系统以及PHP扩展模块支持。

内存接口的主要设置位于 config_global.php 当中，需要通过编辑 config_global.php 进行高级设置来使用内存优化。

三、论坛页面缓存设置

设置页面缓存能够有效的降低服务器的 Mysql 与 CPU 负载，提高论坛运行速度。建议在论坛的数据量和访问量都比较大的情况下开启该功能。

进入后台 => 全局 => 优化设置 => 论坛页面缓存设置，可以看到有关页面缓存的各项设。

1、论坛页面缓存设置

1) 缓存论坛首页有效期

如果该设置设置为 0 的话，那么首页缓存关闭。如果设置为其他值比如 900 则论坛每 900 秒来读取数据库信息更新一次首页缓存，保证缓存信息与实际信息的同步。同时该设置只对游客用户有效，也就是说开启该功能后只有游客浏览的页面是被缓存起来的页面。保证了会员浏览的首页数据是没被缓存的。

2) 缓存帖子有效期

如果该设置设置为 0 的话，那么帖子缓存关闭。如果设置为其他值比如 900 则论坛每 900 秒来读取数据库信息更新一次帖子缓存，保证缓存信息与实际信息的同步。另外，请通过编辑论坛来指定帖子页面缓存系数。

3) 缓存目录

缓存文件保存的目录。默认为 forumdata/threadcaches 目录，如果您需要将其指定为其他目录，请确定您指定的目录有可写权限。

2、缓存系数批量设置

该功能可以批量设置各个版块的帖子缓存系数，在开启了帖子缓存之后请指定这个值。

缓存系数就是说帖子缓存的程度，页面缓存功能可以将会员经常访问的主题临时缓存起来，缓解大型论坛服务器压力。缓存阀值范围 0 - 100，建议设置为 40 ，0 为关闭。在磁盘空间允许的情况下，适当调高缓存系数，可以提高缓存效果。同事系数越高，占用的磁盘空间也就越大。

在下面选择将该系数应用到哪个版块之上，可以对部分版块或者全部版块设置。

四、服务器优化

服务器优化可以对论坛的一些参数进行调整，从而均衡服务器的负载。进入后台 => 全局 => 优化设置 => 服务器优化，可以看到服务器优化的各项设置。主要包括服务器优化与搜索设置。

服务器优化：

1) 点击数延迟更新

延迟更新主题或者附件的浏览量，可明显降低访问量很大的论坛的服务器负担，建议开启本功能。本功能有三个选项：仅主题浏览量、仅附件下载量以及主题浏览量和附件下载量。可以根据实际情况来开启。

2) 禁止浏览器缓冲

禁止浏览器对论坛页面进行缓冲，可用于解决极个别浏览器内容刷新不正常的问题。如登陆后提示成功的用户名不是自己的用户名，但是刷新页面后正常。注意: 本功能会加重服务器负担。

3) 最大在线人数

请设置合理的数值，范围 10～65535，建议设置为平均在线人数的 10 倍左右。这个设置通过设置 sessions 表的最大记录，来控制最大的在线人数，通过这个选项可以适当的控制服务器的资源消耗。可以根据实际在线人数来调节这个设置。

4) 在线保持时间(分钟)

请根据访问情况设置合理的数值，访问量大的站点应当调小该数值，设置范围 5 - 60，过大或者过小的设置都有可能会增大服务器资源开销。用户的在线状态保存在 sessions 数据表内，调整这个值也就是调整了用户在线记录在该表内保存至自动销毁的时间。

5) 系统负载控制

本选项用于 Unix/Linux 主机下，系统高于此值时会禁止新用户访问直至负载下降，通常情况可设置为 5～10，0 为不限制。本功能会轻微加重服务器负担。

当服务器负载高于设置值的时候，论坛会返回一个定制的错误页面。

6) JS 文件目录

设置论坛 Javascript 脚本的目录。当脚本目录为缓存目录时，系统会将默认目录中的 *.js 文件进行压缩然后保存到缓存目录以提高读取速度。

此功能进一步加强了 Discuz!X 系统的缓存机制。


站点功能

全局 —— 站点功能

站点功能可以对站点的管理、评分和帖子内容进行一些基本的管理操作，功能包括管理相关、主题热度、主题评价、帖子点评和其他。

站点功能位置在后台 => 全局 => 站点功能

1、管理相关：可以对站点趋势统计、论坛管理工作统计、管理记录、管理操作及评分理由、隐藏敏感帖子内容、自动禁言和警告有效期等进行操作。如下图所示：

2、主题热度：可以设置主题的增量权重和热门显示级别。如下图所示：

3、主题评价：可以修改加减分操作的文字，可以设置每 24 小时评价主题的次数和评价图标显示级别等。如下图所示：

4、帖子点评：可以设置点评的条目数、是否可以点评楼主贴和自己的帖子、普通主题和特殊主题点评的预置观点，预置观点可以根据自己需要任意填写。如下图所示：

5、其他：设置是否启用登录自动选择帐号、是否启用ＲＳＳ、是否显示程序运行信息，设置活动主题的内置类别。如下图所示：


空间设置

全局 —— 空间设置

空间设置的位置在：后台 => 全局 => 空间设置，如下图所示：

一、基本设置

1、动态保留天数：个人动态的保留天数。超过该天数的个人动态会被清理掉，从而可以保证MySQL的效率。建议不要设置太长。

2、首页动态显示数：首页显示的好友动态将从这些数目的事件中进行合并显示。建议不要设置太多，从而可以保证MySQL的效率，但最少不能低于50。

3、热点推荐的天数范围：设置首页热点推荐选择的天数范围。(单位天，默认为 2天)

4、热点推荐的最小热度值：设置当发布的信息热度值超过多少后，才会显示在推荐里面。

5、动态链接新窗口打开：如果选择是，用户阅读动态的时候，所有的链接都会在新窗口打开。

6、首页动态默认标签设置：好友数小于该值的时候显示所有人的动态，超过这个数值显示好友动态。在日志、相册列表页面，该参数同样生效。

7、首页显示热点的数目：为0，则首页不显示热点推荐。最大不要超过10个。系统会自动获取10个热点，其中，排名第一的热点会固定显示，其余热点会随机显示。

8、列表最大分页数：允许用户查看的最大分页数。当用户查看的分页数越大的时候，对服务器的负载压力就越大。

9、邮件通知更新天数：当用户多少天没有登录站点的时候才会给其发送邮件通知；设置为0，则不启用邮件通知功能；启用本功能将会轻微增加服务器负载

10、成员排行榜缓存时间（单位：分钟）：用户排行榜中，除竞价排行、在线成员、全部成员外，其余排行榜是缓存处理的。请根据服务器的负载情况，设置合理的更新时间间隔。最少不能低于5分钟。

11、好友用户组个数：(默认为 8)设置每个用户最多拥有的好友用户组个数。

12、本处功能可以对发起投票、商品、悬赏、活动、辩论等特殊主题设定指定的默认版块

设置好默认版块后，在“我的中心”点发起此类相关主题时会直接发表到指定的版块。如未设定指定版块，点发起时就会先提示选择要发表的版块，如下图：

注意，此处默认版块的设置和选择前提需要先在版块里面开启发表特殊主题。

13、主题的空间显示模式：设置从空间点击的主题是否按照空间模式显示

如果选否则表示空间点击主题时在论坛的界面中查看。

二、实名认证

通过“实名认证”功能，站长可以对用户进行实名认证，并设置限制未实名认证用户的权限。

1、实名设置：到后台用户 => 用户栏目 => 真实姓名项设置是否必填，是否需要审核等属性，如下图：

2、用户填写实名后，站长可以到后台 => 用户 => 资料审核里面审核实名，如下图

3、未认证实名权限设置：可以限制未实名认证的用户查看实名用户主页、加好友、打招呼、发记录、发日志、使用相册、发投票、分享、收藏、留言/评论、使用MYOP应用等。

二、视频认证

1、开启视频认证：开启需要先在后台 => 站长 => Manyou 设置里启用漫游应用，然后再此处开启视频认证。

2、未视频认证权限设置：可以限制未视频认证的用户查看视频用户的照片、加好友、打招呼、发记录、发日志、使用相册、分享、收藏、向视频用户评论、使用MYOP应用等。

三、隐私设置

1、新用户默认隐私设置：新用户将采用站内的默认隐私设置。用户可以修改自己的隐私设置。

此项设置包括空间首页、好友列表、留言板、个人动态、记录、日志、相册、分享、投票等隐私设置

2、默认动态发布设置：设置论坛各操作动态发布与否。


用户权限

全局 —— 用户权限

Discuz! X1 的用户权限分为两部分：一部分是后台 => 全局 => 用户权限，另一部分是后台 => 用户，这里只讲解全局中的设置。

Discuz! X1 后台 => 全局里的用户权限设置是对所有用户的全局设置。

后台 => 全局 => 用户权限 ，如图

在右侧看到相关的设置项。

1、允许查看用户的主题和帖子

设置是否允许查看其他用户的主题和帖子，只有用户组设置允许查看用户资料后本设置才有效。

2、允许查看会员列表

设置是否允许查看网站会员列表。

3、允许报告内容

设置是否允许报告帖子页面等内容。

4、帖子最小字数(字节)

设置帖子中最小字节数，管理组成员可通过“发帖不受限制”设置而不受影响，0 为不限制。

5、帖子最大字数(字节)

设置帖子中允许的最大字节数，管理组成员可通过“发帖不受限制”设置而不受影响。

6、允许用户随时编辑的帖子类型

被选中的帖子类型将不受用户组中的“编辑帖子时间”限制，任何时刻都可以编辑。

7、投票最大选项数

设置投票帖子所允许的最大选项数。

8、编辑帖子附加编辑记录

在 60 秒后编辑帖子添加“本帖由xxx于xxxx-xx-xx编辑”字样。管理员编辑不受此限制。例如用户刚发完一个帖子，自己发现需要添加或者要修改一些内容，如果这个帖子发表时间已经超过 60 秒，那么在作者编辑完成后，自动添加由“本帖由xxx于xxxx-xx-xx编辑”字样。

9、评分时间限制(小时)

帖子发表后超过此时间限制其他用户将不能对此帖评分，版主和管理员不受此限制，0 为不限制。

10、版主评分限制

设置版主只能在自身所管辖的论坛范围内对帖子进行评分。本限制只对版主有效，允许评分的普通用户及超级版主、管理员不受此限制，因此如果赋予这些用户评分权限，他们仍将可以在全论坛范围内进行评分。

11、允许重复评分

选择“是”将允许用户对一个帖子进行多次评分，默认为“否”。


积分设置

全局 —— 积分设置

一、积分的基本设置

设置方式：

管理中心 => 全局 => 积分设置 => 基本设置

1、扩展积分设置

Discuz! X1 提供了8种扩展积分，站长可以灵活定义每种扩展积分的基本属性，包括：启用积分，设置积分图标、积分名称、积分单位、积分兑换比例、注册初始积分，允许兑出和兑入。

2、积分设置

1）总积分计算公式

总积分是衡量用户级别的唯一标准，积分公式根据每个论坛的实际情况进行设置。系统提供的积分计算项包括posts 代表发帖数 (主题 + 回复数)；threads 代表用户发表的主题数；digestposts 代表精华帖数；friends 代表好友数；doings 代表发表的记录数；blogs 代表发表的日志数；albums 代表上传的相册数；polls 代表发表的投票数；sharings 代表发表的分享数；extcredits1～extcredits8 分别代表上述 8 个自定义积分。公式中可使用包括 + - * / () 在内的运算符号。

2）交易积分设置

交易积分是一种可以由用户间自行转让、买卖交易、发布悬赏主题的积分类型，站长必须指定一种积分作为交易积分。如果不指定交易积分，用户间的积分交易功能将不能使用。注意：交易积分必须是已启用的积分，一旦确定请尽量不要更改，否则以往记录及交易可能会产生问题。

在设置交易积分的时候，不仅可以设置默认使用的交易积分，还可以根据不同情况设置不同的交易积分，这里我们提供了七种额外的交易积分的设置选项：主题(附件)买卖使用的积分、悬赏主题使用的积分、道具买卖使用的积分、空间消费使用的积分、漫游应用使用的积分、用户举报奖惩使用的积分。

3)其他积分相关设置

Discuz! X1 的积分还可以设置积分交易税、转账最低余额、兑换最低余额、单主题(附件)最高收入、单主题(附件)最高出售时限(小时)，可以有效地规范站内的积分交易，以免造成积分的通胀现象。

二、积分策略

Discuz! X1 的积分策略涵盖了整个站点的各个方面，在论坛和空间中的操作都可以做为获取积分的途径。

设置方法：

管理中心 => 全局 => 积分设置 => 积分策略

在编辑积分选项时，可以更改积分的周期、奖励次数、及各项积分的增减方案。

除了在全局设置积分规则外，还可以在版块中单独设置该版块的积分规则。当全局和版块同时设置了相同积分项的不同积分规则时，在版块中的动作获得的积分会以版块的积分规则为主。

设置方法: 管理中心 => 论坛 => 版块管理 => 积分策略，设置方式同全局的积分策略。


防灌水设置

全局 —— 防灌水设置

一、防灌水基本设置：后台 => 全局 => 防灌水设置 => 防灌水基本设置，如下图所示：

1、两次发表时间间隔(秒)：在这里设置两次发表的时间间隔，如果发表间隔小于这个设置，系统将会发出警告。

2、强制新用户验证激活邮箱：此设置为“是”的话，用户必须验证激活自己的邮箱后，才能进行发布操作。

3、强制新用户上传头像：此设置为“是”的话，用户只有设置过自己的头像后才能进行发布操作。

4、强制新用户好友个数：在这里填入数字，设置新用户必须拥有的好友数量，之后才可以进行发布操作

以上各项设置好后，点击提交即可生效。

二、验证码设置：后台 => 全局 => 防灌水设置 => 验证码设置，如下图所示：

1、启用验证码：在这里勾选需要填写验证码才能通过的地方(新用户注册，用户登录，发表信息，修改个人资料)如下图所示：

2、验证码发帖限制：在这里输入数字，发帖数超过这个数量的会员，不受验证码的限制，即使开启了验证码，也不需要输入验证码就可以完成操作，0表示所有会员都受验证码的限制，如下图所示：

3、登录失败时显示验证码：如果选择“是”，只有登录失败3次后才显示验证码。选择“否”，始终显示验证码。此设置在启用了用户登录验证码时，才有效，如下图所示：

4、验证码类型：这里选择验证码的类型，有五种类型可以选择。需要注意的是如果开启中文图片验证码，需要您的主机支持FreeType库；如果开启Flash验证码，建议您的主机开启Ming库以提高安全性，如下图所示：

1)当开启Flash验证码时，还可以进一步设置，如下图所示：

验证码图片宽度：设置验证码图片的宽度，范围在100~200。

验证码图片高度：设置验证码图片的高度，范围在50~80。

2)当开启英文图片验证码或中文图片验证码时，可以做更详细的设置，如下图所示：

图片打散：打散生成的验证码图片，输入打散的级别，0 为不打散。

随机图片背景：选择是，将使用选择“是”将随机使用 static/image/common/seccode/background/ 目录下的 JPG 图片作为验证码的背景图片，选择“否”将使用随机的背景色。

随机背景图形：选择“是”将给验证码背景增加随机的图形。

随机 TTF 字体：选择“是”将随机使用 images/fonts/en 目录下的 TTF 字体文件生成验证码文字，选择“否”将随机使用 images/seccode/gif 目录中的 GIF 图片生成验证码文字。中文图片验证码将随机使用 images/fonts/ch 目录下的 TTF 字体文件，无需进行此设置。

随机倾斜度：选择“是”将给验证码文字增加随机的倾斜度，本设置只针对 TTF 字体的验证码。

随机扭曲：选择“是”将给验证码文字增加随机的扭曲，本设置只针对 TTF 字体的验证码。

随机颜色：选择“是”将给验证码的背景图形和文字增加随机的颜色。

随机大小：选择“是”验证码文字的大小随机显示。

文字阴影：选择“是”将给验证码文字增加阴影。

GIF 动画：选择“是”验证码将显示成 GIF 动画方式，选择“否”验证码将显示成静态图片方式。

以上各项设置好后，点击提交即可生效。

三、验证问答设置：后台 => 全局 => 防灌水设置 => 验证问答设置，如下图所示：

1、启用验证问答：在这里设置要启用验证问答的地方(新用户注册，发表信息，修改密码)，开启后会员必须正确回答系统随机抽取的问题才能继续操作，如下图所示：

2、验证问答发帖限制：在这里填入数字，设置后发帖数超过这个限制的会员，不受验证问答的限制，0 表示所有会员受验证问答的限制，如下图所示：

3、验证问题及答案设置：先点击“添加新问题”，然后在问题下面的文本框中输入问题，在答案下面的文本框中输入答案，最后点击提交即可，开启验证问题后的效果，如下图所示：


时间设置

全局 —— 时间设置

Discuz! X1 的时间设置方式：

管理中心 => 全局 => 时间设置

一、日期和时间格式

1、默认日期格式：使用yyyy(yy) 表示年，mm 表示月，dd 表示天。如 yyyy-mm-dd 表示 2000-1-1。

2、默认时间格式：可选择24小时制或者12小时制；

3、人性化时间格式：选择“是”，论坛中的时间将显示以“n分钟前”、“昨天”、“n天前”等形式显示；

4、默认时差：一般设置为8，指北京时间东8区，如果论坛时间不准确可调整，0.1代表6分钟，可设置为负数；

二、时间段设置

1、禁止访问时间段：禁止用户访问的时间段设置，该段时间内用户不能访问论坛；

2、禁止发帖时间段：禁止用户发帖的时间段设置；

3、发帖审核时间段：发帖需要审核的时间段设置；

4、禁止下载附件时间段：禁止用户下载论坛附件的时间段设置；

5、禁止全文搜索时间段：禁止在论坛使用全文搜索的时间段设置；

备注：时间段设置格式：

每日晚11:25 到次日早5:05可设置为：23:25-5:05；

每日早9:00 到当日下午2:30可设置为：9:00-14:30；

注意：格式不正确将可能导致意想不到的问题，用户组中如开启“不受时间段限制”的选项，则该组可不被任何时间段设置约束。所有时间段设置均以论坛系统默认时区为准，不受用户自定义时区的影响。


上传设置

全局 —— 上传设置

为使内容更加丰富，站点中往往允许用户自行上传附件至服务器中，对于上传附件的设置可以在Discuz! X1 中的管理中心 => 全局 => 上传设置中进行设置。

一、基本设置

1、附件保存位置

是指图片保存到服务器的位置，默认是 ./attachments，结尾不加 "/"，相对目录务必以 "./" 开头，这个目录必须为 web 可访问到的目录，且Linux主机目录的权限必须为 777 ，Windows 主机设置 Internet 来宾帐号可读写的权限。

2、附件 URL 地址

指当前 URL 下的相对地址或 http:// 开头的绝对地址，结尾不加 "/"。

3、图片处理库类型

有两种类型：GD 和 ImageMagick，主要用来处理缩略图和水印的图像处理库。

GD 是最广泛的处理库但是使用的系统资源较多。服务器支持 GD 库，Windows服务器需要修改 php.ini 文件，找到;extension=php_gd2.dll 把前面的分号去掉重启服务即可，Linux服务器需要重新编译安装。

ImageMagick 速度快系统资源占用少且功能多，但需要服务器有执行命令行命令的权限（一般为独立主机）。如果您的服务器有条件安装此程序，请到 http://www.imagemagick.org 下载，安装后在这里指定安装的路径。

4、缩略图质量

设置图片附件缩略图的质量参数，范围为 0～100 的整数，数值越大结果图片效果越好，但尺寸也越大

5、水印

1）启用水印

可以设置自动为用户上传的 JPG/PNG/GIF 图片附件添加水印，在上图所示的地方选择水印添加的位置(3x3 共 9 个位置可选)。不支持动画 GIF 格式。

说明：要使用水印功能必须启用缩略图功能

开启水印后，图片附件的显示效果如下图所示：

2）水印添加条件：小于此尺寸的图片附件将不添加水印，0 以水印图片大小为添加条件。

3）水印图片类型

GIF 类型的文件作为水印，水印图片为 ./images/common/watermark.gif。

PNG 类型的文件作为水印，水印图片为 ./images/common/watermark.png。

这两个图片都可以替换为适合您自己站点的图片，以实现不同的显示效果。

如果选择文本类型的水印并且使用 GD 图片处理库，那么还需要 FreeType 库支持才能使用。windows 主机如果开启了 GD 库默认就是支持 FreeType 库了。

4）水印融合度

设置 GIF 类型水印图片与原始图片的融合度，范围为 1～100 的整数，数值越大水印图片透明度越低。

PNG 类型水印本身具有透明通道，无须此设置。

5）JPEG 水印质量

设置 JPEG 类型的图片附件添加水印后的质量参数，范围为 0～100 的整数，数值越大结果图片效果越好，但尺寸也越大。

二、远程附件

Discuz! X1 的远程附件功能，主要是通过远程上传附件将一部分附件上传到 web 空间以外的其他服务器或空间上，其作用主要有以下三个方面：

1）减少服务器流量

2）减轻服务器负载

3）节约 WEB 空间

1、设置方法

如下图所示：

2、注意事项

1）确保 FTP 服务器地址、端口号、帐号及密码的正确。

2）被动模式（pasv）链接：一般情况下非被动模式即可，如果存在上传失败问题，可尝试打开此设置。

3）远程附件目录：远程附件目录的绝对路径或相对于 FTP 主目录的相对路径，结尾不要加斜杠“/”，“.”表示 FTP 主目录。

举例：FTP登录后的主目录为D:\web，若打算将附件存储在D:\web\attachments文件夹，可直接填写D:\web\attachments（存放远程附件的目录在服务器上的绝对地址），或者填写相对路径 ./attachments。

4）远程访问 URL：支持 HTTP 和 FTP 协议，结尾不要加斜杠“/”；如果使用 FTP 协议，FTP 服务器必需支持 PASV 模式，为了安全起见，URL浏览附件FTP连接的帐号不要设置可写权限和列表权限。

举例：http://www.domain.com/attachments （其中 http://www.domain.com 为用于存放远程附件的 FTP 空间的访问地址，attachments 为存放远程附件的目录）

3、优势及特性

1）独特之处

可设置网络传输超时时间；

支持远程图片水印、缩略图；

开启远程附件后，不影响原来的本地附件的正常使用；

远程附件关闭后，只要 FTP 服务器设置正确，原来的远程附件仍可正常访问；

记录在系统错误记录中包括：

FTP 连接错误

FTP 登录错误

FTP 切换当前目录错误

FTP 创建目录错误

FTP 上传文件错误

2）安全性

（1）FTP 密码加密存储，后台设置只显示密码的首位和末位，中间用 8 个 * 代替

（2）文件名处理，包括超长文件名、可执行扩展名文件、非法文件名等

（3）只有创始人有权查看或修改远程附件的后台设置

（4）支持 SSL 安全连接

3）兼容性

（1）下载远程附件支持多种协议（包括 http 协议和 ftp 协议）

（2）支持多种平台（包括 unix 和 win）

（3）支持多 php 版本

4）扩展性

（1）远程附件和本地附件方便的互相转移

（2）将来可向多 ftp 服务器扩展

三、论坛附件

1、帖子中显示图片附件

选择“是”将在帖子中直接将图片或动画附件显示出来，而不需要点击附件链接与插入图片，如下图：

如果选择“否”指帖子中不直接显示图片，而需要点击附件链接才可以看到，如下图：

2、上传方式

此处为多选，可选择普通上传、批量上传或两者全选。普通上传是单个的文件上传功能；而批量上传是采用Flash机制上传，可以一次上传多个附件并且实时显示上传进度。一般情况建议使用Flash上传，在如果浏览器不支持Flash，可考虑选择普通上传。

3、附件 URL 地址、媒体附件播放

当附件 URL 地址、媒体附件播放选择为“否”时，媒体附件显示如下图：

当选择“是”时，在上传媒体附件后点击视频图标插入，则媒体附件可直接播放。

4、论坛帖子附件缩略图设置

用户可选择不启用缩略图，和以保持比率或保持指定大小的缩略方式。

5、是否直接缩放原图

选择“是”，将直接缩放原图，而不生成缩略图文件。

6、附件链接有效期

以小时为单位，0 或留空表示附件链接永久有效，过期后链接自动更新。本功能可有效防止附件被盗链或附件被软件批量下载，但是会给会员的正常下载带来不便。

7、下载附件来路检查

选择“是”将检查下载附件的来路，来自其他网站或论坛的下载请求将被禁止。

8、远程附件的限制

此处可设置远程附件允许和禁止的附件扩展名、附件尺寸下限（只有尺寸大于当前设置的附件才使用远程附件功能）及是否隐藏远程附件的真实路径。

四、空间附件

限制空间附件上传的大小。本功能需要PHP环境支持GD才生效，如果用户上传一些尺寸很大的数码图片，则程序会按照本设置进行缩小该图片并显示。设置为0，则不做任何处理。


搜索设置

全局 —— 搜索设置

一、普通搜索

Discuz! X1 中可以分别按文章、论坛、日志、相册、群组的范围进行搜索，站长可以根据站点自身的需要，分别启用所需的搜索，并可对各个范围内的搜索时间间隔、60秒内最大搜索次数、最大搜索结果显示条数进行分别限制。

设置方法：管理中心 => 全局 => 搜索设置 => 开启搜索

二、sphinx 全文检索

开启 sphinx 全文检索需要站点的 sphinx 服务已安装及配置成功，填写各项搜索参数即可。

设置方法：管理中心 => 全局 => 搜索设置 => sphinx全文检索设置

三、Manyou 搜索

Manyou 搜索是康盛创想旗下漫游平台针对Discuz! 系列产品提供的站内全文检索/全文搜索服务。具有搜索高效、精准及时、界面友好、使用方便、安全稳定等优势。

在 管理中心 => 站长 => Manyou 设置 中，选择启用漫游搜索，即可使用基于漫游的搜索服务。

以官方论坛为例，Manyou 搜索的界面如下图所示：


地区设置

全局 —— 地区设置

与之前版本不同的是，Discuz! X1 版本可以在后台编辑地区，方便快捷，不再需要修改模板文件了。

该功能具体位置：

Discuz! X后台 => 全局 => 地区设置，如下图所示：

这里可以添加自己的地区，也可以删除默认地区

一、如何添加地区

直接在地区设置下方输入要添加的地区名，点击添加，然后点提交即可，如下图所示：

如果要在某一城市下面添加地区，可以选择好这个省份，然后在下面添加。

如果要在州县下面添加地区，可以选择好省份和城市后再添加，如下图所示：

二、编辑地区

直接点击地区名称右侧的编辑即可对该地区的名称进行修改。

三、删除地区

直接点击地区名称右侧的删除即可把该名称直接删除。


Discuz! X1 后台使用 — 界 面

导航栏：Discuz! X1为站长提供了强大的导航栏功能，其具有一级总导航栏和二级导航栏两种。

界面设置：涉及到全论坛的界面显示方面的设置，比如风格的选择、论坛首页设置、主题列表页、帖子内容页、提示信息、弹出信息等的显示设置。

风格管理：针对论坛的所有风格进行管理，比如卸载、编辑、导出、复制、恢复、设置为默认风格等。

模板管理：通过模板管理，可以对模板套系进行管理，比如添加或者删除。

表情管理：丰富的表情能够更加表达会员的喜怒哀乐，表情管理是您提供增加独特表情的途径。

表态动作：用于设置日志/图片/文章表态动作。

主题图章：可以在帖子主题内显示一个图章，使得看帖更加具有趣味性。

编辑器设置：默认的编辑器模式的选择，以及 Discuz! 代码的添加和管理。

在线列表图标：是显示在线列表的用户及图像显示效果，可以根据自己的需求自定义。


导航栏

界面 —— 导航栏

本篇给站长讲解如何定制自己需要的内容。

通过本篇学习，您可以做到的效果如下图所示：

设置方法：以管理员身份登录后台 -> 界面 -> 导航栏。

点击下方的“添加菜单”，填入您需要的内容，编辑完成后点击提交，如下图所示：

按上面的方法即可给导航栏添加一个新的项目，如果需要修改导航栏的名称和链接地址，可以直接编辑文本框中的文字并提交。

如何设置导航栏的详细属性呢？

设置方法：后台 -> 界面 -> 导航栏，在需要设置的导航栏后面点击“详细”，出现设置面板如下图所示：

设置的菜单含义是：

菜单名称 - 用于显示的导航栏名称

菜单位置 - 可以列入某菜单的子菜单

菜单说明 - 用于显示的导航栏名称下方的说明

菜单链接 - 链接到某个网址

菜单字体样式 - 顾名思义

菜单字体颜色 - 顾名思义

链接打开方式 - 顾名思义

使用等级 - 限制某个用户组可见

如何添加二级导航栏？

设置方法：后台 -> 界面 -> 导航栏 -> 编辑一个导航选项后面的“二级导航”

添加对应的文字即可，如下图所示：

看完本篇教程，就可以完成上面第一幅图所展示的导航栏了。


界面设置

界面 —— 界面设置

Discuz! X1 提供了强大的界面设置，站长朋友可以在不修改程序的情况下快速准确的设置需要给用户展示的界面风格。

进入方法：以管理员身份登录后台 -> 界面 -> 界面设置。

界面设置 -> “全局”，如下图所示：

看到上图，其选项的具体含义：

站点默认风格 - 设置站点默认使用风格

论坛显示版块跳转菜单 - 让用户可以有一个快速的下拉菜单可以快速切换版块

启用浮动窗口 - 当用有主题操作如发帖，回帖，或登录等操作的时候，显示快速的操作窗口。站长可以在这里开启自己需要的。

积分变动提示 - 一个用户体验很好变动提示，可以让用户在发生积分操作的时候有一个直观的认识。

界面设置 -> “论坛首页设置”，如下图所示：

论坛热点 - 用来控制是否显示论坛相关的热点主题

首页显示版块的下级子版块 - 在论坛首页版块中显示下级子版块。

首页显示友情链接 - 论坛首页开启友情链接的显示

显示边栏 - 关闭与显示论坛首页边栏的开关

首页显示生日人数 - 0为关闭显示，大于0则显示相应个数的过生日的会员

显示在线用户 - 更改是否在论坛首页和板块内部显示在线的用户

缩略显示在线列表 - 如果确认显示在线用户，那么这里就可以设置是否默认为显示状态。

最多显示在线人数 - 0为不限制，但只有在显示在线用户启用时才有效

隐藏无权访问的版块 - 不在列表中显示当前用户无权访问的版块

界面设置 -> “主题列表页”，如下图所示：

每页显示主题数 - 主题列表中每页显示主题数目

主题列表最大页数 - 主题列表中用户可以翻阅到的最大页数，建议设置为默认值 1000，或在不超过 2500 范围内取值，0 为不限制

启用全局置顶 - 选择“是”，置顶 III 的主题将在全部论坛显示，置顶 II 的主题将在当前分区中显示。

置顶主题的标识 - 以英文状态下的逗号分割，只有三项有效，级别依次为从高至低

显示主题列表分割带 - 选择“否”，在主题列表页将不显示置顶主题与普通主题之间的分割带

显示最近访问版块数量 - 设置在版块列表和帖子浏览中，显示的最近访问过的版块下拉列表数量，建议设置为 30 以内，0 为关闭此功能、

界面设置 -> “主题列表页”，如下图所示：

每页显示帖数 - 帖子列表中每页显示帖子数目

星星升级阈值 - 星星数在达到此阈值(设为 N)时，N 个星星显示为 1 个月亮、N 个月亮显示为 1 个太阳。默认值为 2，如设为 0 则取消此项功能，始终以星星显示

签名最大高度(px) - 设置帖子中允许显示签名的最大高度

签名显示条件 - 只有帖子字数大于指定数值后才显示签名

是否在页面上显示评分理由 - 选择否就不在页面上显示评分理由，只保留评分数字

评分条目数 - 在帖子中显示最近评分结果的条目数

是否显示作者签名 - 顾名思义

是否显示作者头像 - 顾名思义

是否显示帖内图片 - 顾名思义

帖内图片最大宽度 - 当帖内图片宽度大于设置的值时图片宽度会被自动调节。如为整数，图片的宽度不会超过您所设置的值。如为百分比，图片的宽度将根据不同风格自由调整为百分比适当的大小。宽度最大不能超过 1920

是否使用图片动态放大效果 - 当帖内图片宽度大于“帖内图片最大宽度”时是否附加鼠标点击时的动态放大效果。选择“是”单击图片会有动态放大效果，选择“否”将会新窗口打开图片

快速发帖 - 底部显示快速发帖表单

显示推荐表情 - 在快速发帖右侧显示推荐表情。推荐的表情需要到“ - 表情管理”中设置

显示作者在线状态 - 是否显示帖子作者的在线状态

显示作者的组头衔 - 设置在帖子中是否显示作者的用户组头衔

帖子顺序单位 - 设置帖子显示顺序编号的单位，如“#”将显示为 1 #

帖子顺序名称 - 设置每篇主题所有帖子的顺序名称，每行填写一个名称，第一行代表主题帖，第二行代表主题的第一个回复，以此类推

最大单一表情解析次数 - 在一篇帖子中解析的单一表情符号的最大次数，超过此次数限制的表情将不被解析而保留原样，以避免用户在一篇帖子中恶意发表大量表情影响正常阅读，0 为不限制

作者用户名显示位置 - 显示位置并不会影响论坛的性能和美观，请根据您会员的浏览习惯进行选择。

设置用户信息显示的位置 - 可以设置用户信息的显示位置和显示顺序。如在帖内左侧或作者头像菜单。

界面设置 -> “主题列表页”，如下图所示：

提示信息停留时间（秒）- 各种提示信息页面显示时间的长短，一般设置为 1-3。较短的提示时间让用户拥有快速的体验，但是也可能让用户无法看清信息。

开启直接/快速跳转 - 对于站点中的某些成功的操作不显示提示信息，直接跳转到下一个页面，例如发帖，回复等等，可以节省用户等待跳转的时间

直接/快速跳转的信息 - 当开启直接/快速跳转以后，以下信息将会直接跳转。每行填写一个信息的关键字。

界面设置 -> “弹出信息”，如下图所示：

此功能可以给用户在进行注册、登录、发帖、回复时提示一些很有趣的句子，引导用户进行操作。

弹出信息停留时间（秒） - 各种弹出信息显示时间的长短，一般设置为 3-10，0 为鼠标点击后消失

其余的则是每行写一条信息，多条信息将会随机显示。

当您熟悉了界面设置以后，就可以充分发挥Discuz! X1在界面定制上的优势。


风格管理

界面 —— 风格管理

通过风格管理，您可以设置论坛的默认风格，也可以设置页面的颜色、背景等显示，还可以导入自己下载下来的风格。

功能的位置：后台 => 界面 => 风格管理，如下图所示：

一、编辑风格：后台 => 界面 => 风格管理 => 管理 => 编辑，如下图所示：

进入后就可以对风格进行详细的设置了。

二、导出风格：后台 => 界面 => 风格管理 => 管理 => 导出，如下图所示：

三、复制风格：后台 => 界面 => 风格管理 => 管理 => 复制，如下图所示：

四、恢复风格：后台 => 界面 => 风格管理 => 管理 => 恢复，如下图所示：

恢复风格后，界面的方案将恢复到初始设置。

五、设置默认风格：后台 => 界面 => 风格管理 => 管理，勾选要设置为默认风格旁边的“默认”复选框，点击提交即可，如下图所示：

六、卸载风格：后台 => 界面 => 风格管理 => 管理，勾选要卸载的风格旁边的“卸载”复选框，点击提交即可，如下图所示：

七、导入新风格：后台 => 界面 => 风格管理 => 导入，如下图所示：

1、请选择导入方式：可选择上传文件方式或粘贴文本方式。两者的效果是一样的，数据来源也是一样的。

2、允许导入不同版本 Discuz! 的界面：勾选此复选框，允许导入不同版本 Discuz! 的界面，但容易发生错误。建议使用相同版本的风格。


模板管理

界面 —— 模板管理

通过模板管理，可以对模板套系进行管理，比如添加或者删除。

进入后台 => 界面 => 模板管理，如下图所示：

一、添加模板：

1、把要添加的模板的文件上传至 template 文件夹下，如\template\new。

2、在“新增”后面的文本框中，输入模板名称，目录及版权信息，然后点击提交即可，如下图所示：

3、添加成功后，可以进入后台 => 界面 => 风格管理，点击安装，如下图所示：

二、删除模板：勾选要删除的风格全面的复选框，然后点击提交即可删除该风格，如下图所示：


表情管理

界面 —— 表情管理

在论坛交流中，表情可以协助用户更加生动形象地表达自己。产品自带了三套表情，站长可以在后台启用或关闭某套表情。还可以导出、导入、自行添加或删除表情等，下面请看详细介绍。

后台 => 界面 => 表情管理，即可看到下图所示：

一、导出导入表情

后台 => 界面 => 表情管理 ，即可看到下图所示：

如果想导入从另一 Discuz! 论坛后台导出的表情，清点击上方的“导入表情”如下图所示：

表情文件导入后，您还需要上传表情图片文件到相应的表情目录（static/image/smiley/表情目录/）下，该套导入的表情才可以正常使用。

二、添加表情

如果您有一套表情图片，可以直接自行添加表情。

首先，上传该套表情图片到论坛根目录的 static/image/smiley/ 下，如下图所示：

然后，论坛后台 => 界面 => 表情管理，即可看到如下图所示：

为您刚才上传的表情设置表情分类名，然后点击“提交”。

添加好后，您可以在表情分类页面，点击添加表情后面的“详情”来查看，如下图所示：

到此为止，您已经成功添加了一套表情，前台发帖时即可使用。

三、设置某套表情为默认表情

论坛后台 => 界面 => 风格管理 => 编辑，如下图所示：

设置该风格的默认表情分类，如下图所示：

前台发帖，即可看到新添加的表情为默认表情，如下图所示：


表态动作

界面 —— 表态动作

本功能用于设置日志/图片/文章表态动作，动作图片中请填写图片文件名，并将相应图片文件上传到 static/image/click/ 目录中，每个类型最多启用 8 个动作。

表态动作位置：后台 ＝> 界面 => 表态动作

一、添加新动作

首先将预添加的新动作上传到 static/image/click/ 目录中，如下图所示：

然后到后台 ＝> 界面 => 表态动作，点击下方的“添加新动作”，如下图所示：

最后，点击“提交”，即可看到新添加的表态动作，如下图所示：

二、删除表态动作

选中动作前面的方框，点击下面的“提交”即可删除，如下图所示：

同样的方法可以试用于图片动作和文章动作。


主题图章

界面 —— 主题图章

主题鉴定图章可以在帖子主题内显示一个图章，使得看帖更加具有趣味性。下面主要讲述下管理、使用和添加的操作。

一、管理和使用

后台 => 界面 => 主题鉴定图章，可以看到如下图所示：

1、可以直接修改图章的ID以及图章名称；

2、删除图章：勾选图章前方框，点击底部的提交；

3、关联到其他关联操作：默认的只有3个可以关联的操作：精华、置顶、推荐；如果设置了关联，图章会在执行相应操作时被自动添加到主题中；

例如精华图章关联精华操作，如下图所示：

4、直接给帖子主题添加鉴定图章：前台使用管理组的账号，在帖子上方的主题管理可以看到主题鉴定，如下图所示：

点击进去可以看到设置，如下图所示：

选择一个图章后，帖子可以看到图章，如下图所示：

点击确定后完成给主题帖添加图章。

二、如何添加图章

1、登录 Ftp ，将做好的图章图片文件上传到 static/image/stamp/ 目录下；

2、后台 => 界面 => 主题图章 => 添加,如下图所示：

可以看到新上传的图片文件，勾选前面的方框，点击提交，如下图所示：

提交后可以在后台 => 界面 => 主题鉴定图章看到新加的图章。

备注：系统预留了 100 个主题鉴定图章的位置，分别为图章 ID 0 至 99，不要随意修改图章 ID，否则将会导致主题中已使用的图章错乱。


编辑器设置

界面 —— 编辑器设置

编辑器是用户发表观点必须使用的工具。Discuz! X1 的编辑器更为人性化，使用起来方便快捷。站长可以在管理后台设置编辑器模式及表情的显示； Discuz! 还自带了四种 Discuz! 代码，站长只需在后台开启即可在站点使用，同时还可以添加自定义 Discuz! 代码。下面请看详细介绍：

论坛后台 => 界面 => 编辑器设置，如图：

一、设置编辑器

论坛后台 => 界面 => 编辑器设置 => 全局，如下图所示：

二、Discuz!代码

论坛后台 => 界面 => 编辑器设置 => Discuz!代码，如下图所示：

您还可以新增 Discuz!代码，填写新增 Discuz!代码的标签名，然后点击“提交”，如下图所示：

点击新增 Discuz! 代码后面的“详情”，即可详细设置该代码的各项参数，如下图所示：

设置完毕，点击“提交”添加成功。

然后，论坛后台 => 界面 => 编辑器设置 => Discuz!代码，设置新增 Discuz!代码标签的图标，并开启和显示，如下图所示：

前台发帖即可看到,如下图所示：

注意：

1、在浮动窗口发帖时最多只能显示约 22 个图标，超出的将自动隐藏，请控制好显示在编辑器中的 Discuz! 代码数量。

2、出于安全考虑，如果您启用了 [flash] 等不安全代码，请务必在用户组权限中设置，建议设置为只有特殊用户组或管理组可以使用，以免带来可能的安全问题。

3、只有在自定义 Discuz! 代码可用并设置了图标文件时，具有“允许使用自定义 Discuz! 代码”权限的用户组在发帖时才会看到相应自定义 Discuz! 代码按钮。


在线列表图标

界面 —— 在线列表图标

在线列表图标用于区分在线成员列表中会员的身份。当您打开在首页或分版块显示在线用户功能时，首页或分版块的在线会员列表中每个会员名称前都会显示其对应用户组图例。该功能使得查看在线会员的同时，还可以知道该会员所属的系统用户组。

论坛后台 => 界面 => 在线列表图标，如下图所示：

下面请看详细介绍：

一、添加或更换列表图标

论坛后台 => 界面 => 在线列表图标，进入在线列表图标管理界面，如下图所示：

注意：用户组图例处空白为不区分该组用户，所有未区分的用户组将统一归入第一行的“普通用户”项。

如果要为某个用户组添加图标或更换某个用户组图标，首先把相应图片文件上传到 .static/image/common/ 目录中，以独立主机为例（虚拟主机上传到相对应的目录即可），如下图所示:

然后，论坛后台 => 界面 => 在线列表图标，为某个用户组添加“用户组图例”或修改某个用户组的“用户组图例”为刚才上传的图片文件名，以游客为例，为其添加用户组图例“online_visitor.gif”，如下图所示:

二、后台开启显示在线会员

在线列表图标只有在在线列表功能打开时有效。

论坛后台 => 界面 => 界面设置 => 论坛首页设置，如下图所示：

开启后，管理员访问站点时即可在前台看到，如下图所示：

至此，在线列表图标设置完毕。


Discuz! X1 后台使用 — 内 容

审核帖子：论坛开启了审核主题功能之后，部分会员的主题或者回复需要站长或版主审核后才会在论坛的页面显示出来。

主题管理：通过批量主题管理，您可以对搜索到的主题进行批量删除、移动、分类/取消分类、删除、置顶/取消置顶、设置/取消精华、打开/关闭以及删除主题中的附件等操作；请先根据条件搜索主题，然后选择相应的操作。

批量删帖：批量删帖仅用于删除违规帖子使用，如您需要批量删除历史旧帖，请使用批量主题管理功能。

附件管理：可以用于清理论坛的附件，删除站点的多余附件。

主题回收站：版块开启主题回收站功能之后，所有删除的帖子都存在回收站里，并没有被直接删除，如果有误删的帖子，这个时候就就可以找回来了，如果您没有开启该功能，帖子就被直接删除，无法找回。

词语过滤：为站点设置禁止直接发布的词语，可以更好的防止会员发布违规信息。

用户举报：批网站每天都会有大量的用户来浏览，回帖，难免有管理不到的地方,用户举报的功能可以帮助站长来加强网站的管理，也是站长认识用户的一个窗口。

附件类型尺寸：允许您自定义站点允许上传的附件类型和附件大小，注意这里是全局的附件类型设置。

多版块置顶：可让一个主题在任意多个版块内置顶显示。

帖子优化：主要用于优化回复数量较多的主题在显示时候的性能。

记录管理：通过记录管理功能，站长可以方便的搜索和管理到用户所发表的记录内容。

日志管理：日志信息管理用于删除日志使用，并且连同对应的回复一同删除。

动态管理：动态管理用于删除动态(feed)使用。

相册管理：批量相册管理用于删除相册使用。连图片一同删除。

图片管理：用于删除图片使用,连图片评论一同删除。

评论/留言管理：用于删除留言使用。

分享管理：用于删除分享使用。


审核帖子

内容 —— 审核帖子

对于论坛的特定版块，管理者可能不希望会员发表的主题或回复直接显示出来，而是必须通过管理者的审核后，这些主题或者回复才能显示。Discuz! 提供了审核帖子的功能，使得管理者有效控制用户所发表的信息，最大程度地避免违规内容的出现。下面详细介绍该功能的应用。

一、审核功能的开启

开启审核功能需要在后台设置两处，下面依次介绍：

1、开启论坛相应版块的审核功能

管理员进入论坛后台 => 论坛 => 版块管理 => 编辑特定版块，如下图所示：

然后点击“帖子选项”，开启指定版块的审核功能，如下图所示：

发帖审核：选择“是”将使用户在本版发表的帖子待版主或管理员审查通过后才显示出来，打开此功能后，您可以在用户组中设定哪些组发帖可不经审核，也可以在管理组中设定哪些组可以审核别人的帖子

2、设置论坛中发帖需要审核的用户组

管理员进入论坛后台 => 用户 => 用户组 => 点击指定用户组后的“编辑”，也可以选择“批量编辑”如下图所示：

点击“编辑”后，进入用户组权限编辑界面，然后点击论坛相关 => 帖子相关，设置“允许直接发帖”，如下图所示：

允许直接发帖：是否允许直接发帖或者对回复及主题进行审核，此设置受版块审核影响，如果版块设置为不需要审核，则此设置无效。同时此设置影响词语过滤功能，只有设置为允许审核，词语过滤设置才有效。

3、设置具有审核权限的管理组

管理员进入论坛后台 => 用户 => 管理组 => 点击指定管理组后的“管理权限” ，进入管理组权限设置界面的管理中心权限，如下图所示：

允许审核帖子：设置是否允许审核用户发表的帖子，只在论坛设置需要审核时有效。选择“是”，超级版主和版主就可以在论坛首页 => 管理面板 => 审核，进行审核操作了。如下图所示：

版主只能审核本版内的新帖，超级版主可以审核全部需要审核的新帖。完成上述三步操作后，发帖审核的相关权限就全部开启了。

二、审核帖子功能的使用

开启帖子审核功能后，会员在发表新帖时，出现提示信息，如下图所示：

发表后，提示需要审核，如下图所示：

具有发帖审核权限的超级版主或者版主，进入“管理面板”，即可实现对新发帖子的审核，如下图所示：

同样，管理员也可以登录后台进行帖子审核，后台 => 内容 => 审核帖子 ，如下图所示：

1、审核范围：有未审核和已忽略两个选项

已忽略：可以搜索出以前忽略的帖子来重新进行审核。

未审核：显示所有未审核主题。

2、审核版块：可以选择要审核的主题所在的版块，也可以选择所有版块。

3、批量操作：可以点击下面的全部删除，全部通过，全部忽略进行新主题的批量操作。也可以点击每个需要审核的主题左边的单选框进行单个审核。

4、编辑主题：点击下面的编辑主题可以对主题进行编辑，编辑后还可以输入编辑的理由。

点击“提交”，完成审核，如下图所示:


主题管理

内容 —— 主题管理

这个功能搜索出符合一定条件的主题，然后进行批量的操作。包括：批量移动到版块、批量移动到分类、批量删除、批量置顶、批量设置精华、批量打开关闭、删除主题中的附件。下面主要介绍一下这个功能的使用方法，进入系统后台 => 内容 => 批量主题管理。

一、搜索符合条件主题

管理员可以设置搜索条件，划定搜索范围，如下图所示：

1、显示详细主题列表： 选择“是”，则在搜索结果中列出符合条件的主题详细信息；选择“否”，则只会在结果中显示出符合条件的主题数量。

2、 所在版块：按照主题所在的版块进行搜索。

3、 发表时间范围：按照主题发表的时间范围进行搜索。

4、 主题作者：按照主题的作者进行搜索。

5、 标题关键字：按照帖子标题所含关键字进行搜索。

勾选“更多选项”，可以列出更多条件供选择，如下图所示：

1、所在分类信息：按照帖子的分类信息进行搜索。

2、被浏览次数介于：按照帖子被浏览的次数进行搜索。

3、被回复次数介于：按照帖子被回复的次数进行搜索。

4、所需阅读权限高于：按照帖子的阅读权限进行搜索。

5、售价高于：按照帖子的售价进行搜索。

6、多少天内无新回复：搜索几天内没有回复的帖子。

7、所在主题分类：帖子所在主题分类的包含方式。

8、是否包含置顶帖：搜索的帖子中是否包含已经置顶的帖子。

9、是否包含精华帖：搜索的帖子中是否包含精华贴。

10、是否包含附件：是否搜索包含附件的帖子。

11、是否包含评分帖：是否搜索有评分的帖子。

12、是否包含高亮帖：是否搜索高亮显示的帖子。

二、批量操作主题

管理员设置好搜索范围后，点击“提交”，即进入搜索结果页面，管理员在此页面，可以进行批量主题管理，如下图所示：

1、批量移动到版块：是指把主题批量移动到指定版块。

2、批量移动到分类信息：是指把主题批量设置为指定分类信息。

3、批量删除：是指把帖子批量删除掉，可以选择删贴不减会员的发贴数和积分。即把会员的帖子删除了，但是会员的发贴数和积分并没有减少。

4、批量置顶：是指把帖子批量置顶，或批量解除置顶。

5、批量设置精华：是指把帖子批量设置为精华贴，或批量解除精华。

6、批量打开关闭：是指把帖子批量打开，或者关闭。

7、删除主题中的附件：可以批量删除主题中的附件。

管理员设置好管理操作后，点击“提交”，即可完成批量主题管理过程。


批量删帖

内容 —— 批量删帖

批量删帖仅用于删除违规帖子使用，系统将根据所输入的帖子的信息（包括：所在版块、发表时间范围、发帖用户名、发帖IP、内容关键字、内容最小长度）来获取帖子，然后进行批量删除。如您需要批量删除历史旧帖，建议使用批量主题管理功能。

一、进入设置

1、Discuz! X1后台 => 内容 => 积分设置

二、筛选批量删除帖子条件

1、显示详细帖子列表：是否显示搜索到的帖子的详细信息。

显示帖子详细信息。

不显示帖子详细信息。

2、发表时间范围：格式 yyyy-mm-dd，不限制请输入0。

3、发帖用户名：发帖用户名，若有多个，用‘,’分割。

4、发帖IP：发帖IP，可使用通配符'*'对某网段进行筛选，慎用！

5、内容关键字：内容内包含的关键字。多个关键字用','分割，关键词可以用限定符{*}，表示出现的次数。

6、内容最小长度：帖子内容的最小长度，开启后会加重服务器负担。

7、点击‘提交’。

三、删除筛选后的帖子

1、若选择了‘显示详细帖子列表’，则可以看到所选择的帖子的详细信息，此时可以勾选相应的复选框决定是否删除。

2、删贴不减用户发帖数和积分：若勾选则对用户发帖数和积分数没有影响，否则会减去用户相应的发帖数和积分。

3、点击‘提交’即可删除筛选的所有帖子和主题。

四、注意事项

1、批量删帖仅用于删除违规帖子使用，如您需要批量删除历史旧帖，请使用批量主题管理功能。

2、使用此功能，需同时提供起始时间和终止时间其中之一，及发帖用户名、发帖 IP、内容关键字其中之一，至少共二项必要的条件，否则将无法进行操作。

3、如果符合删除条件的帖子为主题第一帖，或该主题无回复，将删除整个主题。

4、如果您不是论坛管理员，您只能删除从某一时间到现在的范围内的帖子。

5、超级版主的删帖的时间范围为二星期(14 天)；版主的时间范围为一星期(7 天)且只能删除所管辖论坛内的帖子。

6、关键字可以使用限定符 {x} 以限定相邻两字符间可忽略的文字，x 是忽略字符的个数，如 "a{1}s{2}s"(不含引号) 可以搜索到 "ass" 也可搜索到 "axsxs" 和 "axsxxs" 等等。


附件管理

内容 —— 附件管理

附件是一个论坛中重要的一部分，用户需要使用附件功能进行图片展示，文件共享等交流活动。因此对附件的有效管理也就变得十分重要。

论坛自带了对附件的管理功能。通过这个管理功能，管理员可以根据条件搜索附件，对搜索到的附件进行删除、下载、打开附件所在主题，还可以对附件的数据表进行整理，将服务器上已经不存在的附件的信息在数据表中删除，减小附件表的数据量，进而增加附件检索的速度。

附件管理功能在后台 => 内容 => 附件管理，如下图所示，

1、附件的管理操作

1）搜索条件的说明

只搜索记录存在但文件缺失的附件：选中“是”前面的点，则只会搜索数据库中存在附件记录而附件文件夹中并不存在的附件。

所在版块：搜索特定板块的附件，可以选择全部版块，也可以搜索指定版块。

附件尺寸介于：搜索介于某个尺寸的附件，单位为字节，不填写为不限制。

被下载次数介于：搜索下载次数介于某个数的附件，不填写为不限制。

发表于多少天以前：搜索多少天前上传的附件，不填写为不限制。

文件名；对文件名进行模糊查询，不填写为不限制。

描述关键字：多个关键字可以用逗号隔开，对关键词进行模糊查询，不填写为不限制。

作者：搜索由某个会员上传的附件，不填写为不限制。

这些参数可以根据其中之一进行搜索，也可以根据两个或两个以上的条件进行查询。

2）管理

附件的管理，主要包括附件的删除、下载、查看附件所在主题。当按查询条件提交以后，会看到类似下图所示的搜索结果：

搜索出来的插件的详细信息都整齐排列出来了，需要删除某个附件的话可以勾选相应的附件前面的框，然后点击下面的“提交”即可完成操作。如果要删除所有搜索到的附件，

可以勾选“提交”按钮左边的框，所有附件就会被删除干净。这里的删除包括删除附件在数据的信息和真实的附件文件，所以在删除之前一定要谨慎操作。

点击最后面的“下载”链接，可以下载到这个附件。点击所在主题下面的链接，可以访问到发布这个附件的相应主题。

2、删除冗余附件

1）搜索的时候在“只搜索记录存在但文件缺失的附件:”下面的单选框选“是”。如下图所示：

2）搜索出来的列表就是文件不存在的附件，根据自己的情况将这些附件记录删除。如下图所示：


主题回收站

内容 —— 主题回收站

很多站长为版主删除帖子而困扰，因为可能版主一时疏忽或者跟帖子作者闹矛盾，而滥用自己的权利，将帖子删除了。作为站长，这是他们最不想看到的情况，那怎样避免和防止这种情况的发生呢？很显然，版主在其管理的版块里删除帖子是很合情合理的事情，如果删除了帖子，管理员还能将删除的帖子恢复，那样就最好不过了。Discuz! X 的主题回收站就是这个功能，将前台删除的主题先放到主题回收站里，以便管理员进一步确认是否删除。

需要注意的是这个功能需要在 Discuz! X 后台开启才可以，首先这个功能是跟每个版块关联的，所以每个版块都有此项设置，即可以控制哪些版块开启主题回收站的功能。在管理中心 => 论坛 => 版块管理 => 编辑要开启主题回收站的版块 => 帖子选项中，就可以设置这个版块开启或者关闭主题回收站。

如果版块太多，一个一个版块开启太麻烦的话，还可以到管理中心 => 站长 => 数据库 => 升级 => “常用 SQL 升级语句”里面选取“开启所有版块主题回收站”。

开启之后，在开启了回收站的版块中删除的帖子被删除后就会进入回收站了，不会彻底的删除。可以进入管理中心 => 内容 => 主题回收站，来使用此功能。

一、主题列表

打开主题回收站后，默认是按照主题被删除的时间排列的。可以选择对某个或者全部主题进行彻底删除操作，或者恢复操作。

二、搜索

主题回收站中，可以根据不同的版块，作者，标题关键字，删除管理员，帖子时间等等条件进行搜索，并对搜索出来的帖子进行处理。

可以对搜索结果进行删除，还原的操作，如果不想操作可以选择忽略。

三、清理

清理功能可以对回收站中删除时间超过了指定天数的帖子进行清空。避免回收站过大，占用太多数据库空间。


词语过滤

内容 —— 词语过滤

词语过滤是对会员发布内容中非法或骂人的词语进行过滤，以保证网站内容的文明，合法。

词语过滤分为三种：替换、禁止、审核，分别进行词语替换、禁止发布、先审核后发布操作。

过滤词即可以单独添加，也可以批量添加。

一、下面我们来看一下后台界面，后台 => 内容 => 词语过滤 ，如图所示：

点击“显示全部提示...”，可以显示所有的帮助信息

替换关键词：将内容中非法的词语替换成合法的词语，如：aaa 替换成 AAA

禁止关键词：包含被禁止关键词的内容将不允许发布，如：N{2}D，此关键词等价于 NND

审核关键词：包含审核关键词的内容将会被放进待审箱，如：黄色

非法词语有三种写法：

1、具体的字符，如：aaa

2、范围字符，使用限定符 {x} 以限定相邻两字符间可忽略的文字，如：N{2}D

3、使用正则，以"/"(不含引号)开头和结尾则表示格式为正则表达式，这时替换内容可用"(n)"引用正则中的子模式，如："/1\d{10}([^\d]+|$)/" 替换为 "手机(1)"

根据上图中的设置我们来回复帖子，效果如图：

选择中过滤词前面的复选框可以删除过滤词

二、批量添加

如果你有一份完整的过滤词库可以通过批量添加，方便进行操作，如图：

每行一组过滤词语，不良词语和替换词语之间使用“=”进行分割。

如果只是想将某个词语直接替换成 **，则只输入词语即可。

不导入已经存在的词语：只导入数据库中不存在的非法词语。

使用新的设置覆盖已经存在的词语：系统会覆盖当前的过滤词库，对于没有的，进行添加。

清空当前词表后导入新词语，此操作不可恢复，建议首先 导出词表 , 做好备份：系统会先清空当前的过滤词库，然后添加新的过滤词。

如果想备份之前的词语，可以点击“导出词表”链接，进行导出工作。


用户举报

内容 —— 用户举报

网站每天都会有大量的用户来浏览，回帖，难免有管理不到的地方。

用户举报的功能可以帮助站长来加强网站的管理，也是站长认识用户的一个窗口。

一、在浏览网站时，在每个页面的右下脚有“举报当前面”的链接，如图：

二、后台 => 内容 => 用户举报，如图：

可以通过举报理由来分析举报是否合理，并进行相应的处理。

删除：对不合理的举报进行删除处理。

处理中：对于合理的举报可以设置为处理中，方便进行后续的操作。

金钱：可以对举报的用户进行金钱奖励或处罚。

点击“设置用户举报奖惩使用的积分”，如图：

周期：设置多长时间奖励一次

奖励次数：设置一个周期内奖励多少次，0 为不限次数

extcredits1(威望)：每次奖励多少威望

extcredits2(金钱)：每次奖励多少金钱

extcredits3(贡献)：每次奖励多少贡献

点击“已处理记录”，如图：

可以将已经处理过的记录删除。


附件类型尺寸

内容 —— 附件类型尺寸

一、使用说明

1、本设置用于限制用户上传附件的最大尺寸（按字节算），可以分文件类型来设置。

2、本设置仅用于限制附件的上传，对以图片方式上传的文件无效。

3、本设置限制的是论坛帖子中的上传附件和群组话题中的上传附件。

二、具体设置步骤：

首先进入后台相关设置

后台 => 内容 => 附件类型 => 尺寸

1、添加新的附件类型。

点击 添加新附件类型 按钮。会出现两个文本框，在其中分别填上要限制的扩展名（使用小写英文）和最大尺寸（字节数，仅填数字，不支持 + - * / 运算），然后提交。

其中有几个注意点：

1）填写文件后缀名的时候请不要加点“.”，加点会导致无法识别。

2）您可以设置某类附件最大尺寸为 0 以禁止这类附件被上传。

2、修改已有的附件类型尺寸。

添加完的附件类型尺寸限制会显示在该设置的列表中，如要修改，请直接修改该表单后提交。

3、附件类型尺寸限制的删除。

如果要删除已有的限制，请勾选其前面的复选框，点击提交。

三、效果：

在后台设置了附件尺寸限制之后，论坛的发帖及编辑页面的高级模式中的附件上传就会受到限制。如果对应类型的附件尺寸超过限制，则上传不了。


多版块置顶

内容 —— 多版块置顶

一、使用说明。

本设置可以让一个主题在任意的多个版块内置顶显示。

二、设置步骤。

首先进入后台相关设置

后台 => 内容 => 版块置顶

1、添加置顶帖。

点击 添加 后，在 主题 URL 中输入要置顶的主题的 URL，然后选择目标版块。

其中的主题 URL不支持伪静态地址，要输入常规的URL，如：http://bbs.com/forum.php?mod=viewthread&tid=3&extra=page%3D1，如果没有开启伪静态的话，建议直接从前台的主题列表中复制链接地址。

在选择目标版块的时候可以用 Ctrl 或 Shift 进行多选。

在填好主题URL和目标板块之后点击提交按钮即可完成置顶帖的添加。

2、管理置顶帖。

选择管理标签可以对现有的多版块置顶进行管理。

1）删除多版块置顶。勾选多版块置顶列表前端的复选框然后提交即可。

2）更改置顶的目标版块。

点击要修改的置顶贴的最右方的 更改目标版块 后，选择目标版块并提交即可。操作同添加多版块置顶。


帖子优化

内容 —— 帖子优化

本功能主要用于优化回复数量较多的主题在显示时候的性能，通常情况下，当帖子回复数量超过5000或者预计此贴的回复数量将会在5000以上的时候，您可以将该主题加入优化队列。当然您也可以在这里将任意一个回复较多的主题放入优化队列。

此功能的设置位于：产品后台 => 内容 => 帖子优化

下图中的列表表示已经加入优化的帖子列表，在此列表中可以了解到每个加入优化的帖子的ID、标题、所属版块、总回复数、发表日期。

一、添加帖子到帖子优化

点击上图导航栏中的“添加”，进入添加页面，如下图所示：

添加新的帖子进入优化列表，分为两步操作：

1、搜索主题：根据提供的搜索条件，如回复数大于一定的数值，或直接是定主题的tid，将符合条件的主题搜索出来。

2、添加优化：在搜索出来的主题列表前均有复选框，勾选对应主题的复选框，点击“添加优化”按钮，即可将勾选的主题添加到优化列表中。

二、删除帖子优化

在帖子优化主题列表中，勾选主题前的复选框，点击删除优化，即可将勾选的主题从优化列表中删除。如下图所示：

三、重建帖子优化

如果在访问被优化的主题出现了访问出错，可以尝试重新创建以下该主题的优化。

在帖子优化主题列表中，勾选主题前的复选框，点击重建优化，即可对勾选的主题重建优化。如下图所示：

提示：

1、当主题进入优化队列后，我们不建议对该主题的某个帖子进行删除操作，如果该内容确实违规，我们建议您屏蔽它即可。

2、当您发起抢楼活动的时候，系统会自动将抢楼的主题放入优化队列。发起抢楼贴，在发帖页面右侧的附加选项中勾选“抢楼贴”即可。


记录管理

内容 —— 记录管理

通过记录管理功能，站长可以方便的搜索和管理到用户所发表的记录内容。

记录管理在后台 => 内容 => 记录管理，如下图所示：

一、搜索

1、显示详细记录列表：可以在搜索的时候选择搜索出来的记录是否显示详细列表。

2、搜索可以根据发表记录用户名、发表记录IP、内容关键字、内容最小长度和发表时间范围等条件进行搜索。

二、删除

可以勾选搜索出来的记录前面的框对相应的记录进行删除。

三、提示：

1、批量记录信息管理用于删除记录使用，并且连同对应的回复一同删除。

2、关键字可以使用限定符 {x} 以限定相邻两字符间可忽略的文字，x 是忽略字符的个数，如 "a{1}s{2}s"(不含引号) 可以搜索到 "ass" 也可搜索到 "axsxs" 和 "axsxxs" 等等。

3、提醒：点击搜索结果页的删除按钮，将会直接删除相关信息！


日志管理

内容 —— 日志管理

Discuz! X1 中的日志管理功能，可以进行批量日志信息管理，用于删除日志使用，删除日志时会连同对应的回复一同删除。

日志管理的位置：

管理中心 => 内容 => 日志管理

首先搜索出符合管理条件的日志，搜索条件包括用户 UID、日志 ID、发表日志用户名，标题或内容关键字、内容最小长度、日志查看数、回复数、热度、发表时间范围，可以单项搜索，也可以组合搜索。

其中，关键字可以使用限定符 {x} 以限定相邻两字符间可忽略的文字，x 是忽略字符的个数，如 "a{1}s{2}s"(不含引号) 可以搜索到 "ass" 也可搜索到 "axsxs" 和 "axsxxs" 等等。

对搜索出的符合条件的日志，可以对其进行进行删除操作。


动态管理

内容 —— 动态管理

Discuz! X1 中的批量动态管理用于删除动态(feed)使用。

动态管理位置：

管理中心 => 内容 => 动态管理

一、动态管理

首先搜索出要进行批量管理的动态，搜索条件包括用户 UID、发表动态用户名、动态 ID、动态类型、热度、发表时间范围。

对搜索出的符合条件的动态，可以批量进行删除。

二、全局动态

全局动态，就是会在站内任何一个成员的好友动态里面都会出现的动态，每个成员都能第一时间看到。站长可以灵活使用全局动态来发布一些公开的信息。

在 动态管理 => 全局动态 中，填写好要发表的全局动态的标题、内容、备注、图片地址和链接、发布时间等信息后，就可以发表了。需要注意的是全局动态的发布时间，可以通过填写一个将来的日期和时间，使这条动态会在这个将来的日期到来之前，一直显示在第一位。

全局动态的前台显示如下图:


相册管理

内容 —— 相册管理

Discuz! X1 中的相册管理功能用于批量删除相册使用，删除相册时会连同相册中的图片一同删除。

相册管理位置：

管理中心 => 内容 => 相册管理

首先搜索出符合管理条件的相册，搜索条件包括相册名、相册 ID、用户 UID、相册所有者、更新时间范围。

对符合条件搜索出的相册，可以进行批量删除。


图片管理

内容 —— 图片管理

Discuz! X1 中的图片管理功能用于批量删除图片使用，删除图片时会连同图片的评论一同删除。

图片管理位置：

管理中心 => 内容 => 图片管理

首先搜索出符合管理条件的图片，搜索条件包括所在相册 ID、图片所有者、图片 ID、发布 IP、热度、上传时间范围。

对符合条件搜索出的图片，可以进行批量删除。


评论/留言管理

内容 —— 评论/留言管理

Discuz! X1 中的评论/留言管理功能用于批量删除评论/留言使用。

评论/留言管理位置：

管理中心 => 内容 => 评论/留言管理

首先搜索出符合管理条件的评论/留言，搜索条件包括评论类型、留言 ID、评论者、评论者 ID、被评论者 UID、评论内容、发布 IP、评论时间范围。

对符合条件搜索出的评论/留言，可以进行批量删除。


分享管理

内容 —— 分享管理

Discuz! X1 中的分享管理功能用于批量删除分享(share)使用。

分享管理位置：

管理中心 => 内容 => 分享管理

首先搜索出符合管理条件的分享，搜索条件包括用户 UID、发表分享用户名、分享 ID、分享类型、热度、发表时间范围。

对符合条件搜索出的分享，可以进行批量删除。


Discuz! X1 后台使用 — 用 户

用户管理：通过用户管理，您可以进行编辑会员资料、用户组、权限、积分，授予会员勋章以及删除会员等操作。请先根据条件搜索用户，然后选择相应的操作。

添加用户：为站点增加新的用户。

用户栏目：为站点设置更加丰富的会员资料，有利于聚合会员。您可以通过该功能可以增加或隐藏用户扩展资料。

资料审核：对于用户栏目中的某一项，当设置了其修改后需要审核后，每次会员在个人资料中修改此项后，修改内容都会自动进入到待审核的资料中。

资料统计：统计的用户资料与用户栏目设置有关：只有表单元素为下拉框或单选框的会做统计。

发送通知：当站长有重要事项需要通知站内的会员时，可以在 Discuz! X1 的后台管理中心批量发送通知。

禁止用户：对违规用户的惩罚方式，有两种禁止方式：禁止访问和禁止发言，还可以禁止的同时选择删除该用户的帖子，该功能主要用于乱码广告和灌水的帐户禁止。

禁止 IP：设置不允许访问站点的 IP，该功能的意义同禁止用户，通过禁止一些用户的 IP 地址或地址段来限制这些用户正常访问站点。

积分奖惩：从积分的方面对会员进行奖励和惩罚，即增减积分。

审核新用户：如果站点开启人工审核新注册会员，站长在此审核新注册会员。

管理组：设置具备管理权限的用户组权限。

用户组：Discuz!X 按照用户组的机制来对论坛的会员进行权限管理和分配，我们可以在管理中心中管理用户组。

明星会员：Discuz! X1 的明星会员沿袭了原 UCenter Home 的推荐会员功能，站长可以手动把表现活跃的会员推荐到首页上，受到更多其他会员的关注，可以更好地增进网站用户之间的互动。

推荐好友：Discuz! X1 的推荐好友改进了原 UCenter Home 的默认好友功能，站长可以通过设置，默认将指定会员推荐给新注册会员，让新注册会员选择添加好友。该功能可以增加新手会员与网站管理层的接触，提高网站的互动性。


用户管理

用户 —— 用户管理

用户管理，即站长在后台管理用户的功能。

您可以：

1、管理用户（编辑会员的资料、用户组、权限、积分，授予会员勋章，查找马甲以及删除会员等）；

2、清理用户（通过条件匹配批量删除用户）；

3、找出会员使用的马甲。

下面将分三点详述使用方法：

进入管理中心(后台) => 用户 => 用户管理，如图：

一、管理用户

在进行管理操作之前，请先通过搜索，找到想要管理的用户。进入管理中心(后台) => 用户 => 用户管理 => 搜索，如图：

填写好搜索条件后，点击”搜索“按钮，将会列出所有符合条件的用户。（如果什么都不填，将会列出所有用户）如图：

勾选左侧的复选框，然后点击”提交“按钮可删除选中的用户。右边管理功能如下：

1）用户组

点击”用户组“链接，即可跳转到用户组编辑页面。如图：

用户组分为主用户组和扩展用户组，会员在网站上的权限是以主用户组为准，同时通过扩展用户组，延伸会员在特殊版块的权限,如:浏览，发新话题，发表回复，下载/查看附件，上传附件/图片等权限。

举个例子说明一下：

论坛上有一个”VIP 专版“，只有”VIP 用户”这个特殊用户组的会员才能访问和发帖，而用户 A 是”板块1“的版主。

如果要让用户A既能管理”板块1“，又能访问”VIP专版“，就需要将用户 A 的主用户组设置为”版主“，扩展用户组设置为”VIP 用户“组。

其他情况也以此类推，通过扩展用户组方式实现会员的多权限、多身份。

注：只有系统用户组和特殊用户组才会在扩展设置中列出。

设置用户组后，点击“提交”生效。

2）权限

点击“权限”链接，如图：

这里可以设置用户的特殊权限，作用类似扩展权限设置，扩展会员在论坛版块的浏览，发表和回复主题，下载/查看附件，上传附件/图片等权限。和设置扩展用户组不同的是：这里针对当前用户，而不是整个用户组。

注：“主题查看权限”是基本权限，如果禁止此项，其他权限将会自动禁止。

提交后，用户的特殊权限将在上面显示出来：

3）积分

点击“积分”链接，即可对用户的积分进行设置。如图：

点击“提交”即可生效。

4）勋章

点击“勋章”，即可给该用户颁发勋章。如图：

勾选想要颁发给该用户的勋章，然后点击“提交”即可。

5）马甲

点击“马甲”，会列出所有这个会员的马甲。如图：

勾选左侧的复选框，然后点击”提交“按钮可删除选中的马甲用户。

6）详情

点击“详情”，可以修改用户的资料。其中站长比较常用的是修改用户密码和删除违规头像。如图：

另外还可以修改用户的其他资料及用户浏览论坛时的论坛选项设置。这里不一一介绍。

二、清理用户

站长可以设置查找条件，批量删除符合条件的用户。还可以选择是否在删除用户帐号的同时，删除用户发帖和 UCenter 中的用户资料。

进入管理中心(后台) => 用户 => 用户管理 => 清理，如图：

设置好搜索条件，点击“删除用户”按钮，将显示符合条件用户的个数。如图：

勾选“删除用户发帖”：在删除该用户的同时，也会删除该用户曾经发过的帖子。该操作比较费时，请耐心等待。

勾选“删除 UCenter 中用户资料”：在删除该用户的同时，也删除 UCenter 中的资料。

最后，点击“确定”，批量删除用户。

三、马甲

Discuz!从7.2版本开始提供查找并清理马甲的功能，让站长更加方便的管理网站中的马甲帐号。

进入管理中心(后台) => 用户 => 用户管理 => 马甲，如图：

用户名：可以搜索出该用户名都有哪些马甲；

用户UID：可以搜索出该 UID 下有哪些马甲；

IP 地址：可以搜索出该 IP 地址下有哪些马甲；

设置好后，点击“提交”按钮后，就会列出符合条件的会员列表。如图：

从上图可以看到马甲帐号的信息，可以按照会员管理中介绍的方法进行管理操作。

如果要删除，请勾选用户名前的复选框，然后点击下面的“提交”按钮即可删除马甲帐号。


添加用户

用户 —— 添加用户

站长可以在管理后台直接添加用户。

进入管理中心(后台) => 用户 => 添加用户：

用户名：可以设置添加用户的用户名（示例中为：用户1）；

密码：设置添加用户的登录密码（示例中为：123456）；

Email：设置添加用户所用 Email（示例中为：abc@comsenz.com）；

用户组：为新添加的用户设置一个初始用户组,可以是新手会员用户组,也可以是管理组（示例中为：新手上路组）；

发送通知到上述地址：选择“是”，将发送通知到添加用户的 Email 中（在示例中,如果选择是,通知邮件将会发送到 abc@comsenz.com 这个邮件地址）；

填写完毕，点击“提交”即可。

提交后效果如下,提示添加成功.


用户栏目

用户 —— 用户栏目

在产品提供的现有用户资料项目不能满足站长需求时，站长可以通过用户栏目为用户扩展更多的自定义资料项目。

此功能的设置位于：产品后台 => 用户 => 用户栏目

下图中的列表列出了当前系统中所有的用户栏目

列表中的用户栏目分为两类：系统内置字段和自定义字段。系统内置字段不可以修改它的栏目名称和栏目介绍，自定义字段则可以进行修改，两个类型的用户栏目中的其他设置均可以进行修改。

点击某一项用户栏目后面的“编辑”，进入用户栏目的设置界面，如下图所示：

图中以“真实姓名”用户栏目为例。

真实姓名的栏目名称和栏目介绍不可以修改，由此可以看出他是一个系统内置字段。

表单类型：表示该字段的类型，分为单行文本框、多行文本框、单选框、多选框、下拉菜单、多选列表框，共6种。

单行文本框、多行文本框会提供如下图所示的设定项，包括：

大小限定：最多可填写的字符数或最多可选择的项数

正则验证：检验输入数据的正则表达式

单选框、下拉菜单会提供如下图所示的设定项，包括：

可选值：每行输入一个作为选项的值

多选框、多选列表框会提供如下图所示的设定项，包括：

大小限定：最多可填写的字符数或最多可选择的项数

可选值：每行输入一个作为选项的值

在所有的用户栏目中，有一些是不允许设置表单类型的。

是否启用：设置为“是”，用户才可以填写此项内容

提交后不可修改：设置为“是”，用户在第一次填写好此内容后，将不可以再次修改

修改后需要审核：设置为“是”，则用户在每次更新此字段后均会提交给管理员进行人工审核，在审核期间仍可以对此内容进行重新编辑，来修改提交给管理员审核的内容，在管理员通过此内容前，用户的个人资料将不会被更新。

是否必填：设置为“是”，则在用户提交个人资料时必须填写此项内容。

资料页面隐藏：设置为“是”，则不论个人隐私如何设定都不会在个人空间资料页面显示。

默认隐私：此处设置此项用户资料的隐私权限，可设置为“公开”、“好友可见”、“保密”三种。

在帖子中显示：设置为“是”，则此项用户资料会出现在“产品后台 => 界面 => 界面设置 => 帖子内容页”最下端的“设置用户信息显示的位置”的列表中，此列表中的用户资料才可以设置让其出现在贴内左侧或是作者头像菜单中。

允许搜索：设置为“是”，则此项用户资料会出现前台“查找好友”的“高级方式查找”页面内。

显示顺序：设置的值越大在此项用户资料的排列越靠前。

对于自定义字段1~自定义字段8，8个自定义字段，是允许修改其栏目名称和栏目介绍的。


资料审核

用户 —— 资料审核

Discuz! X1 提供了多种用户栏目可供会员填写，增加会员个人资料的多样性，会员之间可以通过对方的资料更深入地了解对方。

对于用户栏目中的某一项，当设置了其修改后需要审核后，每次会员在个人资料中修改此项后，修改内容都会自动进入到待审核的资料中。

在 管理中心 => 用户 => 资料审核 中，根据用户 UID、审核项（依赖于用户栏目中设置修改后需要审核的栏目项）、提交时间搜索出待审核的用户资料。

对待审核的用户资料的管理，除了可以批量通过或忽略该审核，也可以同时设置该用户升级到某个用户组，和给用户增加扩展积分值。


资料统计

用户 —— 资料统计

为了更好地了解站点内用户各项资料的分布情况，帮助站长给自已的站点找到准确的定位，Discuz! X1 提供了用户的资料统计功能。纳入统计的用户资料与用户栏目设置有关，只有表单元素为下拉框或单选框的才会加入到统计项中。

查看用户资料统计：

管理中心 => 用户 => 资料统计

以用户组为例，通过下图可以看出站点内用户的用户组分布情况。

每个统计项都通过比例视图提供直观的比例显示、通过用户数（比率）提供具体的数字和百分比，站长可通过手动更新统计项和更新数据获得最新的统计结果。


发送通知

用户 —— 发送通知

当站长有重要事项需要通知站内的会员时，可以在 Discuz! X1 的后台管理中心批量发送通知。

发送通知的方法：

管理中心 => 用户 => 发送通知

一、选择发送通知的会员

选择给哪些会员发送通知时，可以采用搜索的方法，筛选中符合条件的会员，Discuz! X1 内置的搜索条件包括用户名、用户 UID、主用户组、Email、积分范围、发帖数范围、IP、注册时间、访问时间、发帖时间及用户信息等。

二、填写通知并发送

搜索到符合接收通知条件的会员后，发送方式选择 Email 或站内通知，并设置分批发送数量，填写通知标题及通知内容后提交即可。


禁止用户

用户 —— 禁止用户

如果发现 Discuz! X 中有用户发布广告，恶意灌水，发表禁止的内容时，管理员可以对此用户进行禁止操作，对其进行禁止访问或禁止发言等，可以有效的避免在 Discuz! X 中出现不良信息，保护站点的安全。

禁止用户：对违规用户的惩罚方式，有两种禁止方式：禁止访问和禁止发言，还可以禁止的同时选择删除该用户的帖子，该功能主要用于乱码广告和灌水的帐户禁止。

1、禁止用户的方法

首先进入 Discuz! X 后台，点击用户=> 禁止用户，如下图所示：

填入要禁止用户的用户名，选择禁止用户的类型，设置禁止用户的有效期，选择是否删除禁止用户的帖子，填写禁止会员的理由。

2、禁止用户的类型

禁止发言：会员可以登录 Discuz! X ,但是无法浏览帖子和发表言论；

禁止访问：会员登录之后无法浏览 Discuz! X 中的任何内容。被禁止访问的会员登录DiscuzＸ后会出现如下提示：

3、禁止用户的前台操作方法

在浏览帖子页面时，如果发现某个会员发布违规信息，可以点击会员名下面的管理选项，然后点击“禁止”。如下图所示：


禁止 IP

用户 —— 禁止 IP

如果发现 Discuz! X 中有来自某一个或某一段 IP 地址的用户发布广告，恶意灌水，发表禁止的内容时，管理员可以对此IP地址进行禁止可以有效的避免在 Discuz! X 中出现不良信息，保护站点的安全。

禁止 IP：设置不允许访问站点的 IP，该功能的意义同禁止用户，通过禁止一些用户的 IP 地址或地址段来限制这些用户正常访问站点。

禁止IP的方法：

Discuz! X后台，点击用户=> 禁止IP，如下图所示：

可以填入被禁止的具体IP地址，也可以使用通配符“*”来禁止某一IP地址段。被禁止IP的用户将在禁止有效期时无法登录 Discuz! X。

另外，管理员在前台查看帖子的时候，也可以对IP进行查看和禁止。如图所示：


积分奖惩

用户 —— 积分奖惩

在论坛管理中，积分或威望是对会员进行奖励与惩罚的一种方式，通过积分与威望可以间接的限制会员的权限，规范会员的行为。

在后台 => 用户 => 积分奖惩中可以设置，如图：

可通过用户名、用户UID、主用户组 搜索 目标用户

勾选“更多选择”，可以设置更多的搜索条件，方便于定位特定的目标用户；

设置好搜索条件后，点击“搜索”按钮进行搜索，如图：

积分奖惩：正数(如：5)为加分，负数(如：-5)为减分；

积分清零：将符合条件的用户的某一项积分清零。

勾选“发送积分变更通知”，如图：

可设置通知的标题与内容。

可选择 Email 或 通知 方式来发送通知。

如果奖惩的用户较多，可设置“分批发送数量”。

点击“提交”，即可完成积分奖惩，如图：


审核新用户

用户 —— 审核新用户

在 Discuz! 中，管理员可以对新注册的用户进行审核，以确定是否允许该用户注册。

审核新用户，需要在后台“开启人工审核功能”，后台 => 全局 => 注册与访问控制 => 注册，如图：

选择“人工审核”，保存，新用户注册时，需要输入注册原因，如图：

输入注册原因后，提交会提示需要等待管理员审核，如图：

审核新注册用户，后台 => 用户 => 审核新用户，如图：

可进行单独审核或批量审核；管理员可对审核的用户留言；可选择是否发送 Email 通知被审核用户。

清理功能可将待审核的符合条件的用户，直接清理掉，后台 => 用户 => 审核新用户 => 清理，如图：


管理组

用户 —— 管理组

该设置可以设置站点具备管理权限的用户组权限。

进入管理中心 => 用户 => 管理组，来进行设置。

Discuz!X 管理组包括管理员、超级版主、版主三个内置管理组以及自定义管理组，除管理员组以外，其他管理组均可详细设置管理权限。

下面以超级版主为例，讲解一下管理组的各项设置。

一、基本设置

点击超级版主的“基本设置”链接，如下图所示：

1、基本设置

1）用户组头衔：设置用户组头衔名称。

2）组图标：设置该用户组的图标，可以选择是输入 URL 或者是上传图片。

3）允许访问论坛：选择“否”将彻底禁止用户访问站点的任何页面。

4）阅读权限：设置用户浏览帖子或附件的权限级别，范围 0～255，0 为禁止用户浏览任何帖子或附件。当用户的阅读权限小于帖子或附件的阅读权限许可(默认时为 1)时，用户将不能阅读该帖子或下载该附件。

5）最多好有数：该用户组的用户能够拥有的最多好友数量。

6）允许隐身：是否允许用户在站点上隐身。

7）允许加入/离开公众用户组：是否允许该用户组用户在站点加入或者离开公共用户组。

8）允许积分转账：设置是否允许用户在个人中心将自己的交易积分转让给其他用户。注意: 本功能需在 全局设置中启用交易积分后才可使用。

9）允许发送短消息：设置是否允许用户发送短消息

10）允许使用 HTML 代码：是否允许用户发布信息的时候使用 HTML 代码。

11）允许查看趋势统计：是否允许用户在个人中心中查看站点的趋势统计。

12）允许全文搜索：是否允许用户进行全文搜索，此设置只对搜索论坛有效。

13）允许使用搜索：选择为该用户组用户开启哪些模块的搜索。

14）操作理由短消息通知作者：设置用户在对他人评分或管理操作时是否强制输入理由和通知作者。

15）允许自定义头衔：设置是否允许用户设置自己的头衔名字并在帖子中显示。

16）不受时间段限制：设置用户是否可以不受全局设置中设置的特殊时间段禁令限制。

17）会员每小时发帖数限制：设置允许会员每小时最多的发帖数量，可以配合灌水预防功能进一步限制会员的发帖，可设置为 1～255 范围内的数值，0 为不限制。此功能会轻微加重服务器负担, 且对游客无效。

18）启用防灌水验证机制：如果站点开启了验证码或者验证问答，该用户组是否可以绕过这个验证。

19）发表不受限制：设置发表是否不受灌水预防和最大字数限制等。

2、论坛相关 => 帖子相关

1）允许发新话题：设置是否允许发新话题。注意: 只有当用户组阅读权限高于 0 时，才能发新话题。

2）允许发表回复：设置是否允许发表回复。注意: 只有当用户组阅读权限高于 0 时，才能发表回复。

3）允许直接发帖：是否允许直接发帖或者对回复及主题进行审核，此设置受版块审核影响，如果版块设置为不需要审核，则此设置无效。

4）是否允许发站外URL：是否允许发帖包含URL，合理的设置可以有效的减少广告帖的量。

5）允许发匿名帖：是否允许用户匿名发表主题和回复，只要用户组或本论坛允许，用户均可使用匿名发帖功能。匿名发帖不同于游客发帖，用户需要登录后才可使用，版主和管理员可以查看真实作者。

6）允许设置帖子权限：设置是否允许设置帖子需要指定阅读权限才可浏览。

7）主题(附件)最高售价：主题(附件)出售使得作者可以将自己发表的主题(附件)隐藏起来，只有当浏览者向作者支付相应的交易积分后才能查看主题(附件)内容。此处设置用户出售主题(附件)时允许设置的最高价格，0 为不允许用户出售。

8）允许使用 [hide] 代码：设置是否允许帖子中使用 [hide] 隐藏标签。

9）允许使用自定义 Discuz! 代码：设置是否解析用户帖子中的自定义 Discuz! 代码。注意: 自定义 Discuz! 代码由管理团队成员在管理中心中自行定义，不包括系统内置的数十种代码。

10）允许签名中使用 Discuz! 代码：设置是否解析用户签名中的 Discuz! 代码。

11）允许签名中使用 [img] 代码：设置是否解析用户签名中的 [img] 代码。

12）签名文字最大长度：设置用户签名最大字节数，0 为不允许用户使用签名。

13）主题评价影响值：设置用户评价一次主题，对主题评价指数的影响，0 为不允许用户评价主题。

14）编辑帖子时间限制：帖子作者发帖后超过此时间限制将不能再编辑帖，版主和管理员不受此限制，0 为不限制。

15）帖子点评：设置用户允许点评的帖子。注意: 只有全局的帖子点评设置中允许点评楼主贴时，本设置中的点评楼主贴功能才生效。

16）允许发表点评观点：允许用户在点评时发表观点。注意：只有在全局的帖子点评设置中设置了点评观点后，本设置才会生效。

3、论坛相关 => 附件相关

1）允许下载/查看附件：设置是否允许在没有设置特殊权限的论坛中下载或查看附件。

2）允许发布附件：设置是否允许上传附件到没有设置特殊权限的论坛中。

3）允许设置附件权限：设置是否允许设置附件需要指定积分以上才可下载。

4）允许发布图片：设置是否允许上传图片到没有设置特殊权限的论坛中。

5）空间大小(单位M)：设置最大相册空间尺寸(单位M)，0 为不限制。

6）最大附件尺寸(单位K 1M=1024K)：设置用户上传的每个附件的最大尺寸。

7）每天最大附件总尺寸(单位K 1M=1024K)：设置用户上传的每天总附件的总尺寸。

8）每天最大附件数量：设置用户每天允许上传多少个附件。

9）允许附件类型：设置允许用户上传附件的类型。

4、论坛相关 => 特殊主题

1）允许发起活动：选择“是”允许在论坛发布活动主题。

2）允许发起投票：选择“是”允许在论坛发布投票主题。

3）允许参与投票：选择“是”允许在论坛参与投票。

4）允许发起悬赏：选择“是”允许在论坛发布悬赏主题，悬赏使用交易积分。

5）最小悬赏积分：每笔悬赏最少悬赏积分(最小设置为 1)。

6）最大悬赏积分：每笔悬赏最多悬赏的积分，最大可设置为 32767 (不限制请输入 0)。

7）允许发布商品：选择“是”允许在论坛发布商品主题。

8）最小交易金额：每笔交易的最小交易金额(单位：人民币 元，最小交易金额为 1 元)。

9）最大交易金额：设置每笔交易所能设置的最大交易金额(单位：人民币 元，不限制请输入 0)。

10）商品主题最多推荐商品数：设置用户在每篇商品主题中最多推荐商品的数目。

11）允许发起辩论：选择“是”允许在论坛发布辩论主题。

12）允许发表抢楼帖：选择“是”则抢楼帖不允许用户删除回帖。

5、群组相关

在这里可以设置允许改用户组建立多少个群组，0 为不允许创建。

6、门户相关

设置是否允许用户组用户在门户发布文章。

7、空间相关

1）二级域名最短长度：个人空间二级域名的最短长度，0 为不允许设置二级域名。

2）发表日志：是否允许在个人空间中发布日志。

3）发表记录：是否允许在个人空间中发表记录。

4）上传图片：是否允许上传照片，同时这个会影响论坛的编辑器上上传图片的功能。

5）发布分享：是否允许发布分享。

6）允许打招呼：是否允许跟其他用户打招呼。

7）允许加好友：是否允许加其他用户为好友。

8）允许表态：是否允许对日志表态。

9）发表留言/评论：是否允许发表留言/评论。

10）允许使用漫游(Manyou)应用：是否允许使用漫游应用游戏。

11）不受视频认证限制：该用户组是否可以不受视频认证限制。

12）允许查看视频认证：该用户组用户是否允许查看视频认证信息。

13）允许自定义模块使用HTML：空间中添加的自定义模块是否允许使用 HTML 代码。

14）允许自定义模块使用BBCODE：空间中添加的自定义模块是否允许使用 BBCODE 代码。

15）允许自定义模块使用[img]：空间中添加的自定义模块是否允许使用 [img] 代码。

8、其他 => 积分相关

1）发短消息不扣积分：设置发短消息是否按照积分规则扣积分。

2）搜索不扣积分：设置搜索是否按照积分规则扣积分。

3）允许参与评分：允许该用户组用户在给其他用户评分的时候可以评哪种积分，以及可以评分的最大值与最小值，和24小时评分总量。

9、其他 => 道具相关

1）允许使用道具：是否允许使用道具，包括购买、使用、转让的权限。

2）购买道具折扣：购买道具的折扣值，范围 1~10 数值越小折扣越多。

3）最大携带重量：本组用户带有道具的最大重量，范围 1~65533。注：每个道具重量由道具设置决定。

10、其他 => 注册相关

1）允许购买邀请码：是否允许购买邀请码。

2）允许发送邀请注册：是否允许通过论坛邮件系统发送邀请码。

3）邀请码购买价格：该用户组的会员购买邀请码的价格。

4）24小时内购买邀请码最大数量：该用户组24小时内购买邀请码的最大数量，超过此数量将不能购买新的邀请码。

5）邀请码有效期：该用户组购买邀请码的最大有效期，超过此有效期验证码将自动失效，单位为天，默认为10。

二、管理权限

点击用户组后面的“管理权限”，可以进入管理权限设置页面。

1、主题管理权限

1）允许置顶主题：设置是否允许置顶管理范围内主题的级别。如果打开全局置顶的功能，置顶 III 将全论坛置顶，置顶 II 将在当前分类置顶

2）允许精华主题：设置是否允许精华管理范围内主题的级别。

3）允许提升主题：设置是否允许提升管理范围内的主题。

4）允许高亮主题：设置是否允许高亮管理范围内的主题。

5）允许推荐主题：设置是否允许推荐管理范围内的主题 (要在相应版块的扩展设置里开启推荐主题功能) 。

6）允许鉴定主题：置是否允许鉴定管理范围内的主题。

7）允许关闭主题：设置是否允许关闭管理范围内的主题。

8）允许移动主题：设置是否允许移动管理范围内的主题。

9）允许编辑主题分类：设置是否允许编辑管理范围内主题的分类。

10）允许复制主题：设置是否允许复制管理范围内的主题。

11）允许合并主题：设置是否允许合并管理范围内的主题。

12）允许分割主题：设置是否允许分割管理范围内的主题。

13）允许修复主题：设置是否允许修复管理范围内的主题。

14）允许强制退款：允许将作者发布的收费主题终止，并将作者所获得收益退还给购买者。退款后，该主题将不能再被设置为收费主题，同时作者将自行承担积分交易而产生的损失。

15）允许编辑投票：设置是否允许编辑管理范围内投票主题的选项。

16）允许移除悬赏：设置是否允许移除管理范围内悬赏主题的悬赏金额。

17）允许管理活动报名者：设置是否允许管理范围内活动主题的报名者。

18）允许编辑商品：设置是否允许编辑管理范围内商品主题的商品。

2、帖子管理权限

1）允许编辑帖子：设置是否允许编辑管理范围内的帖子。

2）允许警告帖子：设置是否允许警告管理范围内的帖子。

3）允许屏蔽帖子：设置是否允许屏蔽管理范围内的帖子。

4）允许删除帖子：设置是否允许删除管理范围内的帖子。

5）允许置顶回帖：设置是否允许置顶管理范围内的回帖。

3、管理面板权限

1）允许审核帖子：设置是否允许审核用户发表的帖子，只在站点设置需要审核时有效。

2）允许审核用户：设置是否允许审核新注册用户，只在站点设置需要人工审核新用户时有效。

3）允许禁止用户：设置是否允许禁止用户发帖或访问。

4）允许禁止 IP：设置是否允许添加或修改禁止 IP 设置。

5）允许编辑用户：置是否允许编辑用户资料。

6）允许批量删帖：设置是否允许通过管理面板批量删帖，版主在面板中批量删帖的范围是 1 周内，超级版主删帖范围是 2 周内，管理员无限制。

7）允许编辑版块：设置是否允许编辑管理范围内的版块的资料。

8）允许发布公告：设置是否允许发布站点公告。

9）允许查看管理日志：设置是否允许查看管理日志。

4、空间管理权限

1）允许管理动态(feed)：是否允许管理空间中产生的 feed。

2）允许管理记录：是否允许管理用户发表的记录。

3）允许管理分享：是否允许管理用户的分享。

4）允许管理日志：是否允许管理用户的日志。

5）允许管理相册：是否允许管理用户的相册。

6）允许管理评论：是否允许管理用户的评论。

7）允许管理道具记录：是否允许管理道具记录。

8）允许管理举报：是否允许管理举报信息。

9）允许管理推荐成员：是否允许管理推荐成员。

10）允许管理推荐好友：是否允许管理推荐好友。

11）允许管理视频认证：是否允许管理视频认证。

12）允许管理道具：是否允许管理道具。

13）允许管理表态动作：是否允许管理表态动作。

5、门户管理权限

1）允许管理文章：是否允许管理门户文章。

2）允许创建专题：是否允许创建门户专题。

3）允许管理专题：是否允许管理门户专题。

4）允许 DIY：是否允许 DIY 门户首页。

6、其他权限

1）发表不受限制：设置发表是否不受灌水预防和最大字数等。

2）允许查看 IP：设置是否允许查看用户 IP。


用户组

用户 —— 用户组

Discuz! X 按照用户组的机制来对论坛的会员进行权限管理和分配，我们可以在管理中心中管理用户组。

进入管理中心 => 用户 => 用户组，来进行设置。

Discuz! X 中的用户组包括会员用户组、特殊用户组、系统用户组。

一、三种用户组介绍

1、会员用户组

会员用户组是普通会员的用户组，该用户组根据会员的积分而自动授予会员。在此处可以设置各个用户组需要的最低积分，提交修改的时候系统会自动修改上一用户组的最高积分。点击用户组后面的详情可以设置该用户组的详细权限。

2、特殊用户组

特殊用户组是管理员手工创建的用户组。

点击“特殊用户组”，可以进入特殊用户组的设置。

点击“添加新特殊用户组”,可以添加一个新的用户组，可以自定义组头衔，星星数，头衔颜色和组头像。

在添加完成之后，可以点击“查看”来查看当前有多少用户在这个特殊用户组里面，点击“详情”来设置特殊用户组的权限。

用户被加入特殊用户组后，将不受会员用户组级别的限制。

3、系统用户组

系统用户组是系统内部已经内置了的8个用户组。点击“系统用户组”，可以进入系统用户组设置页面。

在这里，可以修改几个默认的系统用户组的名称与星星数目等，同样，点击详情可以看到用户组的具体设置。

二、用户组详细权限设置

现在以我们在特殊用户组中添加的“亲友团”用户组为例，讲解一下用户组的详细设置。进入管理中心 => 用户 => 用户组 => 特殊用户组，添加了一个新的名为“亲友团”用户组之后，点击详情进行编辑。

1、基本设置

1）用户组头衔：设置用户组头衔名称。

2）组图标：设置该用户组的图标，可以选择是输入 URL 或者是上传图片。

3）允许访问论坛：选择“否”将彻底禁止用户访问站点的任何页面。

4）阅读权限：设置用户浏览帖子或附件的权限级别，范围 0～255，0 为禁止用户浏览任何帖子或附件。当用户的阅读权限小于帖子或附件的阅读权限许可(默认时为 1)时，用户将不能阅读该帖子或下载该附件。

5）最多好有数：该用户组的用户能够拥有的最多好友数量。

6）允许隐身：是否允许用户在站点上隐身。

7）允许加入/离开公众用户组：是否允许该用户组用户在站点加入或者离开公共用户组。

8）允许积分转账：设置是否允许用户在个人中心将自己的交易积分转让给其他用户。注意: 本功能需在 全局设置中启用交易积分后才可使用。

9）允许发送短消息：设置是否允许用户发送短消息

10）允许使用 HTML 代码：是否允许用户发布信息的时候使用 HTML 代码。

11）允许查看趋势统计：是否允许用户在个人中心中查看站点的趋势统计。

12）允许全文搜索：是否允许用户进行全文搜索，此设置只对搜索论坛有效。

13）允许使用搜索：选择为该用户组用户开启哪些模块的搜索。

14）操作理由短消息通知作者：设置用户在对他人评分或管理操作时是否强制输入理由和通知作者。

15）允许自定义头衔：设置是否允许用户设置自己的头衔名字并在帖子中显示。

16）不受时间段限制：设置用户是否可以不受全局设置中设置的特殊时间段禁令限制。

17）会员每小时发帖数限制：设置允许会员每小时最多的发帖数量，可以配合灌水预防功能进一步限制会员的发帖，可设置为 1～255 范围内的数值，0 为不限制。此功能会轻微加重服务器负担, 且对游客无效。

18）启用防灌水验证机制：如果站点开启了验证码或者验证问答，该用户组是否可以绕过这个验证。

19）发表不受限制：设置发表是否不受灌水预防和最大字数限制等。

2、用户组体制

特殊用户组体制分为“非公众用户组”、“公众用户组”、“收费公众用户组”、“免费公众用户组”。根据不同的用户组体制设置来决定的。

1）公众用户组：设置是否为公众用户组。注意: 使用此功能前请确定是否确实需要，否则用户一旦自行加入本组，即便之后再设置本组为非公众用户组，仍然无法将用户从该组中批量去除，除非删除本用户组。公众用户组不能关联管理组，以免产生安全隐患。

2）收费公众用户组日价格：如果您需要用户支付相应的交易积分后才能加入本用户组，请在此输入本组的日购买价格，单位为交易积分所使用的单位。例如设置为 2，则用户购买为期 30 天的本组权限，需要支付 2*30=60 个交易积分，30 天有效期后该用户将自动从本组中退出。如设置为 0，则本组为免费公众用户组。注意: 本功能需要首先设定用户组为公众用户组且设置了有效的交易积分后才有效。

3）收费公众用户组一次最短购买时间(天)：设置用户在购买本组权限时，一次支付价值至少多少日的交易积分，请设置为大于等于 1 的数值。例如日价格为 2，最短购买时间为 10，则用户至少需要花费 2*10=20 个交易积分，获得至少 10 天本组权限，才能加入本组。注意: 本功能需要首先设定用户组为收费公众用户组才有效。

3、论坛相关 => 帖子相关

1）允许发新话题：设置是否允许发新话题。注意: 只有当用户组阅读权限高于 0 时，才能发新话题。

2）允许发表回复：设置是否允许发表回复。注意: 只有当用户组阅读权限高于 0 时，才能发表回复。

3）允许直接发帖：是否允许直接发帖或者对回复及主题进行审核，此设置受版块审核影响，如果版块设置为不需要审核，则此设置无效。

4）是否允许发站外URL：是否允许发帖包含URL，合理的设置可以有效的减少广告帖的量。

5）允许发匿名帖：是否允许用户匿名发表主题和回复，只要用户组或本论坛允许，用户均可使用匿名发帖功能。匿名发帖不同于游客发帖，用户需要登录后才可使用，版主和管理员可以查看真实作者。

6）允许设置帖子权限：设置是否允许设置帖子需要指定阅读权限才可浏览。

7）主题(附件)最高售价：主题(附件)出售使得作者可以将自己发表的主题(附件)隐藏起来，只有当浏览者向作者支付相应的交易积分后才能查看主题(附件)内容。此处设置用户出售主题(附件)时允许设置的最高价格，0 为不允许用户出售。

8）允许使用 [hide] 代码：设置是否允许帖子中使用 [hide] 隐藏标签。

9）允许使用自定义 Discuz! 代码：设置是否解析用户帖子中的自定义 Discuz! 代码。注意: 自定义 Discuz! 代码由管理团队成员在管理中心中自行定义，不包括系统内置的数十种代码。

10）允许签名中使用 Discuz! 代码：设置是否解析用户签名中的 Discuz! 代码。

11）允许签名中使用 [img] 代码：设置是否解析用户签名中的 [img] 代码。

12）签名文字最大长度：设置用户签名最大字节数，0 为不允许用户使用签名。

13）主题评价影响值：设置用户评价一次主题，对主题评价指数的影响，0 为不允许用户评价主题。

14）编辑帖子时间限制：帖子作者发帖后超过此时间限制将不能再编辑帖，版主和管理员不受此限制，0 为不限制。

15）帖子点评：设置用户允许点评的帖子。注意: 只有全局的帖子点评设置中允许点评楼主贴时，本设置中的点评楼主贴功能才生效。

16）允许发表点评观点：允许用户在点评时发表观点。注意：只有在全局的帖子点评设置中设置了点评观点后，本设置才会生效。

4、论坛相关 => 附件相关

1）允许下载/查看附件：设置是否允许在没有设置特殊权限的论坛中下载或查看附件。

2）允许发布附件：设置是否允许上传附件到没有设置特殊权限的论坛中。

3）允许设置附件权限：设置是否允许设置附件需要指定积分以上才可下载。

4）允许发布图片：设置是否允许上传图片到没有设置特殊权限的论坛中。

5）空间大小(单位M)：设置最大相册空间尺寸(单位M)，0 为不限制。

6）最大附件尺寸(单位K 1M=1024K)：设置用户上传的每个附件的最大尺寸。

7）每天最大附件总尺寸(单位K 1M=1024K)：设置用户上传的每天总附件的总尺寸。

8）每天最大附件数量：设置用户每天允许上传多少个附件。

9）允许附件类型：设置允许用户上传附件的类型。

5、论坛相关 => 特殊主题

1）允许发起活动：选择“是”允许在论坛发布活动主题。

2）允许发起投票：选择“是”允许在论坛发布投票主题。

3）允许参与投票：选择“是”允许在论坛参与投票。

4）允许发起悬赏：选择“是”允许在论坛发布悬赏主题，悬赏使用交易积分。

5）最小悬赏积分：每笔悬赏最少悬赏积分(最小设置为 1)。

6）最大悬赏积分：每笔悬赏最多悬赏的积分，最大可设置为 32767 (不限制请输入 0)。

7）允许发布商品：选择“是”允许在论坛发布商品主题。

8）最小交易金额：每笔交易的最小交易金额(单位：人民币 元，最小交易金额为 1 元)。

9）最大交易金额：设置每笔交易所能设置的最大交易金额(单位：人民币 元，不限制请输入 0)。

10）商品主题最多推荐商品数：设置用户在每篇商品主题中最多推荐商品的数目。

11）允许发起辩论：选择“是”允许在论坛发布辩论主题。

12）允许发表抢楼帖：选择“是”则抢楼帖不允许用户删除回帖。

6、群组相关

在这里可以设置允许改用户组建立多少个群组，0 为不允许创建。

7、门户相关

设置是否允许用户组用户在门户发布文章。

8、空间相关

1）二级域名最短长度：个人空间二级域名的最短长度，0 为不允许设置二级域名。

2）发表日志：是否允许在个人空间中发布日志。

3）发表记录：是否允许在个人空间中发表记录。

4）上传图片：是否允许上传照片，同时这个会影响论坛的编辑器上上传图片的功能。

5）发布分享：是否允许发布分享。

6）允许打招呼：是否允许跟其他用户打招呼。

7）允许加好友：是否允许加其他用户为好友。

8）允许表态：是否允许对日志表态。

9）发表留言/评论：是否允许发表留言/评论。

10）允许使用漫游(Manyou)应用：是否允许使用漫游应用游戏。

11）不受视频认证限制：该用户组是否可以不受视频认证限制。

12）允许查看视频认证：该用户组用户是否允许查看视频认证信息。

13）允许自定义模块使用HTML：空间中添加的自定义模块是否允许使用 HTML 代码。

14）允许自定义模块使用BBCODE：空间中添加的自定义模块是否允许使用 BBCODE 代码。

15）允许自定义模块使用[img]：空间中添加的自定义模块是否允许使用 [img] 代码。

9、其他 => 积分相关

1）发短消息不扣积分：设置发短消息是否按照积分规则扣积分。

2）搜索不扣积分：设置搜索是否按照积分规则扣积分。

3）下载附件不扣积分：下载附件是否可以不扣积分。

4）可直接下载收费附件：是否可以直接下载收费附件。

5）可直接查看收费主题：设置是否可以直接查看收费主题

10、其他 => 道具相关

1）允许使用道具：是否允许使用道具，包括购买、使用、转让的权限。

2）购买道具折扣：购买道具的折扣值，范围 1~10 数值越小折扣越多。

3）最大携带重量：本组用户带有道具的最大重量，范围 1~65533。注：每个道具重量由道具设置决定。

11、其他 => 注册相关

1）允许购买邀请码：是否允许购买邀请码。

2）允许发送邀请注册：是否允许通过论坛邮件系统发送邀请码。

3）邀请码购买价格：该用户组的会员购买邀请码的价格。

4）24小时内购买邀请码最大数量：该用户组24小时内购买邀请码的最大数量，超过此数量将不能购买新的邀请码。

5）邀请码有效期：该用户组购买邀请码的最大有效期，超过此有效期验证码将自动失效，单位为天，默认为10。

三、用户组批量编辑

Discuz!X 中新增了用户组的批量编辑功能，在要编辑用户组的时候，选择多个用户组，然后点击批量编辑，就可以进入批量编辑界面。

如提示，按住 alt 键修改那些单选，复选的项目，可以横向的全部选择。

从这里，就可以方便的批量设置多个用户组的设置了。


明星会员

用户 —— 明星会员

Discuz! X1 的明星会员沿袭了原 UCenter Home 的推荐会员功能，站长可以手动把表现活跃的会员推荐到首页上，受到更多其他会员的关注，可以更好地增进网站用户之间的互动。

设置明星会员的方法：

登录Discuz! X1 后台 => 用户 => 明星会员 =>添加推荐

填写要推荐的会员名和推荐原因即可，如下图所示：

明星会员列表，没推荐则为空。可添加推荐。显示顺序的数值越小，推荐优先级越高。

推荐完成后，在DIY中把明星会员模块添加上，方法：

Discuz! X1 前台 => DIY => 添加框架（按需添加模块类型） => 添加模块 （会员类）

拖拽会员类模块到刚才添加的框架，数据来源选 “指定用户”，特殊会员选“明星会员”，如下图所示：

点击确定即可，再点击DIY的保存退出，明星会员就设置完了。


推荐好友

用户 —— 推荐好友

Discuz! X1 的推荐好友改进了原 UCenter Home 的默认好友功能，站长可以通过设置，默认将指定会员推荐给新注册会员，让新注册会员选择添加好友。该功能可以增加新手会员与网站管理层的接触，提高网站的互动性。

设置推荐好友的方法：

登录Discuz! X1 后台 => 用户 => 推荐好友 =>添加好友

填写要推荐的用户名和推荐原因即可，如下图所示：

推荐好友列表，没添加则为空。可添加好友。显示顺序的数值越小，推荐优先级越高。

推荐好友功能就设置完了。当新用户注册时，推荐好友会显示在 “家园” 页面，如下图所示：


Discuz! X1 后台使用 — 门 户

文章分类：Discuz! X1 中可以设置在站点发布文章时供选择的文章分类，最多可以设置三级分类。

日志分类：Discuz! X1 中可以设置用户在发布日志时的选择的日志分类，最多可以设置三级分类。在设置日志分类之前，必须要选择开启系统分类。

相册分类：Discuz! X1 中可以设置用户在建立相册时选择的相册分类，最多可以设置三级分类。在设置相册分类之前，必须要选择开启系统分类。

文章管理：在门户发布的文章，管理员可以在后台进行统一管理。

模块样式：该功能用来添加，编辑和删除模块的样式，用于在前台 DIY 时，插入模块时使用。

模块管理：DIY 的站点首页的时候，可以增加各类想调用的模块。

专题管理：专题是针对一个特定主题，聚合相关信息以传播内容及引导用户参与互动的页面，这里可以创建专题，也可以开启、关闭、删除专题等操作。


文章分类

门户 —— 文章分类

文章分类的设置方法：管理中心 => 门户 => 文章分类

对文章分类的操作包括转移、删除、发布文章和权限管理。

1、转移

对文章分类进行转移时，可以选择把该分类的文章移动到其他分类中，如果该分类下存在子分类，还需要处理子分类，可以选择把子分类直接删除或是移动一级分类。

2、删除

对文章分类进行删除时，可以选择将该分类的文章移动到其他分类中，如果该分类下存在子分类，还需要处理子分类，可以选择把子分类直接删除或是移动一级分类。

3、发布文章

在相应的文章分类后点击“发布文章”，直接进入文章发布页面，填写好文章的各项信息即可发布。查看文章时，可以在导航条中查看文章所属的分类，以及在右边栏显示同级的相关分类。

4、权限管理

此处可以给指定用户增加在门户发布文章、推送文章和管理文章的权限，使站点的文章管理更加灵活。


日志分类

门户 —— 日志分类

Discuz! X1 中可以设置用户在发布日志时的选择的日志分类，最多可以设置三级分类。在设置日志分类之前，必须要选择开启系统分类。

日志分类的设置方法：管理中心 => 门户 => 日志分类 ，

当对某一系统日志分类进行删除时，可以选择将此分类下的日志移动到其他日志分类中。如果该分类下存在子分类，还需要处理子分类，可以选择把子分类直接删除或是移动到上一级分类。


相册分类

门户 —— 相册分类

Discuz! X1 中可以设置用户在建立相册时选择的相册分类，最多可以设置三级分类。在设置相册分类之前，必须要选择开启系统分类。

相册分类的设置方法：管理中心 => 门户 => 相册分类

当对某一系统相册分类进行删除时，可以选择将此分类下的相册移动到其他相册分类中。如果该分类下存在子分类，还需要处理子分类，可以选择把子分类直接删除或是移动到上一级分类。


文章管理

门户 —— 文章管理

在门户发布的文章，管理员可以在后台进行统一管理。

该功能所在位置：管理中心 => 门户 => 文章管理

搜索文章：这里可以根据文章ID、文章标题、作者UID、作者、文章分类和结果排序进行搜索。

移入垃圾箱：把想要删除的文章移入垃圾箱，选择好要删除的文章，直接移动到垃圾箱即可，如下图所示：

移到分类：可以把某篇文章的分类移动到另一个分类下，如下图所示：

垃圾箱：这里的文章可以进行恢复，也可以彻底删除。

发布文章：这里的发布文章会直接跳转到前台的“门户管理”中来进行发布文章操作。


模块样式

门户 —— 模块样式

该功能用来添加，编辑和删除模块的样式，用于在前台 DIY 时，插入模块时使用。

一、功能的位置：后台 => 门户 => 模块样式，如下图所示：

二、功能的使用：

1、添加模块样式：

1）后台 => 门户 => 模块样式，点击添加，在下拉菜单中选择要增加的模块样式的类别，如下图所示：

2）在样式名称处填写新增样式的名称，在下面的文本框中输入模块调用的内容，点击提交即可，如下图所示：

3）添加成功后可以在后台 => 门户 => 模块样式 => 列表中，看到新增的样式，如下图所示：

4）在前台 DIY 时，插入模块的时候，模块的显示样式下拉菜单中可以选择新增样式了，如下图所示：

2、编辑模块样式：

后台 => 门户 => 模块样式 => 列表，点击要修改的模块样式后面对应的编辑，修改模块样式名称或者模块数据调用内容，如下图所示：

3、删除模块样式：

后台 => 门户 => 模块样式 => 列表，点击要删除的模块样式后面对应的删除，即可删除此模块样式，如下图所示：


模块管理

门户 —— 模块管理

DIY 的站点首页的时候，可以增加各类想调用的模块。

一、功能的位置：

后台 => 门户 => 模块管理，如下图所示：

二、功能的使用

1、管理模块

在前台DIY，添加了模块后，添加的模块会全部显示在后台 => 门户 => 模块管理 => 模块列表里，如下图所示：

可以点击模块后面的编辑，修改模块的属性和数据，如下图所示：

2、删除模块

如果模块从未使用过，可以通过清除未使用模块按钮，删除未使用的模块，如下图所示：

3、添加模块

1）后台 => 门户 => 模块管理 => 数据调用，如下图所示：

2）点击添加数据调用，选择要添加的调用类别，如下图所示：

3）在编辑模块页面，设置好模块的属性，点击确定即可，如下图所示：

4）添加成功后，数据调用在门户 => 模块管理 => 数据调用中显示，如下图所示：

5）点击内部调用，复制弹出的内容，加到模板文件中，此调用就可以在添加的位置显示，如下图所示：

如把这段数据调用语句加到 template\default\common\header.htm 文件的 67 行，更新缓存后，首页显示的效果，如下图所示：


专题管理

门户 —— 专题管理

专题功能介绍：专题是针对一个特定主题，聚合相关信息以传播内容及引导用户参与互动的页面，简而言之，专题能聚集用户与内容。同门户首页一样，专题可以通过 DIY 功能方便的整合和展示网站内容。

专题功能解读：专题是门户功能的一部分。之所以推出专题功能，是为了增强网站的媒体属性和商业价值。例如：使用专题后可以对某个事件进行深度报道，一个专题可能集中了 30 个帖子、20 个图片，10 个评论，可以对该事件进行全方位、多角度的深度报道。

如何制作专题：包括怎样添加专题，怎样生成伪静态地址，怎样制作专题背景，如果实现专题聚合页等内容。

一、添加专题

1、后台 => 门户 => 专题管理 => 创建专题，如下图所示：

2、点击创建专题之后，会弹出新建专题的页面，填写相应内容，点击提交，如下图所示：

3、创建新的专题后,就可以 DIY 这个专题了，如下图所示：

二、制作专题背景

1、修改背景颜色：选择自定义 => 背景，点击背景颜色后面的颜色框，选择要修改的颜色，然后保存，如下图所示：

2、添加背景图片：点击浏览，选择要上传的图片，点击开始上传即可，如下图所示：

3、上传成功后，会看到如下图所示的内容，点击上传的图片，选择图片的平铺方式，图片位置，背景是否滚动，设置好后保存即可：

三、生成伪静态地址：首先服务器要支持rewrite规则，如果是虚拟空间的话，需要咨询空间商后，再开启伪静态。如果是自己的服务器可以看下面这两个教程配置rewrite规则。http://faq.comsenz.com/viewnews-11

http://faq.comsenz.com/viewnews-12

1、后台 => 全局 => 优化设置 => 搜索引擎优化 => URL静态化

2、再访问专题时，会发现地址已经变为静态化地址，如下图所示：

四、实现专题聚合页

1、首页点击 DIY，拖拽要添加的框架。

2、在框架中添加专题类模块，各个专题就可以在首页聚合显示了。


Discuz! X1 后台使用 — 论 坛

版块管理：论坛分区和版块的添加、删除、编辑，还有版块的添加等管理。

版块合并：该功能方便站长将两个版块合并为一个版块。

分类信息：为了加强论坛的聚合信息，您可以设置论坛的分类信息。添加分类信息、添加修改分类信息选项等操作，根据站点的类型和会员的喜好您可以设置不同类型的分类，大大增强了站点信息的融合度。


版块管理

论坛 —— 版块管理

站长可以在管理后台管理论坛版块，包括添加新分区、添加新版块、添加子版块、为版块添加版主、设置版块显示顺序及编辑、删除版块等。

Discuz! X1管理后台 => 论坛 => 版块管理

1、添加新分区

点击“添加新分区”：

填写分区名称，点击“提交”完成添加：

2、添加新版块

点击“UCHome活动”版块下方的“添加新版块”，为该分区添加版块：

填写版块名称，点击“提交”：

到前台查看：

说明：当分区下有版块时，才可以在前台正常显示，否则分区无法在前台显示。

3、添加版主

点击“添加版主”，即可为该分区或版块添加版主。

填写要添加为版主的会员名，并设置用户组；

将本版块或分类版主的权力继承到下级版块：如果勾选，那么该版块版主也可以管理该板块的下级版块；

4、编辑分区

点击分区后面的编辑，可以对该分区进行详细信息设置：

分区名称：设置该分区名称；

分区名称颜色：设置该分区名称的显示颜色；

下级子版块横排：设置下级子版块横排时每行版块数量，如果设置为 0，则按正常方式排列；

显示分区：选择“否”将暂时将分区隐藏不显示，但分区内容仍将保留，且用户仍可通过 URL 访问到此分区及其版块；

5、编辑版块

点击版块后面的“编辑”，可以对版块进行详细的个性化设置。

编辑版块的详细设置请查看：基本设置、扩展设置、帖子选项、积分策略、主题分类、分类信息、权限相关。


基本设置

论坛 —— 版块管理 —— 基本设置

这里主要设置版块的一些基本信息，如版块名称，是否显示版块等。

Discuz! X1后台 => 论坛 => 版块管理 => 编辑 => 基本设置：

版块名称：设置版块名称；

版块名称颜色：设置版块名称在前台的显示颜色；

版块图标：版块图标将会显示在版块名称前面，使得版块更加个性化；上传版块的图标，可以直接上传也可以输入 URL 地址；

图标宽度：填写版块的图标宽度，单位：px

顶部图片：上传版块的顶部图片，可以直接上传也可以输入 URL 地址；

显示版块：选择“不显示”将暂时将版块隐藏不显示，但版块内容仍将保留，且用户仍可通过直接提供带有 fid 的 URL 访问到此版块。选择“部分显示”版块将不显示在下拉列表中，但仍会显示在首页或相应版块下；

上级版块：设置本版块的上级版块或分类，可以通过此设置移动过该版块到某个分类或某个版块下；

版块转向URL：如果设置转向 URL(例如 http://www.discuz.com)，用户点击本分版块将进入转向中设置的 URL。一旦设定将无法进入版块页面，请确认是否需要使用此功能，留空为不设置转向 URL；

版块简介：将显示于版块名称的下面，提供对本版块的简短描述，支持内置的 Discuz! 代码；

本板块规则：显示于主题列表页的当前版块规则，留空为不显示，支持内置的 Discuz! 代码；

搜索关键词优化：此关键词用于搜索引擎优化，放在 meta 的 keyword 标签中，多个关键字间请用半角逗号 "," 隔开；

绑定别名：当站点开启 URL 静态化后可通过别名访问此版块；


扩展设置

论坛 —— 版块管理 —— 扩展设置

扩展设置主要是版块下主题列表显示方式等的设置。下面请看详细介绍：

Discuz! X1后台 => 论坛 => 版块管理 => 编辑 => 扩展设置：

下级子版块横排：设置下级子版块横排时每行版块数量，如果设置为 0，则按正常方式排列；

本版块在首页显示下级子版块：首页版块列表中在版块简介下方显示下级子版块名字和链接(如果存在的话)。注意: 本功能不考虑子版块特殊浏览权限的情况，只要存在即会被显示出来。选择“默认”，将使用全局设置；

只显示下级子版块：选择“是” 将不显示本版块的主题列表、发帖按钮等等，类似于一个分类；

显示边栏：选择“是”版块首页侧边将显示聚合本版内容的信息；

显示全局置顶和分类置顶的主题：选择“是”，将在本版显示全局置顶和分版置顶；

主题默认排序字段：设置版块的主题列表默认按照哪个字段进行排序显示。默认为“回复时间”，除默认设置外其他排序方式会加重服务器负担；

主题默认排序方式：设置版块的主题列表默认排序的方式。默认为“按降序排列”，除默认设置外其他排序方式会加重服务器负担；

页面缓存系数：此功能可以将游客经常访问的主题临时缓存起来，缓解大型论坛服务器压力。系数范围 0～100，建议数值 20 ～ 40，0 为关闭缓存。在磁盘空间允许的情况下，适当调高缓存系数，可以提高缓存效果。注：版块设置完毕后请到 基本设置 -> 页面缓存设置，调整其缓存时间；

允许版主修改本版块规则：选择“是”，将允许超级版主和版主在前台管理界面修改本版规则；

是否开启推荐主题功能：选择“是”，版主在前台可以推荐主题，被推荐的主题将显示到版块的主题推荐中，以提高主题的阅读次数；


帖子选项

论坛 —— 版块管理 —— 帖子选项

帖子选项主要是用户在该版块发帖时一些限制。下面请看详细介绍：

Discuz! X1后台 => 论坛 => 版块管理 => 编辑 => 帖子选项：

发帖审核：选择“是”将使用户在本版发表的帖子待版主或管理员审查通过后才显示出来，打开此功能后，您可以在用户组中设定哪些组发帖可不经审核，也可以在管理组中设定哪些组可以审核别人的帖子；

允许编辑帖子：选择“是”将允许用户编辑本版自己发表的帖子；

主题回收站：选择“是”，所有被删除主题将被放在回收站中，而不会被直接删除，必要时可以到回收站恢复；

允许使用 HTML 代码：选择“是”将不屏蔽帖子中的任何代码，将带来严重的安全隐患，请慎用；

允许使用 Discuz! 代码：Discuz! 代码是一种简化和安全的页面格式代码，选择“是”，发帖即可解析使用的 Discuz! 代码；

允许使用 [img] 代码：选择“是”，作者将可以在帖子插入其他网站的图片并显示；

允许使用 [audio] [video] [flash] 等多媒体代码：选择“是”，作者将可以在帖子插入多媒体文件并显示；

允许使用表情：选择“是”，将提供对表情符号，如“:)”的解析，使之作为图片显示；

启用内容干扰码：选择“是”将在帖子内容中增加随机的干扰字串，使得访问者无法复制原始内容。注意: 本功能会轻微加重服务器负担；

允许匿名发帖：是否允许用户在本版匿名发表主题和回复，只要用户组或本版块允许，用户均可使用匿名发帖功能。匿名发帖不同于游客发帖，用户需要登录后才可使用，版主和管理员可以查看真实作者；

禁用图片附件添加水印：选择“是”将不对本版块上传的图片附件自动添加水印，即便 全局设置中开启了此项功能。选择“否”为按照系统默认设置决定是否添加水印；

允许发布特殊主题：勾选表示在版块允许发表该特殊主题；

只允许发表特殊类型主题：选择“是”，该版块将只可发表特殊主题，不允许发表普通主题；

主题自动关闭：设置本版块主题是否在某时间后自动关闭，禁止普通用户回复；如果要自动关闭，还可以设置自动关闭的时间；

允许附件类型：设置本版块中允许上传的附件扩展名，多个扩展名之间用半角逗号 "," 分割。本设置的优先级高于用户组，留空为按照用户组允许的附件类型设定；

允许发送动态：是否允许发送本版块的动态信息。

普通主题点评预置观点：每个观点一行。如存在空行，空行下方的内容将显示在下拉菜单中作为备选观点。只有开启帖子点评功能后本设置才生效，如留空表示使用全局的“普通主题点评预置观点”设置。


积分策略

论坛 —— 版块管理 —— 积分策略

这里主要设置单独版块的扩展积分增减策略，这里的设置将覆盖论坛全局设置。

Discuz! X1后台 => 论坛 => 版块管理 => 编辑 => 积分策略：

可以设置在本版块发主题，回复，加精华，上传附件所加的积分数及下载附件所减积分数。

各项积分增减允许的范围：-99~+99。空表示积分将按论坛默认设定的规则增减。


主题分类

论坛 —— 版块管理 —— 主题分类

这里对版块的主题分类操作进行设置。

Discuz! X1后台 => 论坛 => 版块管理 => 编辑 => 主题分类：

启用主题分类：设置是否在本版块启用主题，分类功能，您需要同时设定相应的分类选项，才能启用本功能；

发帖必须归类：选择“是”，将强制用户发表新主题时必须选择分类；

允许按类别浏览：选择“是”，用户可以按照主题分类筛选浏览内容；

类别前缀：是否在主题前面显示分类的名称；

添加分类：这里可以直接添加分类名称，如下图所示：


分类信息

论坛 —— 版块管理 —— 分类信息

这里主要对版块的分类信息进行设置。

Discuz! X1后台 => 论坛 => 版块管理 => 编辑 => 分类信息：

启用分类信息：选择“是”，再设置相应的分类信息选项， 即可在本版块开启该功能；

发帖必须归类：选择“是”，用户发表新主题时必须选择分类；

类别前缀：选择“是”，主题前面显示分类的名称；

启用默认显示分类：是否启用默认显示分类，如果启用请在下面的分类信息里面选择；


权限相关

论坛 —— 版块管理 —— 权限相关

这里主要对版块的访问权限，发表主题和回复权限及附件上传和下载权限进行设置。

Discuz! X1后台 => 论坛 => 版块管理 => 编辑 => 权限相关：

访问密码：当设置密码后，用户需要输入密码才可以访问到此版块；

访问用户：可以限定只有列表中的用户可以访问本版块，每行填写一个用户名；

某权限如果未全选则表示如下含义:

浏览版块，全部用户组具有浏览；发新话题，除游客以外的用户组具有发帖权限；发表回复，除游客以外的用户组具有回复权限；查看附件，全部用户组具有下载/查看附件权限；上传附件，除游客以外的用户组具有上传附件权限；

权限表达式设置：当设定了权限表达式后，只有符合此表达式的会员才可以浏览本版块；

无权限访问时的提示信息：自定义无权限时的提示信息，如不填写则无权限时将显示权限表达式的公式。


版块合并

论坛 —— 版块合并

由于业务需要，管理员可能需要合并论坛的两个版块，Discuz! 对这一功能做了很好的设置，管理员只需要选择好源版块和目标版块即可实现。

进入 Discuz! X1后台 => 论坛 => 版块合并，进入合并版块界面，如下图所示，

操作很简单，选择“源版块”和“目标版块”，提交即可。

注意：源版块的帖子全部转入目标版块，同时删除源版块。

下面分析下几种情况：

1、两个子版块合并

选择“源版块”和“目标版块”，提交即可，源版块的帖子全部转入目标版块，同时删除源版块。

2、两个版块合并

1）没有子版块则同两个子版块的合并，源版块的帖子全部转入目标版块，同时删除源版块。

2）源版块如果有下级子版块，则无法顺利合并，提示如下图所示，

提示内容为：源版块下级版块不为空，请先返回修改相关下级版块的上级设置。

3）源版块没有下级子版块，无论目标版块是否有下级子版块，合并同两个子版块的合并，源版块的帖子全部转入目标版块，同时删除源版块。

3、一个版块和一个子版块合并

1）源版块是个没有子版块的版块，目标版块是子版块：其合并同两个子版块的合并，源版块的帖子全部转入目标版块，同时删除源版块。

2）源版块是个有子版块的版块，目标版块是子版块：则无法顺利合并，提示如上图所示。

3）源版块是个子版块，目标版块是个没有子版块的版块：其合并同两个子版块的合并，源版块的帖子全部转入目标版块，同时删除源版块。

4）源版块是个子版块，目标版块是个有子版块的版块：其合并同两个子版块的合并，源版块的帖子全部转入目标版块，同时删除源版块。


分类信息

论坛 —— 分类信息

Discuz! X1 的分类信息功能帮助站长更方便地建立自己的分类信息频道。

下面请看详细介绍：

Discuz! X1后台 => 论坛 => 分类信息 => 分类信息管理：

下面以添加“交友类”分类信息类别为例，来演示该功能的使用：

一、添加分类

填写该分类的显示顺序、名称、描述，然后提交即可。

点击“详情”对该分类信息进行详细设置：

是否设置有效期：此分类信息是否有有效期限制，过期后将不参与分类信息搜索，此有效期在前台发帖时选择。

添加分类信息选项：选择交友类，其中包括星座、身高、体重、婚姻状况、爱好、收入范围，可以选择这里的任意项或者全部选择为分类信息的选项。选择好以后可以编辑这些选项。如下图所示：

说明：

1、如果模板为空则采用系统默认模板。

2、点击上面的 [插入模板] 链接，可以将相关的代码插入到模板，如下图所示：

然后您可以用网页编辑工具如 DreamWeaver 或者手工进行编辑。

3、分类信息显示模板支持 HTML，其中{选项变量名}代表该选项的名称，[选项变量名]代表该选项的具体值。

例如有一个选项变量名为 age，选项名称为年龄，会员填写的数值为 20。那么 {age}[agevalue] 这样的字符串，在模板中将显示为年龄 20。

二、关联版块

分类信息添加成功后，必须关联版块，用户才可以在关联到的版块发布该类别信息。

Discuz! X1后台 => 论坛 => 版块管理 => 编辑要关联分类信息的版块 => 分类信息，启用分类信息

三、选项管理

选项管理中包括通用类、房产类、交友类、求职招聘类、交易类和互联网类。这是系统默认已经增加好的几种分类信息。您也可以在已有的分类信息选项中另外添加自己想要的选项，下面具体介绍如何添加：

添加分类信息选项：

注意：这里的变量名必须填写。

点击“详情”对该信息选项进行详细设置：

名称：填写分类选项的名称。

变量名：填写分类信息变量名。

类型：选择分类选项的类型。

简短描述：对该分类选项的简单说明。

单位：可以留空默认。

是否限制有效期：选择“是”则超过有效期信息自动隐藏

上传图片(image)：填写图片的最大宽度、最大高度和表单显示的长度。

选择的类型不同，选项的内容会不相同。

四、前台发布信息

前台，进入关联版块发帖：

选择在后台添加的分类，即可看到添加的选项；

填写选项内容，并填写帖子内容，发布即可。


Discuz! X1 后台使用 — 群 组

群组设置：Discuz! X1 的群组设置中，可以对站内的群组功能是否开启、群组图标的大小、群组的管理用户组及对群组页面进行搜索引擎优化。

群组分类：Discuz! X1 的群组分类类似于版块分类，每个群组分类下允许设置子分类，为每个新建的群组做好分类，可以使站点的群组结构更加清晰，便于管理。

群组管理：可以对群组的各项参数进行设置。

群主权限：Discuz!X 加强了群组的功能，群主权限功能可以将群组的群主权限设置细化，让群主在论坛之外更自主的管理群组。

群组等级：通过群组等级功能可以设置群组的不同等级，让会员更积极的参与到群组升级中去。


群组设置

群组 —— 群组设置

Discuz! X1 的群组设置中，可以对站内的群组功能是否开启、群组图标的大小、群组的管理用户组及对群组页面进行搜索引擎优化。

设置方法：管理中心 => 群组 => 群组设置

其中，对搜索引擎进行优化的页面描述和关键词可以在查看群组页面的源文件看到。


群组分类

群组 —— 群组分类

Discuz! X1 的群组分类类似于版块分类，每个群组分类下允许设置子分类，为每个新建的群组做好分类，可以使站点的群组结构更加清晰，便于管理。

分类设置：管理中心 => 群组 => 群组分类

对群组分类的操作包括删除、搜索群组和合并分类。

在每个分类的管理操作中，对分类进行删除，前提是该分类下没有群组，否则需要先删除分类下的群组再删除分类。

通过搜索群组可以对该分类下的群组进行批量删除和分别管理。

对群组分类进行合并时，选择将要合并的目标分类，合并操作将会把原分类下的所有群组转移到目标分类下，并删除原分类。

此外，对分类下的群组可以设置群组横排数，如下图，即为“电影”的分类下，选择了群组横排数为3时的显示效果。


群组管理

群组 —— 群组管理

Discuz! X1 的群组管理中，可以对群组的各项参数进行设置。

首先通过搜索条件找到需要进行管理的群组，搜索条件包括群组名称、群组ID、群组分类、成员数、主题数、回复数、创建时间、最后更新时间、创建者、创建者 UID。

对于搜索到的群组，可以对其进行批量删除，也可以对某个群组的详情进行管理。

在对指定群组进行详情管理时，可以管理其群组名、分类、加入方式、是否推荐，是否所有人可见，以及群组的简介、公告、图标、顶部图片等。Discuz! X1 新增加的群组的自定义顶部图片功能，可以使群组的表现力更加丰富，用户可以选择能够体验群组特性的个性化图片装饰群组页面。

以下为各项设置及前台显示：


群主权限

群组 —— 群主权限

Discuz! X1 加强了群组的功能，群主权限功能可以将群组的群主权限设置细化，让群主在论坛之外更自主的管理群组。

群主权限在后台 => 群组 => 群主权限如下图所示：

1、主题管理权限

设置群主对主题置顶、提升、高亮、鉴定、关闭、合并、分割、修复等权限，强制退款、编辑投票、移除悬赏、管理活动报名者、编辑商品等权限。

2、允许精华主题：设置是否允许精华管理范围主题的级别

3、帖子管理权限：设置是否允许对群组内的帖子进行编辑、警告、屏蔽、删除。

4、管理面板权限：设置是否允许群主上传群组顶部图片

5、其它权限：设置是否发表不受限制和是否允许查看IP。


群组等级

群组 —— 群组等级

通过群组等级功能可以设置群组的不同等级，让会员更积极的参与到群组升级中去。

群组等级在后台 => 群组 => 群组等级，如下图所示：

一、群组等级

1、默认程序有三个等级普通级、中级、高级

2、群组级别会根据群组的积分自动分级。在此处可以设置各个群组需要的最低积分，提交修改的时候系统会自动修改上一等级的最高积分。点击后面的详情可以设置该级别群级的详细权限。

二、各等级群组详细权限设置

1、基本设置

1）等级名称：可以设置不同等级群组不同的等级名称。

2）等级图标：可以设置不同级别的群组不同的等级图标，可以上传文件或者直接输入URL。

2、积分相关：可以设置群组中各操作是否加积分

3、帖子相关：可以设置不同等级群组的帖子相关的权限及附件等类型

4、特殊功能：设置是否允许创始修改群组名、群组分类、主题分类及关闭群组。设置群组可加入到最大成员数。

提示：

1、群组等级不宜设置过多。

2、当允许群组内发帖等操作影响用户积分时应谨慎，有可能通过群主刷积分。

3、默认等级图标大小是25 X 25像素。


Discuz! X1 后台使用 — 扩 展

站点广告：Discuz! X1 在系统中内置了 11 个广告位，如果用户对内置的广告位不满足，还可以自行增加自定义广告位。

站点任务：通过使用论坛任务可以起到对用户引导的作用，比如引导用户上传自己的头像、让用户使用论坛推广、完成发布帖子、添加好友等动作，可以促使用户更快的熟悉您的论坛，快速的融入您的站点当中。

道具中心：道具中心为论坛提供丰富多彩的娱乐功能，可以有效的增强论坛会员的活跃性。

勋章中心：用于设置可以颁发给用户的勋章信息。如果您想拥有与众不同的勋章图标，那就来这里添加和编辑吧。

站点帮助：是站长为会员提供的，方便会员能快捷地找到自己需要的内容。站长可以根据站点情况，随意添加帮助信息。

电子商务：开启论坛电子商务功能允许您的站点用户在论坛上进行出售和购买等交易操作。

友情链接：是每个站点都会用到的一个功能，友情链接的呈现方式有以下三种：竖排两列完全显示、横排纯 logo 显示和横排纯文字显示。您需要哪种方式的友情链接排列方式？根据这篇文章随您的心意设置吧。

站长推荐：站长推荐将以浮窗的形式显示在帖子内容页面右下角。


站点广告

扩展 —— 站点广告

用户可以在管理中心 => 扩展 => 站点广告 中通过广告位示意图直观地看到广告的展示位置，选择想要添加广告的广告位，即可进行添加广告的操作。

一、系统内置的广告位的设置和显示。

1、论坛/群组 帖间通栏广告

展现方式：

帖间通栏广告显示于主题帖和第一个回帖之间，可使用 468x60 或其他尺寸图片和 Flash 的形式。当前页面有多个帖间通栏广告时，系统会随机选取其中之一显示。、

价值分析：

由于能够将主题与回帖分开，广告尺寸大而且不影响帖子内容，因此不会招致帖子作者及访问者反感，适合在帖内进行商业宣传或品牌推广。

设置：

显示：

2、论坛 分类间广告

展现方式：

论坛分类间广告显示于版块列表相邻的两个版块分类之间，可使用 468x60 或其他尺寸图片和 Flash 的形式。当前页面有多个分类间广告时，系统会从中抽取与版块分类数相等的条目进行随机显示。

价值分析：

由于出现在版块列表页比较明显的位置，广告展示效果较好，但是过多过大的广告可能会招致访问者反感。

设置：

显示：

3、全局 页头二级导航栏广告

展现方式：

页头二级导航栏广告显示于页面上方，通常使用 468x60 图片或 Flash 的形式。当前页面有多个通栏广告时，系统会随机选取其中之一显示。

价值分析：

由于能够在页面打开的第一时间将广告内容展现于最醒目的位置，因此成为了网页中价位最高、最适合进行商业宣传或品牌推广的广告类型之一。

设置：

显示：

4、论坛/群组 格子广告

展现方式：

页内文字广告以表格的形式，显示于版块列表、主题列表和帖子内容三个页面的中上方，通常使用文字的形式，也可使用小图片和 Flash。当前页面有多个文字广告时，系统会以表格的形式按照设定的显示顺序全部展现，同时能够对表格列数在 3～5 的范围内动态排布，以自动实现最佳的广告排列效果。

价值分析：

由于此类广告通常以文字形式展现，但其所在的较靠上的页面位置，使得此类广告成为了访问者必读的内容之一。同一页面可以呈现多达十几条文字广告的特性，也决定了它是一种平民化但性价比较高的推广方式，同时还可用于论坛自身的宣传和公告之用。

设置：

显示：

5、论坛/群组 帖内广告

展现方式：

帖内广告显示于帖子内容的上方、下方或右方，帖子内容的上方和下方通常使用文字的形式，帖子内容右方通常使用图片的形式。当前页面有多个帖内广告时，系统会从中抽取与每页帖数相等的条目进行随机显示。您可以在 全局设置中的其他设置中修改每帖显示的广告数量。

价值分析：

由于帖子是论坛最核心的组成部分，嵌入帖子内容内部的帖内广告，便可在用户浏览帖子内容时自然的被接受，加上随机播放的特性，适合于特定内容的有效推广，也可用于论坛自身的宣传和公告之用。建议设置多条帖内广告以实现广告内容的差异化，从而吸引更多访问者的注意力。

设置：

显示：

6、全局 页头通栏广告

展现方式：

页头通栏广告显示于页面上方，通常使用 468x60 图片或 Flash 的形式。当前页面有多个页头通栏广告时，系统会随机选取其中之一显示。

价值分析：

由于能够在页面打开的第一时间将广告内容展现于最醒目的位置，因此成为了网页中价位最高、最适合进行商业宣传或品牌推广的广告类型之一。

设置：

显示：

7、全局 页尾通栏广告

展现方式：

页尾通栏广告显示于页面下方，通常使用 468x60 或其他尺寸图片、Flash 的形式。当前页面有多个页尾通栏广告时，系统会随机选取其中之一显示。

价值分析：

与页面头部和中部相比，页面尾部的展现机率相对较低，通常不会引起访问者的反感，同时又基本能够覆盖所有对广告内容感兴趣的受众，因此适合中性而温和的推广。

设置：

显示：

8、全局 对联广告

展现方式：

对联广告以长方形图片的形式显示于页面顶部两侧，形似一幅对联，通常使用宽小高大的长方形图片或 Flash 的形式。对联广告一般只在使用像素约定主表格宽度的情况下使用，如使用超过 90% 以上的百分比约定主表格宽度时，可能会影响访问者的正常浏览。当访问者浏览器宽度小于 800 像素时，自动不显示此类广告。当前页面有多个对联广告时，系统会随机选取其中之一显示。

价值分析：

对联广告由于只展现于高分辨率(1024x768 或更高)屏幕的两侧，只占用页面的空白区域，因此不会招致访问者反感，能够良好的突出推广内容。但由于对分辨率和主表格宽度的特殊要求，使得广告的受众比例无法达到 100%。

设置：

显示：

9、空间 动态广告

展现方式：

日志广告显示于动态的上方。

设置：

显示：

10、全局 漂浮广告

展现方式：

漂浮广告展现于页面左下角，当页面滚动时广告会自行移动以保持原来的位置，通常使用小图片或 Flash 的形式。当前页面有多个漂浮广告时，系统会随机选取其中之一显示。

价值分析：

漂浮广告是进行强力商业推广的有效手段，其在页面中的浮动性，使其与固定的图片和文字相比，更容易被关注，正因为如此，这种强制性的关注也可能招致对此广告内容不感兴趣的访问者的反感。请注意不要将过大的图片或 Flash 以漂浮广告的形式显示，以免影响页面阅读。

设置：

显示：

11、空间 日志广告

展现方式: 日志广告显示于日志右方。

设置：

显示：

二、广告管理

对站点中已经添加的广告，可以分别在其广告位的分类下或“所有广告"选项中进行管理。根据广告标题、起始时间、终止时间、排序方式等搜索条件，对搜索出符合条件的广告进行管理，管理选项包括删除、更改显示顺序和更改广告详情等。


站点任务

扩展 —— 站点任务

Discuz! X1 中通过使用论坛任务系统，可以起到对用户引导的作用，比如引导用户上传自己的头像、让用户使用论坛推广、完成发布帖子、添加好友等动作，可以促使用户更快的熟悉您的论坛，快速的融入站点中。

论坛任务设置方法：管理中心 => 扩展 => 站点任务

一、安装任务

在管理中心 => 扩展 => 站点任务 => 任务类型 中，系统内置了论坛帖子类任务、完善用户资料任务、站点推广任务、会员类任务、红包类任务、发表日志任务、验证邮箱任务、添加好友任务、头像类任务共九类论坛任务，站长可以根据站点需要自由选择在站点中安装哪一类的任务，安装之后，也可以继续对任务进行升级。

二、添加任务

安装了的任务会在添加菜单的下拉框中显示，站长可添加新任务。下面以添加头像类任务为例，对任务添加的过程进行说明

选择添加头像类任务后，根据站点的实际需求填写任务名称、任务描述、任务图标、上线/下线时间、设置任务间隔周期、任务奖励及对申请任务的用户组和人数限制后，提交即建立了新的站点任务。

三、启用任务

添加任务后，可以在任务管理中，选择是否开启站点任务，及设置任务是否可用和任务的显示顺序。对于启用的任务，站点内凡是满足申请条件的会员就可以进行申请，并通过完成站点任务获取相应的奖励了。


道具中心

扩展 —— 道具中心

Discuz! X1 的道具中心为站点提供丰富多彩的娱乐功能，可以有效的增强站点会员的活跃性。

如果要让会员在站点中使用道具，需要在 管理中心 => 扩展 => 道具中心 中，选择打开道具中心及设置道具回收价格折扣。

Discuz! X1 中内置了 22 种道具，如果要额外添加其他道具，需要将道具脚本程序上传到 source/class/magic/ 目录，这样新的道具就会出现在道具列表中，并在站点中使用了。

每个道具的作用如下：

悔悟卡：可以删除自己的帖子

帖子显身卡：可以将指定的匿名贴显身

金钱卡：可以随机获得一些金币

窥视卡：可以查看指定用户的 IP

抢沙发：可以抢夺指定主题的沙发

互访卡：随机访问好友空间/向好友打招呼/给好友留言

救生圈：把自己日志的发布时间更新为当前时间

雷鸣之声：发布一条全站动态，通知大家自己上线了

置顶卡：可以将主题置顶

热点灯：把自己的日志热度增加站点推荐的热点值

主题变色卡：可以将主题高亮，变更颜色

雷达卡：查看某个用户是否在线

点名卡：发通知给自己的好友，让他们来查看自己的日志

提升卡：可以提升某个主题

附件增容卡：增加附件容量上限

沉默卡：可以将主题关闭，禁止回复

涂鸦板：在日志、帖子中使用涂鸦板

好友增容卡：增加好友容量上限

彩虹炫：在日志、相册评论中使用彩虹炫

时光机：把自己日志的发布时间修改为过去

帖子匿名卡：可以将自己的帖子匿名，隐藏身份

在每个道具后点击“详情”，可对道具的名称、价格、库存、重量、补货方式和数量、使用周期和数目、道具描述、允许使用的版块、用户组及允许被使用的用户组等属性进行编辑。


勋章中心

扩展 —— 勋章中心

Discuz! X1 中的勋章中心，用于设置颁发给用户的勋章。勋章在站点中的作用非常广泛，在站点中拥有勋章，可以彰显用户在某一方面的特殊贡献，提升用户的形象和知名度。

勋章中心位置：管理中心 => 扩展 => 勋章中心

一、管理勋章

Discuz! X1 内置了10个勋章可供使用，站长还可以行添加勋章。添加勋章时，填写勋章名称和勋章图片，并将相应图片文件上传到 static/image/common/ 目录中即可。

如果要对勋章进行具体设置，可以点击勋章后面的“详情”，对勋章的名称、图片、领取方式、有效期、描述、领取权限进行设置。

二、颁发勋章

当勋章的领取方式设置为手动发放时，管理员需要在后台通过搜索到符合条件的用户，给期颁发勋章。搜索条件包括用户名、UID、主用户组、Email、积分值区间、IP、注册时间、访问时间、发帖时间和用户栏目等。

搜索到符合勋章颁发条件的会员后，选择要颁给的勋章即可，可自行选择是否发送勋章颁发通知。

三、审核勋章

当勋章的领取方式设置为用户申请不自动颁发时，管理员需要在后台审核申请勋章的用户，审核时可选审核或否决。


站点帮助

扩展 —— 站点帮助

站点帮助是站长为会员提供的，方便会员能快捷地找到自己需要的内容。站长可以根据站点情况，随意添加帮助信息。

进入后台 => 扩展 => 站点帮助，如下图所示：

一、添加站点帮助的分类

1、点击添加新帮助分类，如下图所示：

2、在显示顺序文本框下填写数字，帮助主题的文本框中输入帮助分类的名称，设置好后，点击提交即可，如下图所示：

二、添加帮助主题

只有添加了主题分类后，才能进行这个操作。

1、点击添加新帮助主题，如下图所示：

2、在显示顺序文本框下填写数字，帮助主题的文本框中输入帮助主题的名称，设置好后，点击提交即可，如下图所示：

3、点击添加的帮助主题后面的详情，进一步编辑帮助主题，如下图所示：

4、填写相关内容，点击提交即可，如下图所示：

帮助标题：设置和修改帮助主题的标题。

上级分类：设置和修改帮助主题的上级分类。

帮助标识：用于帮助信息的前台模版调用，前台模版中可以用{faq 帮助标识}调用此帮助，此标识唯一。如没有特殊需要请不要修改。

帮助关键字：配合帮助标识用于帮助信息的前台的模版调用。

帮助内容：设置帮助主题的详细内容，支持 HTML 代码。

三、前台显示帮助

1、进入后台 => 界面 => 导航栏，如下图所示：

2、启用内置的帮助导航，如下图所示：

帮助在前台显示的效果，如下图所示：


电子商务

扩展 —— 电子商务

论坛提供了电子商务的选择，用户可以直接在论坛后台开启电子商务功能。

后台“扩展 => 电子商务”，如下图所示：

一、基本设置

基本设置是针对所有用户，所有支付方式进行积分购买的一些限制：

1、现金/积分兑换比率：设置真实货币现金(以人民币元为单位)与论坛交易积分间的兑换比率，例如设置为 10，则 1 元2、人民币可以兑换 10 个单位的交易积分。本功能需开启交易积分，并成功进行支付宝收款账号的相关设置后方可使用，如果禁止使用现金与交易积分的兑换功能，请设置为 0。

3、单次购买最小积分数额：设置用户一次支付所购买的交易积分的最小数额，单位为交易积分的单位，0 为不限制。

4、单次购买最大积分数额：设置用户一次支付所购买的交易积分的最大数额，单位为交易积分的单位，0 为不限制。

5、每月购买最大积分数额：设置用户每月能够通过在线支付方式购买的交易积分的最大数额，单位为交易积分的单位，0 为不限制。

二、财付通

财付通功能详细介绍请看：http://www.discuz.net/thread-1359807-1-1.html

三、支付宝

支付宝功能详细介绍请看：http://www.discuz.net/thread-1341501-1-1.html

四、诚信规则

在这里为站点的买卖家设置诚信规则，通过信用度值设置信用图标。站点的会员可以很方便的看到买卖双方的信用度：

1、每个自然月中，相同买家和卖家之间的评价计分最大，以交易创建时间计算，超出计分规则范围的评价将不计分；

2、信用等级：根据买卖双方获得的评价信用度而决定的信用等级；

五、积分充值订单

这里可以查询积分充值订单的状态与支付历史。

填入筛选条件之后点击提交，可以查询到符合条件的订单。

有几种订单状态：

1、成功在线支付：说明支付一切顺利，不需要人工干预。

2、成功人工补单：用户支付有问题，可以由管理员在这里进行人工补单，补单后下方将出现补单管理员的用户名。

3、等待付款：用户还没有付款的订单。

没有成功的订单是没有交易号的，在订单成功后，会在下方显示交易号，通过交易号可以链接到支付宝网站查询交易信息。

六、商品交易订单

这里可以查看实物交易的订单，订单有几种状态，包含发货与退款：

1、未生效交易

2、等待买家付款

3、交易已创建，等待卖家确认

4、确认买家付款中，请勿发货

5、买家已付款，等待卖家发货

6、卖家已发货，买家确认中

7、买家确认收到货，等待支付宝打款给卖家

8、交易成功结束

9、交易中途关闭（未完成）

10、等待卖家同意付款

11、卖家拒绝买家条件，等待买家修改条件

12、卖家同意退款，等待买家退货

13、等待卖家收货

14、双方已经一致，等待支付宝退款

15、支付宝处理中

16、结束的退款

17、退款成功

18、退款关闭


友情链接

扩展 —— 友情链接

友情链接是一种网站之间的简单合作形式，即分别在自己的网站上以文字、图片或其他形式的载体链接到对方的网站。

友情链接的意义主要有两方面：

1、通过和其他站点交换链接,可以吸引用户点击访问，直接提高您网站的访问量。

2、搜索引擎在决定一个网站的排名时，不仅对网页内容和结构进行分析，还围绕网站的链接展开。

设置友情链接的位置：后台 => 扩展 => 友情链接，如下图所示：

一、添加友情链接：友情链接一共有 3 种显示样式。仅显示站点名称，仅显示 logo，显示 logo 和文字说明。

1、添加仅显示站点名称的友情链接。

1)点击添加友情链接，填写友情链接的显示顺序，站点名称和站点 URL，然后点击提交即可，如下图所示：

2)添加后的前台显示效果，如下图所示：

2、添加仅显示 logo 的友情链接。

1)点击添加友情链接，填写友情链接的显示顺序，站点名称，站点 URL 和 logo 地址，然后点击提交即可，如下图所示：

2)添加后的前台显示效果，如下图所示：

3、添加显示站点名称，logo 和文字说明的友情链接。

1)点击添加友情链接，填写友情链接的显示顺序，站点名称，站点 URL,文字说明和 logo 地址，然后点击提交即可，如下图所示：

2)添加后的前台显示效果，如下图所示：

二、删除友情链接

勾选要删除的友情链接前面的复选框，点击提交，即可删除此友情链接，如下图所示：


站长推荐

扩展 —— 站长推荐

一、使用说明。

站长推荐可以以浮动窗口的形式显示在站点指定页面的右下角。

站长推荐可以设置多条，但最多 10 条，每次随机显示其中 1 条。

二、设置步骤。

首先进入后台相关设置

后台 => 扩展 => 站长推荐

1、设置。

设置标签中可以修改站长推荐弹窗中显示的区域标题，默认标题为“站长推荐”。

如果要修改显示的标题，只需要在文本框中填入想要显示的标题，然后点击提交即可。

该设置支持 html 代码，但是使用的时候需要将其中的双引号（"）过滤掉。

如： 站长推荐标题

由于支持 html 代码，所以在使用时请注意代码的安全性。

2、添加。

添加标签中可以添加一条站长推荐内容。

点击添加后，会显示一些表单内容。其中有：

1）推荐链接地址：该地址为显示该条站长推荐的时候标题超链接所对应的链接地址。

如果链接地址是站内地址则不需要填站点域名，只需要填类似 forum.php?mod=forumdisplay&fid=36 或 forum-29-1.html 即可。

如果链接地址是站外地址则需要填写全部链接，并且不能省略 http:// 如： http://www.comsenz.com

2）推荐标题：设定该条站长推荐的标题，注意其与区域标题的区别（区域标题是整个弹窗的标题，而推荐标题是弹窗中显示的推荐的标题）。

支持 html 代码，使用方法同设置。

3）推荐内容：推荐窗口中显示的主要内容，支持 html 代码，内容的长度（ html 代码不计算在内）上限为 150 个字符。

4）附加图片：可以在该条推荐中显示一张图片，只需要填入该图片的绝对地址。

如：http://www.discuz.net/static/image/common/logo.png

5）站长推荐投放区域：此处设置该推荐显示的页面。

注意如果不设置投放区域该推荐将不会被显示。

3、管理。

此处用于管理已有的站长推荐。

1）删除：要删除某条或某些站长推荐只需勾选前端的复选框，然后点击下方的提交即可。

2）设置是否可用：在列表中的“可用”栏目中的复选框被勾选的为可用的推荐，前台只显示可用的推荐。如需修改，则勾选希望显示的推荐提交即可。

3）编辑：此处可以对某个已经存在的推荐进行编辑，点击其对应的编辑链接即可调转到编辑页面，编辑操作同添加操作。

三、显示效果。


Discuz! X1 后台使用 — 插 件

扩展中心：将显示由资源提供商提供各类 Discuz! 插件、风格等扩展资源。

插 件：基于 Discuz! 论坛系统之上，设计开发的一种小程序或小方案，用来实现对站点现有功能扩展和改进。


扩展中心

插件 —— 扩展中心

论坛的扩展中心功能，为站长查找及安装最新最有保障的插件和风格提供了便利。站长朋友们可以很轻松的从扩展中心中得知插件提供服务商。并将其使用到自己的站点中。

下面具体介绍扩展中心的功能。

管理中心 => 插件 => 扩展中心，这里默认提供了两个资源服务提供商。站长可以在扩展中心里面筛选到最新的扩展信息，如下图所示：

1、添加资源提供商

点击上图的最上部“添加”按钮，即可获得资源提供商列表，只需要点击资源提供商的图标，就可以将其纳入到提供商的收藏列表供日后浏览。如下图所示：

如果知道提供商的 ID 也可以直接在下方填写 ID，来添加资源提供商。

2、浏览资源

添加后，切换到列表，可以看到刚刚添加的资源服务商：

点击图片，可以浏览到资源提供商提供的资源：

用户就可以寻找更多的安全可靠的插件与模板了。


插件

插件 —— 插件

插件，是基于 Discuz! X 系统之上，设计开发的一种小程序或小方案，用来实现对论坛现有功能扩展和改进。由于 Discuz! X 已具有相当完备的底层架构，因此插件并不需要具备很多深层的设计思想，也不需要很专业的开发人员，只要把想实现的功能与论坛的基本体系挂接起来，论坛就能拥有更加个性化的功能。

一、管理已经安装的插件

进入到管理中心 => 插件 => 插件列表，可以看到现在已经安装了的插件。

二、安装新插件

进入到“安装插件”，可以看到已经上传到 source/plugin/ 目录，但是尚未安装的插件，点击插件右侧的“安装”链接，便可以安装插件了。

安装后，返回到插件列表启用插件。

三、设计插件

1、新建插件

进入“设计新插件”，可以创建属于自己的插件

插件名称：插件的名称，中英文均可，最多 40 个字节；

插件版本号：插件的版本。

版权信息：设置插件的版权信息，最多 100 个字节，一旦设置无法更改；

唯一标识符：插件的唯一英文标识，不能够与现有插件标识重复。可使用字母、数字、下划线命名，不能包含其他符号或特殊字符，最大 40 个字节；

2、设置插件

进入到插件列表，对应插件后面的“设计”，可以进入到插件的设置页面

插件名称：插件的名称，中英文均可，最多 40 个字节；

插件版本号：插件的版本。

唯一标识符：插件的唯一英文标识，不能够与现有插件标识重复。可使用字母、数字、下划线命名，不能包含其他符号或特殊字符，最大 40 个字节；

插件目录：插插件程序（包括前台和后台）相对于 source/plugin/ 的相对路径，必须以 "/" 结尾，否则会产生错误。如果不指定本设置，则默认插件的前后台程序均放置于 source/plugin/ 里；

插件数据表：插件单独使用的数据表，用于在备份功能中将插件的数据表一同备份。请勿包含数据表前缀。多个数据表可以使用半角逗号 ","(不含引号) 分割；

插件描述：插件的简单描述，最多 100 个字节，可选填；

插件语言包：如果插件存在语言包，请选择“是”。

3、插件模块设置

Discuz! 引入了模块类型和程序模块的概念，将菜单链接的方式简化了，只需要填入直接链接URL即可。如下图所示：

4、设置变量

创建新的插件以后，可以为插件创建可以使用的变量。您在二次开发当中会用到此功能。如下图所示：

5、导出

点击导出，即可将插件导出为 xml 格式。可以在其他同版本产品后台导入使用。

四、升级卸载插件

在插件列表，可以看到“升级/卸载”，点击后，可以对插件进行卸载操作，如果插件目录更新了新版本的 xml 文件的话，那么则提示是否升级。


Discuz! X1 后台使用 — 工 具

更新缓存：是把现有的缓存文件清空，以便重新生成新的缓存文件。当管理员对站点数据进行了操作或者修改了模板，如果站点在显示方面未及时更新，就需要更新缓存。

站点公告：站长通过张贴公告的形式通知所有会员一些重要信息。

更新统计：站点的总体信息变换的很频繁，比如删除帖子，发表帖子都会影响帖子总数，所以难免会出现一些统计信息和站点的实际信息不符的情况，更新统计功能让站点的总体信息更为准确。

运行记录：记录站点各个运行状态的运行记录，方便站长了解站点的运行情况。

计划任务：其作用是通过执行计划任务，使得系统在规定时间自动执行某些特定任务的功能。例如：在每天的某个时刻，通过执行计划任务，清空当日发帖量。

文件权限检查：针对 Discuz! X1 本身的运行环境需要，检查站点所有的目录权限是否已设置正确。

文件校验：使您及时发现站点程序是否被非法篡改。通过文件校验可以看得到你的哪些文件被修改过了，哪些文件是新增的，哪些文件被删除了，这些问题都一目了然，方便您可以很快的发现问题并且解决问题。


更新缓存

工具 —— 更新缓存

更新缓存是把现有的缓存数据进行清空，以便重新生成新的缓存数据。当站点进行了数据恢复、升级或者工作出现异常的时候，您可以使用本功能重新生成缓存。更新缓存的时候，可能让服务器负载升高，请尽量避开会员访问的高峰时间。

管理后台 => 工具 => 更新缓存，如下图所示：

数据缓存：更新站点的全部设置数据的缓存。

模板缓存：更新论坛模板、风格等缓存文件，当您修改了模板或者风格，但是没有立即生效的时候使用。


站点公告

工具 —— 站点公告

做为站长，有时需要通知论坛所有用户一些信息。Discuz! 的论坛公告即可解决这个问题，您不必逐个用户通知，也不必批量发送短消息或 Email ，您只需在后台添加一条公告即可。

一、添加公告

论坛后台 => 工具 => 论坛公告 => 添加，即可看到下图所示：

注意：

文字公告：添加公告后，点击该公告将跳转到公告详细信息页面。

网址链接：添加公告后，点击该公告将跳转到公告内容部分指定的网址。

二、管理公告

论坛后台 => 工具 => 论坛公告 => 管理，即可看到下图所示：

如上图所示，您可以设置各个公告的显示顺序，编辑公告，还可以选择性地删除公告。

三、前台显示

注意：添加两条公告以上，将会从下往上翻滚显示；

如果有多条公告，版块内只显示最新的一条公告，可以点击进入查看全部公告。


更新统计

工具 —— 更新统计

论坛的总体信息变换的很频繁，比如删除帖子，发表帖子都会影响帖子总数，所以难免会出现一些统计信息和论坛的实际信息不符的情况，怎样才能让论坛的总体信息更为准确呢？Discuz! X 的更新论坛统计就显得尤为重要。一般在从数据库里面删除了数据之后，那就需要用到重建统计数据功能。

在论坛管理中心 => 工具 => 更新统计，如下图所示：

1、重建（论坛/群组）帖数

重新统计每个版块/群组的贴子数和总帖数。

2、重建用户精华帖数

重新计算每个用户的精华数目。

3、重建用户发帖数

统计每个用户的总发帖数。

4、重建主题帖数

重建每个主题的回复数。

5、清理移动标记

移动的时候有个保留帖子转向，清理移动标记可以批量删除移动转向。

6、分类信息整理

Discuz! X 中可以针对帖子的分类信息在版块中展示这些信息，这些信息是单独保存在一个表中的，如果这部分数据出现了问题，可以使用这个功能来重新写入表中的数据。

7、重建分类群组数

重新统计每个群组分类的群组数。

8、重建群组成员数

重新统计每个群组中的成员数量。

9、重建群组成员发帖数

重新统计群组成员的发帖数量。

10、重建日志回复数

重新统计每篇日志的回复数。

11、重建空间好友数

重新统计会员个人空间的好友数。

12、重建相册图片数

重新统计每个相册的图片数数量

更新统计之前，都有每次循环更新数量的设置，这个设置主要是为了防止一次更新太多，完成时间太长导致服务器超时而设置的，这样每次执行你设置的数目，然后自动跳转分批执行。


运行记录

工具 —— 运行记录

想让论坛能健康稳定的运行，就要经常对论坛的运行情况进行监控。运行记录提供了记录论坛各个运行状态的功能。当遇到一些故障的时候，不妨来看看运行记录。

后台 => 工具 => 运行记录，如图

运行记录分三大类：用户记录，系统记录 以及 扩展记录。

一、用户记录：记录用户执行的或被执行的一些操作，包括：忘记密码、禁止用户、版主管理。

1、密码错误，如图

密码错误记录用户在登录的时候，多次尝试密码登录。更及时发现猜测密码的用户，或者忘记密码的用户，并帮助用户找回密码等。尝试密码是记录不完全的，这点是为了保护用户的隐私而设计的。只有部分字符而已。可以通过页面右下角的搜索查看您需要查看的信息，通过ip地址信息，或者用户名查找您需要的信息。

2、禁止用户，如图

禁止用户记录着管理组对用户的禁止操作。当解封或者禁止其他人的操作的时候，可以在这里查到根据。可以通过页面右下角的搜索您需要的禁止用户信息。

3、版主管理，如图

版主管理记录着版主进行的所有操作，可以知道版主进行了什么操作。可以通过页面右下角的搜索查看您需要查看的信息。

二、系统记录：记录论坛运行的过程中出现的一些问题，包括：后台访问、系统错误。

1、后台访问，如图

后台访问记录着管理组的成员户访问后台的记录。无论访问后台那个动作，都会有记录，对论坛的修改进行了提交后，在其他那个选项就会出现一些特殊的字符，就是sql的片段。所以这个记录很重要，可以了解到访问后台的管理组的人员，到底执行了什么操作。可以通过页面右下角的搜索您需要的后台访问信息。

2、系统错误，如图

系统错误记录着论坛在运行状态中，出现的MySQL的错误，发邮件错误，ftp远程附件上传错误。这个记录可以帮助我们了解论坛的运行情况。以通过页面右下角的搜索您需要的系统错误信息。

三、扩展记录：记录系统中的一些其他操作，包括：用户评分、积分交易、道具操作、勋章颁发、邀请注册、买卖主题。

1、用户评分，如图

用户评分记录记录着在所有用户的评分记录，就是用户是否是在恶意评分或者版主评分是否不公正，都做到有证可查。这个记录同样可以通过 用户名，被评用户名，分数，标题，原因。同样，可以通过页面右下角的搜索查看您需要查看的信息。

2、积分交易，如图

可以通过左下角的下拉菜单来选择自己想要关注的交易记录，也可以通过页面右下角的搜索查看您需要查看的信息。这个交易记录是记录在数据库里面的。

3、道具操作，如图

道具操作记录着前台道具市场的购买记录，和用户使用道具的记录。通过这个记录您可以全面的了解当前道具的使用情况。这个记录是存储在数据库里面的，所以查看的条件比较多，可以很精确的查看到您需要的记录。可以通过页面右下角的搜索您需要的道具操作信息。

4、勋章颁发，如图

勋章颁发记录着所有的勋章的颁发和收回的信息。可以通过左下角的下拉菜单来选择自己想要关注的勋章颁发信息。可以通过页面右下角的搜索您需要的勋章管理信息。

5、邀请注册，如图

邀请注册记录着邀请注册的所有使用情况。所有使用邀请注册的情况都一目了然。可以通过页面右下角的搜索您需要的邀请注册信息。

6、买卖主题， 如图

买卖主题记录着买卖主题的信息。所有买卖主题的交易都一目了然。可以通过页面右下角的搜索您需要的买卖主题信息。


计划任务

工具 —— 计划任务

计划任务是 Discuz!X 提供的一项使系统在规定时间自动执行某些特定任务（如今日发帖数的更新、标签的更新、主题回复的email通知等）的功能，在需要的情况下，您也可以方便的将其用于论坛功能的扩展。

后台 => 工具 => 计划任务，如图

一、计划任务的编辑设置

1、系统内置了12个计划任务，如果修改某一项计划任务，可点击计划任务名称后面对应的“编辑”，进入设置界面，如图

2、在编辑计划任务界面，可修改计划任务的执行时间或相对应的任务脚本。

注意：除非非常了解 Discuz!X 结构，否则强烈建议不要修改默认设置。如需修改，请在修改之前记录原有设置，不当的设置将可能导致论坛出现不可预期的错误。

二、添加计划任务

1、自己写好计划任务的程序，传到论坛目录下的 /source/include/cron/ 下。

2、后台 => 工具 => 计划任务 “新增:”后填写计划任务名，如下图所示：

提交保存后，再编辑这个计划任务，如图

3、填写上已上传到 /source/include/cron/ 中脚本的文件名，提交。

4、再到计划任务列表里面勾选刚设置好的计划任务“可用”的选择框，如图

三、计划任务的执行

在设置的计划任务执行的时刻，如果有人访问站点，计划任务就会执行；如果那个时刻无人访问站点，则直到有人访问时才执行计划任务。

如果站点的计划任务偶尔没有正常执行，也手动执行计划任务即点击相应的计划任务后面的执行，相应的计划任务将立即执行，如图

注意：

计划任务和其他功能不同，本功能中完全按照论坛系统默认时差对时间进行设定和显示，而不会依据某一用户或管理员的时差设定而改变显示或设置的时间值。

计划任务是与系统核心紧密关联的功能特性，不当的设置可能造成论坛功能的隐患，严重时可能导致论坛无法正常运行，因此请务必仅在您对计划任务特性十分了解，并明确知道正在做什么、有什么样后果的时候才自行添加或修改任务项目。


文件权限检查

工具 —— 文件权限检查

文件权限检查的功能是针对我们 Discuz! 本身的运行环境需要，需要设置一些目录的可写权限，那么在没有设置好的前提下，是没有办法完全正常的运转论坛的。所以可以利用该功能检查一下你的所有的目录权限是否设置正确了的。如不正确，将会有红色字体列出目录名称的。

后台 => 工具 => 文件权限检查，如下图：

点击“开始”按钮，如下图：

检查结果，如下图：

可以通过校验结果检查网站文件权限是否设置正确，设置文件权限的方法请参考：http://faq.comsenz.com/viewnews-183


文件校验

工具 —— 文件校验

文件校验，这个功能可以使你即时发现论坛程序是否被非法篡改。就是可以看得到你的哪些文件被修改过了，哪些文件是你增加的，哪些文件被删除了，这样都一目了然。那样你可以很快的发现问题或者解决问题。

后台 => 工具 => 文件校验，如图：

点击“开始”按钮。

开始校验，如图：

校验结果，如图：

可以通过校验结果检查网站文件是否被非法修改。


Discuz! X1 后台使用 — 站 长

后台管理团队：您可以制定多种团队职务分配给您网站管理团队的各个成员，让他们管理网站的不同事务。

邮件设置：方便站长通过站点来向您的会员发送电子邮件，让您的管理与服务更加的专业和体贴。。

UCenter 设置：主要设置 Discuz! 与 UCenter 连接的一些信息，本设置在论坛安装时自动生成，一般情况下请不要修改，修改前请备份 config 文件夹，以防止修改错误导致论坛无法运行。

Manyou 设置：开启漫游应用功能后，用户可以自由选择各种不同的应用（诸如开心农场、快乐庄园、德克萨斯扑克、荣光医院......）在站内进行使用。

数据库：主要包括数据库的备份、数据的恢复、数据升级、数据库优化以及数据库校验功能。

帖子分表：可以将帖子分在不同的数据表中，减轻单表的访问压力，提高网站运行效率，适合帖子数很多并且运行效率受到影响的站点使用。

主题分表：主题分表功能可将 forum_thread 表（包含主题标题、创建时间等信息，但不包含主题及回复内容）分在多个数据表中。


后台管理团队

站长 —— 后台管理团队

管理团队是 Discuz! X1 新增的机制，它彻底分离了前后台的管理人员组织架构，前台用户组和后台用户组是两套用户组机制。每一个用户在拥有前台用户组身份的同时，还拥有一个隐藏的前台不可见的后台管理团队成员身份。管理团队机制可以让站点后台更安全，网站的管理成员层级更清晰。

一、站长/创始人。

使用管理团队功能，首先要为站点设置一个创始人。

打开 config/config_global.php，找到 $_config['admincp']['founder'] 设置创始人。

如:设置了 $_config['admincp']['founder'] = '1'; 假设站点最高身份用户的 UID 为 1，这样 UID 为 1 的用户为站点的创始人，此人必须是管理员用户组的成员。如果未设置创始人，那么所有在管理员用户组的成员，均是创始人。这样是不安全的，我们不建议用户这样做。

二、团队成员

在设置了最高身份的创始人后，用创始人身份的用户登录，会看到管理中心顶部有"站长“页签。这是只有“创始人”才能看到的管理项目，在这里列出了所有能进入后台的成员，可以在这里对管理团队的成员进行删减，并为增加的成员设置职务，删减操作不会影响成员的前台用户组身份。

三、团队职务

Discuz! X1 中预置了 5 个团队职务，站长可以自行增加或减少团队职务。

每个职务均根据后台菜单的布局拥有不同的权限，站长可以根据站点的需要，在各个团队职务的编辑中对其管理权限进行调整。下图即为调整门户管理员权限方法。


邮件设置

站长 —— 邮件设置

说明：Discuz! X1的邮件功能，对于站长来说是相当重要的，如果用户忘记密码，可以通过邮件直接取回，比较方便下面为大家仔细讲解如果设置邮件功能。

一、Discuz! X1 支持如下三种邮件发送方式：

1、通过 PHP 函数的 sendmail 发送(推荐此方式)

说明：

这种方式是使用 PHP 的函数发送邮件，需要服务器上安装邮件系统。一般的虚拟主机都内置邮件系统。因此推荐使用这种方式。

2、通过 SOCKET 连接 SMTP 服务器发送(支持 ESMTP 验证)

说明：

这种方式适用于 win 或者 linux 类服务器使用（适合于虚拟主机或者独立主机使用），并且支持 ESMTP 验证。需要站长拥有一个 SMTP 服务器，例如 Foxmail 的 SMTP 服务器。

3、通过 PHP 函数 SMTP 发送 Email(仅 Windows 主机下有效, 不支持 ESMTP 验证)

说明：这种方式仅仅适合于 win 主机。对系统环境要求较高，不推荐使用。

用户可以根据自己的情况来选择使用哪一种方式

二、邮件头的分隔符分为三种

1、使用 LF 作为分隔符(通常为 Unix/Linux 主机)

2、使用 CRLF 作为分隔符(通常为 Windows 主机)

3、使用 CR 作为分隔符(通常为 Mac 主机)

说明：这里根据您使用的邮件服务器系统选择邮件头的分隔符。

三、下面我们以第二种邮件发送方式为例详细介绍一下设置邮件功能的整个过程：

1、首先我们需要注册一个邮箱，如 Foxmail的邮箱，邮箱名为：hellensu@foxmail.com

2、站点创始人登录 Discuz! X1 的后台 => 站长 => 邮件设置，如下图所示：

3、邮件发送方式选择通过 SOCKET 连接 SMTP 服务器发送，邮件头的分隔符选择使用 CRLF 作为分隔符，然后填写相关SMTP 服务器信息。

SMTP 服务器：填写 SMTP 服务器 地址，如：smtp.foxmail.com

SMTP 端口：默认一般为 25。可以根据自己所用 SMTP 端口的不同进行填写。

说明：要求身份验证这里建议大家选择“是”。

发信人邮件地址：填写发件人的邮件地址。

SMTP 身份验证用户名：填写的邮件地址同上。

SMTP 身份验证密码：填写邮箱的密码。

邮件头的分隔符：这里根据您使用的邮件服务器系统选择邮件头的分隔符。

收件人地址中包含用户名：

选择“是”将在收件人的邮件地址中包含站点用户名。

屏蔽邮件发送中的全部错误提示：选择“是”将屏蔽邮件发送中的全部错误提示。

四、检测

要想知道设置的邮件功能会员是否能正常收到邮件，我们需要测试一下

填写好发件人和收件人邮箱后，点击“检测邮件发送设置”如果邮件设置成功会提示如下图所示：

这样做为站点管理员，我们的邮件功能就设置好了。


UCenter 设置

站长 —— UCenter 设置

UCenter 设置主要设置 Discuz! 与 UCenter 连接的一些信息，本设置在论坛安装时自动生成，一般情况下请不要修改，修改前请备份 config 文件夹，以防止修改错误导致论坛无法运行。

一、此功能的位置：后台 => 站长 => UCenter 设置，如下图所示：

二、各项目的设置

1、根据 UCenter 中的对应信息，详细设置下面的信息即可，如下图所示：

UCenter 应用 ID：该值为当前站点在 UCenter 的应用 ID，一般情况请不要改动。

UCenter 通信密钥：通信密钥用于在 UCenter 和 Discuz! 之间传输信息的加密，可包含任何字母及数字，请在 UCenter 与 Discuz! 设置完全相同的通讯密钥，以确保两套系统能够正常通信。

UCenter 访问地址：如果您的 UCenter 访问地址发生了改变，请修改此项。不正确的设置可能导致站点功能异常，请小心修改。格式: http://www.sitename.com/uc_server (最后不要加'/')。

UCenter IP 地址：如果您的服务器无法通过域名访问 UCenter，可以输入 UCenter 服务器的 IP 地址。

2、UCenter 连接方式：请根据您的服务器网络环境选择适当的连接方式。

1)数据库方式：需要您站点可以连接 UCenter 数据库，如下图所示：

UCenter 数据库服务器：可以是本地也可以是远程数据库服务器，如果 MySQL 端口不是默认的 3306，请填写如下形式：127.0.0.1:6033。

UCenter 数据库用户名，UCenter 数据库密码，UCenter 数据库名，UCenter 表前缀按照 UCenter 实际的数据库信息填写。

2)接口方式：UCenter 和 Discuz! 不在同一台服务器则可以选择接口方式，接口方式无需设置其他的选项，如下图所示：

3、是否允许其他应用的会员在站点激活：通常情况下，如果会员在其他应用注册了，但是他还不是站点用户，如果允许这些用户进入站点，请设置“是”。

4、头像调用方式：设置用户头像的调用方式。


Manyou 设置

站长 —— Manyou 设置

Discuz! X1 给站长提供了 Manyou(漫游)游戏与大型全文搜索服务，Manyou游戏也是一个SNS站点主要的收入来源。全文搜索则针对站点量身定制高效的、高性能的、不占用自身站点Mysql资源的搜索。

本篇教程讲解如何开启 Manyou 服务。

首先使用站点管理团队的身份账号登录站点后台。进入Discuz! X1后台 -> 站长 -> Manyou 设置，看到“漫游设置”如下图所示：

选择启用Manyou应用即可开启漫游服务。

如果您没有办法开启漫游服务，并且遇到问题，请详见后面连接中的问题汇总：

http://www.discuz.net/thread-1044418-1-1.html

关于图内选项的含义：

MYOP的IP：如果您的服务器因DNS解析问题无法使用MYOP服务，请填写MYOP的IP地址，默认为空。

关闭MYOP的更新提示：您的站点开启了MYOP多应用服务后，当平台有了新的信息的时候MYOP会自动提示给管理员。关闭本功能后，您将不再获取更新提示。

同步漫游信息：如果有问题可以选择同步漫游信息。

启用漫游搜索：漫游搜索是专为Discuz产品量身定做的高效、全文搜索服务，无须占用论坛的MySQL资源。

开启了漫游之后，点击“漫游应用管理”即可看到漫游应用控制界面，如下图所示：

在此可以设置应用的状态：默认应用、推荐应用、开启和关闭应用。注意：会员只能使用开启的应用（开启的应用包括：默认应用，推荐应用和站长手动开启的应用）。

默认应用：无论用户是否安装此应用，默认应用都会显示在所有用户的开始菜单里面。

关闭应用：用户不能安装处于关闭状态的应用，前台应用目录中也不会显示处于关闭状态的应用。

推荐应用：被设置为推荐的应用将显示在您网站应用目录的推荐栏目下。

点击上面的各个选项卡，可以看到下面的选项名称：

所有应用 - 现在Manyou能开放的站长可见的应用列表。

关闭应用 - 已经被站长关闭使用的应用列表。

开启应用 - 现已开启使用的应用列表。

推荐应用 - 为站内用户推荐的应用列表，有两种模式可选择，第一个使用Manyou推荐，第二个使用站长自己推荐的应用。

默认应用 - 设置了默认应用，那么无需用户添加，将会默认显示在用户的边栏菜单中。

审核方式 - 对Manyou平台上的应用进行审核开放，当开启时，可以关闭某一应用，这样用户就不能看到和使用此应用。

Manyou公告 - Manyou对某个应用的最新公告，里面带有上线时间、UV走势图、应用类型、漫游比支付状况和评价等。

漫游币服务 - 站长收入来源之一，当用户购买了漫游比之后，会与本站进行漫游币的分成结算。

杂项设置 - 可以对Manyou的应用添加形式以及页面刷新方式进行个性化定制。

统计 - 实时的站点运营应用的统计。

通过了解上述Manyou的一些操作，站长就可以轻松开启自身站点的漫游应用，从而达到SNS与游戏轻松结合，实现盈利，以及开通全站搜索的目的。


数据库

站长 —— 数据库

Discuz! X1 为站长提供了非常强大的数据库管理功能，可以一键完成诸如数据库备份、恢复、升级、优化、校验等操作。具有高级技术的站长朋友可以通过“升级”完成自己对数据库需要完成的高级操作。下面的将对如何使用此类功能，做一个详细的讲解。

首先使用后台管理团队登录 Discuz!X1后台 -> 站长 -> 数据库。看到如下图所示：

图中出现的是数据库备份界面，其中的单选选项默认选择了“站点全部数据”，在这里无需其他设置，直接点击提交即可完成站点所有数据的备份工作。

如果是高级用户，一键备份的选择不能满足你，可以点击上图中的“更多选项”，以此来定制自己需要的备份方式。如下图所示：

图中的数据库备份方式默认选择为“Discuz! 分卷备份 - 文件长度限制(kb)”，初始化为2048kb（2MB）

使用扩展插入(Extended Insert)方式 - 使用增量备份的方式，默认为否

建表语句格式 - 使用默认格式，即mysql自身的默认格式。

强制字符集 - 可以不选，这里是需要论坛转码的时候备份用到的。

十六进制方式 - 默认选择是。

压缩备份文件 - 默认为不压缩，提高备份的程序执行速度。

备份文件名 - 可以自定要备份到哪个文件中，后缀名为.sql。

如何将备份好的数据恢复

进入方法：后台 -> 站长 -> 数据库 -> 恢复

看完了如何备份数据库，就要学习一下如何恢复数据库，如下图所示：

数据恢复分两种情况，直接上传到服务器的“./data/backup_xxxxx”目录，然后在上图中的“从服务器（填写文件名或URL）”中填写需要恢复的文件夹，这样的方式适合多个备份文件恢复。

第二种情况是从本地上传文件，这个比较适合于小型站点，备份文件不多。

这个页面会自动刷新服务器备份数据目录中的备份文件，点击上图中右侧的高亮“导入”即可进行数据恢复工作。数据恢复的时间根据站点备份的数据量大小和数据文件的多少有关。

如何使用高级的数据库升级功能

进入方法：后台 -> 站长 -> 数据库 -> 升级

站点默认状态下是禁止SQL语句运行的，当您进入数据库升级页面发现此处功能不能使用的时候。请进入站点所在的服务器根目录(FTP文件根目录)，找到config/config_global.php文件，将$_config[admincp][runquery] 设置修改为 1 之后，刷新后台的页面，就能进入数据库升级页面了。

数据库升级界面如下图所示：

此数据库升级页面，有两种方法供站长选择，一种是打包好的升级语句“常用 SQL 升级语句”，这种是最快速完成需要的工作的选择。如果需要扩充打包语句，可以修改修改 admincp/quickqueries.inc.php 来添加常用 SQL 操作进行功能扩充。

第二种是直接输入数据库升级语句，如上图中的升级语句：

UPDATE pre_common_setting SET svalue = "Discuz! X1" WHERE skey = 'bbname';

“既是修改系统设置的论坛名称为 Discuz! X1”

写好语句，点击下面的提交，即可。修改结束后，推荐更新一下系统缓存。

如何使用数据库优化，及其作用

进入方法：后台 -> 站长 -> 数据库 -> 优化

如同电脑操作系统，Discuz! X1 也具备数据库碎片整理功能，如下图所示：

只需要点击“提交”按钮，即可让程序优化数据库中的数据碎片了。

如何校验数据库

进入方法：后台 -> 站长 -> 数据库 -> 校验

本页只有一个按钮，点击即可进行校验。当有出现Discuz! X1 默认的数据库结构与现运行站点的结构不同时，这里将会列出，并提供修复按钮。如下图所示：

通过上面的演示，站长朋友已经可以熟练的进行数据库的备份、恢复、优化、和校验了。通过sql语句的学习，也会很快掌握高级的“升级”功能。


帖子分表

站长 —— 帖子分表

帖子分表功能可以将帖子分在不同的数据表中，减轻单表的访问压力，提高网站运行效率，适合帖子数很多并且运行效率受到影响的站点使用。

此功能的设置位于：产品后台 => 站长 => 帖子分表

一、分表管理

帖子的分表有三种类型：主表、副表、存档表。其中主表必须有且只有一个，用于存放新主题的帖子；副表最多有一个，作为主表内容的补充，可与主表联合进行后台的进行批量更新、删除等操作；存档表可有任意多个，用于归档旧帖子，不参与后台的批量管理操作，但可以进行浏览、回复。

第一次访问帖子分表功能，会看到默认拥有一个主表，名称为pre_forum_post，此表为安装Discuz!X后的标准帖子表。

新添加的表会自动以“pre_forum_post_数字”的方式进行命名，无需人工干预。

如果当前主表内帖子过多，可以点击列表下方的“添加主表”创建一个新的主表。添加新的主表后，会影响之前的表类型设置，原来的主表将变成副表，原来的副表（如果存在）将变成存档表，新发的主题帖将存放在新的主表中。

点击列表下方的“添加存档表”，便可以添加一个新的存档表，添加存档表不会影响之前的表类型设置。

通过每个分表后面的类型，可以重新设置该表的表类型，设置好后，点击列表下方的“更新表类型”来保存修改。

“重置 Post ID”用于重新计算当前所有帖子表中pid的最大值，这个值加1便是下一个新帖子的pid。例如计算出当前所有帖子表中pid的最大值位1000，某一个用户的一个新回复的帖子pid便是1001。

点击每个帖子分表后面的“删除”可以删除该分表，只有空表可以被删除。当主表被删除后，列表中的最后一个分表会自动成为主表。

二、帖子移动

使用“帖子移动”功能可以在各个分表之间移动帖子。帖子移动涉及大量的数据转移，需要关闭论坛后使用。为防止数据库在移动过程中出现问题，请先进行数据备份。

移动帖子需要两步：

1、根据提供的条件搜索出要移动的主题帖

“在以下主题 (thread) 表中检索”会列出主题表存在的所有分表，指定其中一个主题分表，在其中进行搜索。

“所在分表”会列出帖子表存在的所有分表，指定其中一个主题分表，在其中进行搜索。

点击“更多选项”会出现更多搜索条件。

2、选择搜索出的帖子，然后选择目标分表，进行帖子移动。

移动操作可能需要一段时间，请耐心等待。

移动之后，可以从分表管理的分表列表中查看到每个分表的帖子数。


主题分表

站长 —— 主题分表

主题分表功能可将 forum_thread 表（包含主题标题、创建时间等信息，但不包含主题及回复内容）分在多个数据表中，减轻单表的访问压力，提高网站运行效率，适合主题数很多并且运行效率受到影响的站点使用。

此功能的设置位于：产品后台 => 站长 => 主题分表

一、分表管理

主题的分表有两种类型：主表、存档表。其中主表有且只有一个，用于存放新主题；存档表可有任意多个，其中的主题，只供浏览，不可回复、评分，不能进行管理操作，但可以删除和移动到非存档区。

第一次访问主题分表功能，会看到默认拥有一个主表，名称为pre_forum_thread，此表为安装Discuz!X后的标准主题表。此主表信息不可删除，不可更改。

新添加的存档表会自动以“pre_forum_thread_数字”的方式进行命名，无需人工干预。

点击列表下方的“添加存档表”，便可以添加一个新的存档表。

创建新的主题存档表后，可使用主题移动功能将特定主题移动到存档表中。移动到存档表中的主题，会在主题所在的版块下建立一个存档区（名称可自定义），通过存档区可浏览存档表中的主题。修改该存档表在板块的显示名称后，点击列表下方的“更新表信息”来保存修改。

“更新板块存档”用于更新在主题存档表中的主题所在的所有版块的主题存档信息。例如有两个主题存档表，这两个表中的主题属于A、B、C三个版块，“更新板块存档”后，便会在这些板块出现存档区的显示提示；反之，如果某一个版块中没有主题存在于主题存档表中，则会通过“更新板块存档”来删除此板块出现的存档区。如下图所示：

点击每个主题分表后面的“删除”可以删除该分表，只有空表可以被删除。

二、主题移动

主题移动功能可将特定的主题在原始表（forum_thread）和新建的主题存档表之间移动。移动主题之前，请确定存在至少一个主题存档表（表名为 forum_thread_1、forum_thread_2……）。

主题移动涉及大量的数据转移，需要关闭论坛后使用。为防止数据库在移动过程中出现问题，请先进行数据备份。

移动主题需要两步：

1、根据提供的条件搜索出要移动的主题

“搜索以下 thread 分表”会列出主题表存在的所有分表，指定其中一个主题分表，在其中进行搜索。

点击“更多选项”会出现更多搜索条件。

2、选择搜索出的主题，然后选择目标分表，进行主题移动。

移动操作可能需要一段时间，请耐心等待。

移动之后，可以从分表管理的分表列表中查看到每个分表的主题数。


常用功能

Discuz! X1 常用功能

  • 如何开启快速回复旁边的推荐表情
  • 官方页头广告示例讲解
  • 如何防灌水
  • 如何备份
  • 如何防攻击
  • 如何设置二级导航
  • 如何安装模板、风格
  • 如何绑定二级域名
  • 如何制作专题
  • 远程附件设置管理
返回主目录


如何开启快速回复旁边的推荐表情

推荐表情是 Discuz! X1 新增的机制，开启该功能后，会员可以在快速回复里添加表情，让操作更简单快捷，不用再去再点高级模式就可以发表情图片，同时推荐表情也可以在后台由管理员自由选择，想推荐哪组表情都可以，十分的方便。

1、该功能需要在后台开启，具体位置：

登录 Discuz! X1管理后台 => 界面 => 界面设置 => 帖子内容页 => 快速发帖 => 选择“是”，显示推荐表情，选择“是”。

2、推荐的表情需要到“表情管理”中设置

Discuz! X1管理后台 => 界面 => 表情管理 => 选择想要在快速回复中推荐的表情，点击“详情”如下图所示：

把所要推荐的表情全部选中，如下图所示：

提交后就可以在快速回复中使用表情了，在前台的显示效果如下

也可以点击显示所有表情，在快速回复中发布非推荐的其它表情。


官方页头广告示例讲解

很多站长想要实现和官方页头广告相同的广告方式，把站点中重要的内容显示在站点醒目的位置，而且还可以美化整个站点本身的布局，突显社区广告价值和会员价值可谓一举多得，下面主要以官方的广告为实例为大家讲解如果添加页头广告。

用户可以在 管理中心 => 扩展 => 站点广告 中通过广告位示意图直观地看到广告的展示位置，选择全局 页头二级导航栏广告，即可进行添加广告的操作。

展现方式:

页头二级导航栏广告显示于页面上方，通常使用 468x60 图片或 Flash 的形式。当前页面有多个通栏广告时，系统会随机选取其中之一显示。

价值分析:

由于能够在页面打开的第一时间将广告内容展现于最醒目的位置，因此成为了网页中价位最高、最适合进行商业宣传或品牌推广的广告类型之一。

设置：

打开“全局 页头二级导航栏广告”点击添加，如下图所示：

广告标题(必填)：这里填写广告的标题如“页头广告”。

广告投放范围(必选)：选择“论坛”

投放版块：选择在哪些版块显示，这里选择全部版块。

投放群组分类：这里可以不选择，因为前面的广告投放范围只选择了论坛，所在在群组中不会显示，如果上面的广告投放范围选择了群组，这里可以选择群组的分类。

广告起始时间(选填)：填写广告从哪一天开始显示，格式 yyyy-mm-dd，留空为不限制起始时间。

广告结束时间(选填)：填写广告结束的时间，格式 yyyy-mm-dd，留空为不限制结束时间。

展现方式：选择代码

广告 HTML 代码：这里要填写需要展现的广告的 HTML 代码，官方的广告代码如下：

在前台的显示效果如下图：


如何防灌水

这个功能主要是防止用户或者注册机恶意灌水，破坏站点的环境。

可以通过以下几种方式来实现。

一、防灌水基本设置：后台 => 全局 => 防灌水设置 => 防灌水基本设置，如下图所示：

1、两次发表时间间隔(秒)：在这里设置两次发表的时间间隔，如果发表间隔小于这个设置，系统将会发出警告。

2、强制新用户验证激活邮箱：此设置为“是”的话，用户必须验证激活自己的邮箱后，才能进行发布操作。

3、强制新用户上传头像：此设置为“是”的话，用户只有设置过自己的头像后才能进行发布操作。

4、强制新用户好友个数：在这里填入数字，设置新用户必须拥有的好友数量，之后才可以进行发布操作

以上各项设置好后，点击提交即可生效。

二、验证码设置：后台 => 全局 => 防灌水设置 => 验证码设置，如下图所示：

1、启用验证码：在这里勾选需要填写验证码才能通过的地方(新用户注册，用户登录，发表信息，修改个人资料)如下图所示：

2、验证码发帖限制：在这里输入数字，发帖数超过这个数量的会员，不受验证码的限制，即使开启了验证码，也不需要输入验证码就可以完成操作，0 表示所有会员都受验证码的限制，如下图所示：

3、登录失败时显示验证码：如果选择“是”，只有登录失败 3 次后才显示验证码。选择“否”，始终显示验证码。此设置在启用了用户登录验证码时，才有效，如下图所示：

4、验证码类型：这里选择验证码的类型，有五种类型可以选择。需要注意的是如果开启中文图片验证码，需要您的主机支持 FreeType 库；如果开启 Flash 验证码，建议您的主机开启 Ming 库以提高安全性，如下图所示：

1)当开启Flash验证码时，还可以进一步设置，如下图所示：

验证码图片宽度：设置验证码图片的宽度，范围在 100~200。

验证码图片高度：设置验证码图片的高度，范围在 50~80。

2)当开启英文图片验证码或中文图片验证码时，可以做更详细的设置，如下图所示：

图片打散：打散生成的验证码图片，输入打散的级别，0 为不打散。

随机图片背景：选择是，将使用选择“是”将随机使用 static/image/common/seccode/background/ 目录下的 JPG 图片作为验证码的背景图片，选择“否”将使用随机的背景色。

随机背景图形：选择“是”将给验证码背景增加随机的图形。

随机 TTF 字体：选择“是”将随机使用 images/fonts/en 目录下的 TTF 字体文件生成验证码文字，选择“否”将随机使用 images/seccode/gif 目录中的 GIF 图片生成验证码文字。中文图片验证码将随机使用 images/fonts/ch 目录下的 TTF 字体文件，无需进行此设置。

随机倾斜度：选择“是”将给验证码文字增加随机的倾斜度，本设置只针对 TTF 字体的验证码。

随机扭曲：选择“是”将给验证码文字增加随机的扭曲，本设置只针对 TTF 字体的验证码。

随机颜色：选择“是”将给验证码的背景图形和文字增加随机的颜色。

随机大小：选择“是”验证码文字的大小随机显示。

文字阴影：选择“是”将给验证码文字增加阴影。

GIF 动画：选择“是”验证码将显示成 GIF 动画方式，选择“否”验证码将显示成静态图片方式。

以上各项设置好后，点击提交即可生效。

三、验证问答设置：后台 => 全局 => 防灌水设置 => 验证问答设置，如下图所示：

1、启用验证问答：在这里设置要启用验证问答的地方(新用户注册，发表信息，修改密码)，开启后会员必须正确回答系统随机抽取的问题才能继续操作，如下图所示：

2、验证问答发帖限制：在这里填入数字，设置后发帖数超过这个限制的会员，不受验证问答的限制，0 表示所有会员受验证问答的限制，如下图所示：

3、验证问题及答案设置：先点击“添加新问题”，然后在问题下面的文本框中输入问题，在答案下面的文本框中输入答案，最后点击提交即可，开启验证问题后的效果，如下图所示：

四、注册限制设置：后台 => 全局 => 注册与访问 => 注册，如下图所示：

1、允许新用户注册：在这里设置，只开放邀请注册。这样只有收到邀请链接的人才能注册成为站点的会员，如下图所示：

2、新用户注册验证：可以选择 Email 验证或者人工审核，只有通过了验证才能成为正式的会员。如下图所示：

3、同一IP注册间隔限制(小时)：填入数字，设置后同一个 IP 在这个时间内只能注册一次，0 表示不限制，如下图所示：

4、同一IP在 24 小时允许注册的最大次数：填入数字，0 表示不限制，设置后同一个 IP 在 24 小时内只能注册设置的次数：如下图所示：

5、限时注册的IP列表：当用户处于本列表中的 IP 地址时，每 72 小时将至多只允许注册一个帐号。每个 IP 一行，既可输入完整地址，也可只输入 IP 开头，例如 "192.168."(不含引号) 可匹配 192.168.0.0～192.168.255.255 范围内的所有地址，留空为不设置，如下图所示：

以上各项设置好后，点击提交即可生效。

五、后台 => 全局 => 注册与访问 => 访问控制，如下图所示：

1、新手见习期限(小时)：新注册用户在本期限内将无法发帖和短消息，不影响版主和管理员，0 为不限制

2、允许访问站点的 IP 列表：只有当用户处于本列表中的 IP 地址时才可以访问本站点，列表以外的地址访问将视为 IP 被禁止，仅适用于诸如企业、学校内部站点等极个别场合。本功能对管理员没有特例，如果管理员不在此列表范围内将同样不能登录，请务必慎重使用本功能。每个 IP 一行，既可输入完整地址，也可只输入 IP 开头，例如 "192.168."(不含引号) 可匹配 192.168.0.0～192.168.255.255 范围内的所有地址，留空为所有 IP 除明确禁止的以外均可访问。

以上各项设置好后，点击提交即可生效。

六、后台开启帖子审核，防止灌水，以下两个地方要配合使用，只有都设置了审核，发帖才需要审核。

1、后台 => 论坛 => 版块管理 => 编辑版块 => 帖子选项 => 发帖审核，选择审核新主题和新回复，如下图所示：

2、后台 => 用户 => 用户组 => 详情 => 帖子相关 => 允许直接发帖，选择全部需要审核，如下图所示：

七、后台 => 扩展 => 站点任务，开启站点任务，完成任务给相应的积分等奖励，没有积分的会员不能进行其他操作。如下图所示：

任务类型，安装要启用的任务类型，如下图所示：

添加，添加安装的任务类型，设置具体的任务奖励，任务可申请的用户组等。如下图所示：


如何备份

站点搬家、升级或者安装涉及数据库的插件时，推荐备份数据；本教程简单讲解 UCenter 和 Discuz! X1 备份数据以及备份需要注意的事项。

一、关闭站点

后台 => 全局 => 站点信息 => 关闭站点 => 设置为是，如图：

二、备份数据库

1、登录 UCenter 后台 => 数据备份：

勾选要备份的应用，点击下面的“提交”按钮：

备份是自动的，您只需等待。备份完毕，您可以在“恢复数据”内查看备份数据：

点击详情：

三、备份数据存放目录

在 UCenter 后台备份得到的备份数据存放目录如下：

UCenter 备份数据存放目录：以独立主机为例，UCenter 安装根目录 /data/backup/backup_日期_随机字母/ 目录下，如图：

Discuz! 备份数据存放目录：以独立主机为例，Discuz! 安装根目录 /data/backup_日期_随机字母/ 目录下，如图：

这样就把所有数据都备份好了。

2、也可以站点后台 => 站长 => 数据库 => 备份，进行单个应用的备份，如图：

打开更多选项，可以设置具体备份条件，如图：

1、数据备份方式：一般都选择 Discuz! 分卷备份，可以单独设置每个备份文件大小；系统 MySQL Dump (Shell) 备份不建议虚拟空间用户使用；

2、使用扩展插入(Extended Insert)方式：保持默认的否即可

3、建表语句格式：备份时 MySQL 版本设置，一般备份不需要动到，除非搬家前后空间 MySQL 版本存在巨大差异；

4、强制字符集：分为 GBK 和 UTF-8，一般备份不需要动到，保持为默认即可；

5、十六进制方式：选择是，可以确保数据比较完整；

6、压缩备份文件，需要服务器支持压缩才可以正常使用，分为多分卷压缩成一个文件、 每个分卷压缩成单独文件、以及不压缩是三个设置；

7、备份文件名：可以自定义备份文件目录文件名称。

四、常用需要备份程序文件说明

1、Discuz! X1 程序目录\data\attachment 附件目录

2、UCenter\data\avatar 头像目录

五、注意事项

1、如果是论坛搬家，注意新的虚拟主机要支持 PHP+MySQL 环境，否则迁移后论坛无法正常运行；并确保新虚拟主机 MySQL 版本和字符集和原虚拟空间一致（ MySQL 版本以4.0和4.1为分割线），否则可能导致恢复后站点乱码等现象。

2、如果安装过插件，建议除了 config 目录外，其余目录、文件全部备份。


如何防攻击

在网站运营中，总有一些人不坏好心，想方设法来阻碍站点的正常运行。CC攻击就是常见的一种攻击办法，能导致站点 CPU 占用100%。Discuz! X1 内置了防攻击功能，可缓解被攻击带来的 CPU 占用100%问题。

打开防攻击功能的办法是：

登录 FTP 或者登录服务器 => 进入 config 目录 => 打开 config_global.php 文件 => 找到 $_config['security']['attackevasive'] 这一行 => 修改这一行 = 号后面的数字。

默认是0，就是关闭这个功能。没有受到攻击的时候，建议设置成0，对用户的访问影响最小。

1 代表 cookie 刷新限制，设置成1后，对论坛的请求间隔必须大于2秒钟，在2秒钟内进行的多次请求和刷新，都会被拒绝。

2 代表 限制代理访问，设置成2后，使用代理的用户将无法访问论坛，这个可以防止一些人利用代理进行攻击。

4 代表 二次请求，设置成4后，初次访问论坛，会进行一个页面跳转，然后才会接受正常访问。利用攻击工具是无法实现这个跳转的，可防止一些攻击工具的攻击。

这个防攻击的设置，并不限于一个参数，可以多个参数组合使用，比如设置成 1|4 ,就是同时限制刷新和开启二次请求，还可以设置成 1|2|4 ，就是启用所有的防御方式。这些都可以根据需要灵活组合，已获得最佳的防御效果。


如何设置二级导航

二级导航开启后，将显示在如下图所示的地方，更加方便会员访问一些链接：

1、添加二级导航的方法：后台 => 界面 => 导航栏 =>首页二级导航，如下图所示：

2、点击添加菜单，填写导航名称，描述和链接，点击提交即可，如下图所示：

添加后的显示效果，如下图所示：

3、点击二级导航后面的详情，还可以设置菜单子体样式、菜单子体颜色、链接打开方式和使用等级，如下图所示：

4、如果想改变二级导航显示的顺序，修改显示顺序下的数字即可，如下图所示：


如何安装模板、风格

在 Discuz! X1 中安装风格，首先需要把该风格的文件夹上传到 template 目录中，然后安装该风格。

风格的安装有两种方式：

一、在 管理中心 => 界面 => 风格管理 => 管理 中，点击需要安装的风格预览图上的“安装”选项。

二、在 管理中心 => 界面 => 风格管理 => 导入 中，导入需要安装的风格的 xml 风格文件。导入方式分为两种：

1、上传文件

直接上传该风格文件夹下的 xml 文件，提交导入。

2、粘贴文本

把 xml 文件中的文本内容粘贴到文本输入框中，提交导入。


如何绑定二级域名

一、你需要为你的域名添加泛解析

以新网的域名后台为例，你进入新网的域名管理面版后，添加一条A记录。其中，“主机名”填写为 *.yourdomain.com，“指向”填写为 你的服务器IP。(域名解析需要一段时间，您可以 ping 看看是否成功)

说明：yourdomain.com 需要修改为您的域名。

二、设置服务器支持泛域名

1、Apache 服务器：

打开配置文件 conf/httpd.conf 文件（Linux 主机该文件默认安装在 /usr/local/Apache2/，win 主机取决于您的 Apache 安装位置），添加一个虚拟主机配置（如下）：

ServerAdmin webmaster@yourdomain.com

DocumentRoot /www/uchome

ServerName yourdomain.com

ServerAlias *.yourdomain.com

注意：上面的 yourdomain.com 需要修改为你的域名。 如使用三级域名，则 yourdomain.com 修改为类似 home.yourdomain.com 这样的形式。

2、IIS 服务器：

首先需要为 UCenter Home 建立一个新站点。

注意：

1）如果该服务器上还有其他站点，请为这些站点先设置好主机头，否则二级域名设置无效。

2）UCenter Home 的站点主机头必须为空。

3）更改其他站点的主机头，如果为空，则需要编辑更改主机头不为空。

如下图所示：

三、虚拟主机开启二级域名

首先需要咨询空间商，服务器是否支持泛解析，如果支持泛解析，直接在您的域名管理后台添加一条 A 记录，然后到 UCenter Home 管理后台开启二级域名功能会员就可以正常使用了。

四、后台开启功能：

1、后台 => 全局 => 空间设置 => 基本设置 => 开启二级域名,如下图所示：

2、保留二级域名：填写不允许会员设置的二级域名名称

3、二级域名根域名：填写网站根域名

设置好后，提交即可。

二、前台的使用：

1、前台 => 首页 => 设置，如下图所示：

2、点击我的空间域名，填写要设置的域名名称，提交即可，如下图所示：

设置之后就可以用设置好的二级域名来访问自己的空间了。


如何制作专题

一、添加专题。

1、进入后台 => 门户 => 专题管理，选择创建专题，如下图所示：

2、在新建专题页面，编辑专题的相关内容，如下图所示：

1)专题标题：填写新建的专题的标题名称。

2)静态化名称：填写新建专题的静态化名称，开启专题页静态化后，此名称将显示在链接中，不能重复。

3)专题介绍：输入描述专题的介绍性文字。

4)专题封面：设置专题的封面，可以填写网络链接地址，也可以本地上传图片。

5)模板名：在下拉菜单中选择专题使用的模板名。如果要使用自定义的模板，请将模板文件上传到 template/default/portal 目录下，文件名必须为 portal_topic_*.htm，* 为自定义文件名。

6)附件内容：可以勾选站点导航或站点尾部信息附件内容。

设置好后点击提交，跳转到 DIY 专题页面。

3、DIY 专题

1)框架：拖拽专题要添加的框架。如下图所示：

2)模块：在添加的框架中，添加模块，如下图所示：

3)风格：选择专题要用的风格样式，如下图所示：

4)自定义：分背景，标题栏和内容区，来设置背景颜色，背景图片，文字颜色及连接颜色，如下图所示：

如果想重新自定义，可以点击取消背景图或恢复原装皮肤。

以上设置都完成后，保存即可。

二、开启，关闭和删除专题。

1、开启专题：

1)进入后台 => 门户 => 专题管理 => 列表，可以看到所有已添加的专题。

2)勾选专题前面的复选框，然后选择开启前的复选框，点击提交即可开启专题，如下图所示：

2、关闭专题：

1)进入后台 => 门户 => 专题管理 => 列表，可以看到所有已添加的专题。

2)勾选专题前面的复选框，然后选择关闭前的复选框，点击提交即可关闭专题，如下图所示：

3、删除专题：

1)进入后台 => 门户 => 专题管理 => 列表，可以看到所有已添加的专题。

2)勾选专题前面的复选框，然后选择删除前的复选框，点击提交即可删除专题，如下图所示：

三、专题生成伪静态地址：

1、设置伪静态规则，后台 => 全局 => 优化设置 => 搜索引擎优化 => URL 静态化，点击查看当前的 Rewrite 规则，会自动生成 Rewrite 规则，如下图所示：

如果是虚拟主机用户，需要咨询空间商是否支持Rewrite规则。

2、后台 => 全局 => 优化设置 => 搜索引擎优化 => URL 静态化，勾选首页专题页，如下图所示：

设置好后，访问专题页，即可看到静态化地址，效果如下图所示：

四、实现专题聚合页。

1、首页点击 DIY，拖拽要添加的框架。

2、在框架中添加专题类模块，各个专题就可以在首页聚合显示了，效果如下图所示：


远程附件设置管理

Discuz! X1的远程附件功能，主要是通过远程上传附件将一部分附件上传到 web 空间以外的其他服务器或空间上，其作用主要有以下三个方面：

1）减少服务器流量

2）减轻服务器负载

3）节约 WEB 空间

1、设置方法

如下图所示：

2、注意事项

1）确保 FTP 服务器地址、端口号、帐号及密码的正确。

2）被动模式（pasv）链接：一般情况下非被动模式即可，如果存在上传失败问题，可尝试打开此设置。

3）远程附件目录：远程附件目录的绝对路径或相对于 FTP 主目录的相对路径，结尾不要加斜杠“/”，“.”表示 FTP 主目录。

举例：FTP登录后的主目录为D:\web，若打算将附件存储在D:\web\attachments文件夹，可直接填写D:\web\attachments（存放远程附件的目录在服务器上的绝对地址），或者填写相对路径 ./attachments。

4）远程访问 URL：支持 HTTP 和 FTP 协议，结尾不要加斜杠“/”；如果使用 FTP 协议，FTP 服务器必需支持 PASV 模式，为了安全起见，URL浏览附件FTP连接的帐号不要设置可写权限和列表权限。

举例：http://www.domain.com/attachments （其中 http://www.domain.com 为用于存放远程附件的 FTP 空间的访问地址，attachments 为存放远程附件的目录）

2、附加设置

在站点启用了远程附件后，还可以在 管理中心 => 全局 => 上传设置 => 论坛附件 中设置远程附件允许和禁止的扩展名、附件尺寸下限、及是否隐藏远程附件的真实路径。


工具

Discuz! X1 工具相关

  • Tools工具针对Discuz! X1 使用说明
  • PHPWind 7.5 to Discuz! X1 转换说明
返回主目录


Tools工具针对Discuz! X1 使用说明

工具 —— Tools工具针对Discuz! X1 使用说明

说明：

新版 tools 一改旧版庞大的单文件版本，转变成 插件形式的多文件版本，由于 Discuz! X 将各个产品模块的融合，tools 工具箱也不用再为各个版本都提供不同的判断程序了。同时以插件形式存在，也为广大站长提供了更多的除了系统救援之外的功能。目前第一个版本只有最基本的功能，之后会将旧版 tools 中如：数据恢复，数据转码等功能加如进来，还会增加更多的方便站长管理的功能。

使用方法：

下载压缩包后，解压，将 upload 目录下的所有文件，全部上传到 Discuz! X 的程序根目录中。

其中，source 目录中为插件程序，tools.php 为外部入口程序，如果不需要外部入口提供的各项功能的话，可以不上传这个文件。同时可以保证安全，需要使用的时候再上传。

一、安装插件

进入后台插件管理面板，安装插件。

选择字符集：

选择和 Discuz! X1 相同的字符集进行安装，

启用插件：

二、后台的使用

1、密码/文件锁设置

文件锁：选择启用，将返回一段随机字串，如下图所示：

以此字串为文件名（不需要扩展名）新建文件上传到站点根目录中，才可以正常使用 Tools 外部接口 tools.php 文件。

这里每提交一次，验证字串就会改变一次，需要重新建立新的字串文件上传到站点根目录中。

密码锁：此密码为 tools 外部访问接口访问密码，请妥善保管。

Tools 外部接口是在站点无法访问的时候应急处理站点问题的入口，请保存好这个密码，不要透露给任何人，第一次使用无密码，请自行设置。

2、模块相关设置

可以修改默认首页模块，和为各个模块绑定域名。

当前首页：修改站点打开的时候默认的首页为哪个模块。

模块域名绑定：修改各个模块单独的域名，格式如：forum.discuz.net，不需要加 http//:

3、清理数据库冗余

清理贴子表冗余：清理对应主题已经不存在的回复。

清理主题表冗余：清理 post 无对应记录的主题，同时修复正常主题的标题，回复，附件，最后回复等参数。

清理附件表冗余：清理对应主题已经不存在的附件记录，并删除附件文件。

清理用户表冗余：清理用户信息表里存在，用户表里不存在的记录。

清理家园相册表冗余：清理相册下已经没有图片的相册，并删除封面图片。

清理家园图片表冗余：清理无对应相册存在了的图片，并删除图片文件。

检查用户信息表完整：如果您发现无法对某个用户办法勋章或者无法记录部分用户的隐私设置，请执行此项。

4、地区信息

备份和恢复地区信息数据

地区信息备份：直接点击备份即可保存到本地，即将地区信息下载到本地。

地区信息恢复：浏览找到备份文件即可直接恢复。

安装官方地区信息：可以直接安装官方默认的地区信息，安装前确保 install\data\common_district.sql 这个文件存在并完好。

5、导出个人资料

可以将用户填写的家园信息导出为 csv 格式的文件。以便地区网站与行业网站统计。

三、tools.php的使用

如果官方站点地址为例 http://www.discuz.net ，直接上传 tools.php 文件，那么在浏览器可以访问：http://www.discuz.net/tools.php

由于我在后台设置了文件锁，但是没有上传文件锁到站点根目录，所以会提示如下的信息：

上传文件锁之后，可以看到登陆框，输入密码即可登录，登录成功后，就可以看到功能界面了。

1、找回管理员

此功能可以重置创始人以及副站长密码，在忘记密码无法进入后台的时候使用。

密码留空为不重置密码，只设置管理员。也可以把某个普通会员添加为现有管理员（副站长）

如果不想添加其它会员为管理员，可以在这里直接输入创始人的密码即可，同时可以清除安全提问。

2、关闭站点

此处可以进行站点“关闭/打开”的操作。

会自动检测出站点的当前状态，比如当前状态为关闭，可以在这里直接选择打开，站点即可打开。如果当前状态站点为打开，可以在这里关闭站点，并填写关闭再由。

3、UCenter 配置

可以监控测试站点的数据库连接情况，同时可以对配置文件进行修改。

注：修改配置文件前要保证配置文件可写。

4、修复数据库

尝试使用 repair table 命令修复数据库，如果无法修复，那么请在服务器上以命令行模式进行修复。

可以对数据表进行检查然后修复。

5、关闭验证码

如果验证码显示不正确，或者无法通过验证造成无法进入后台，可以从这里关闭验证码。

6、更新缓存

如果由于站点缓存出现问题而无法进入后台，那么可以从这里更新缓存。

7、恢复数据库

当站点无法打开，后台恢复数据库不成功的时候，可以使用 tools 恢复数据库。


PHPWind 7.5 to Discuz! X1 转换说明

工具 ——PHPWind 7.5 to Discuz! X1 转换说明

Discuz! X 是一个整合了BBS、SNS、PORTAL、漫游等多种功能一个社区产品。它的出现解决了一直存在于社区中的若干重大问题。

为了方便广大站长转换及使用 Discuz! X , 我们开发了 Phpwind 7.5 转 Discuz! X 转换程序。

本程序只适用于 Phpwind 7.5 版本的程序。转换程序前请认真阅读转换程序中的转换说明。

一、转换前的准备

1、请确认您已经成功安装了 Discuz! X

Discuz! X 图文教程：http://faq.comsenz.com/index.php?action-viewnews-itemid-943-php-1

2、下载 XConvert 转换程序到本地或服务器，主要包含以下几个文件，如下图所示：

二、转换详细步骤

1、将 XConvert 文件夹上传到 web 可以访问的目录下，在浏览器里输入 http://yourwebsite.com/xconvert 就看到了授权协议，点击“确定”，如下图所示：

2、在上图中点击“pw75 - 1X”后，如下列图所示：上部分是转换说明，下部分是转换配置信息。

着重说明的几点：

1）、phpwind 数据库字符集：有 GBK、UTF8、BIG5 三种，如果不知道网站的数据库字符集，选择其中的一种，点击右方的“检查此设置”，程序会提取的 pw 的部分数据转换做个测试，如果显示正常说明数据库字符集正确，否则重新设置并检测。

下面举个例子：配置好数据库信息，选择字符集为 GBK ，点击“检查此设置”，效果如下图所示。显然这个显示是正确的，说明 pw 库的字符集就是 GBK。

选择数据库字符集为 utf8 ，点击“检查此设置”，效果如下图 ，显然这个显示是乱码。

2）Discuz 论坛类型：用于区分 Discuz! 产品是 7.2及之前的版本或是 X 及其他以后的版本

3）每次需要转换的数据量：这项主要是根据服务器繁忙情况设置，建议在服务器不是太忙的时候转换或将此值调低。

4）更新统计的循环量：这项主要是根据服务器繁忙情况设置，建议在服务器不是太忙的时候转换或将此值调低。

3、配置好信息后，点击“保存”，如下图所示：这一步中可以选择“完全转换”或者单步转换，第一次转换一般建议选择“完全转换”。

4、上图中点击“开始转换”按钮则得到如下图所示的开始转换的界面：

1）正常情况下，转换过程是全自动的，您无需干预，请坐下来喝杯茶，静静等待出现转换完成的提示；

2）如果转换过程中程序终止运行，请根据出错提示信息进行调整，然后刷新页面继续进行转换；

3）转换所需时间取决于您的数据量大小、数据结构的标准与否、转换程序所在平台的性能、网络状况等因素。

转换完成如下图所示：

三、转换后的工作

1、查看转换结果分析报告：点击查看转换报告

本次转换演示的转换分析报告如下图所示：


主题和帖子管理