首页.1

Powered By Gisun http://www.gisun.com

QQ聊天内容监控特别说明

首次独家实现：在局域网内，不需要在被监控电脑安装任何软件，进行简单设置即可解密监控QQ聊天内容！


一、为什么市场没有不在被监控端安装，就可以监控QQ聊天内容的网络监控系统软件？.690

一、为什么市场没有不在被监控端安装，就可以监控QQ聊天内容的网络监控系统软件？

腾讯QQ是中国使用最多的即时通讯软件，其网络通信全部加密传输，这也是目前实现监控QQ聊天内容，其他网络监控软件都必须在被监控电脑安装一个后门软件的重要原因，否则网络监控系统无法实现解密QQ聊天内容。

成都考普科技有限责任公司一直致力于互联网通信监控领域的技术研究和产品开发，不在被监控电脑端安装任何软件和易于管理层使用是我公司开发的一贯基本原则。基于这样的原则和多年专业积累，历经数年我们终于有了突破性实现：不在客户端安装，就可以监控单位内部的QQ聊天内容（包括最新大量采用DirectUI技术的QQ2009版本）。

本功能的成功实现，综合了多种先进网络技术，如抓包技术、分析还原技术、监控技术、封网技术、加密技术、解密技术、身份验证技术、协议分析技术以及社会工程学技术等等，技术含量非常高，也充分展示我公司在这一领域的技术实力和开发能力。

提示：请经常访问http://www.corpcorp.com 关注最新版本，因为腾讯QQ经常在升级，试用客户尽量下载最新版本。我们只保证最新版本才能正常监控腾讯的最新QQ。


二、考普软件监控ＱＱ的基本原理.3381

二、考普软件监控ＱＱ的基本原理

QQ通信中的加密解密基本原理：QQ登录时，腾讯服务器使用该QQ密码产生通信数据包的加密密钥，从而实现通信数据包的加密和解密。也就是说，如果能够获取QQ登录的通信密钥，就可以完全不在被监控机安装任何软件，即可实现监控QQ聊天内容。

考普监控软件实现监控的基本过程如下，整个过程的目的就是为了自动获取QQ的密码和密钥，从而实现解密：

（1） 当监控系统检测到QQ向好友发送的聊天消息不能解密时，监控系统将强制被监控的登录QQ离线（过程一般几分钟）。

（2） QQ再次登录的时候，强制要求QQ用户到腾讯安全中心http://aq.qq.com/cn/services/abnormal/abnormal_index进行“解除限制”。

（3） 腾讯安全中心http://aq.qq.com/cn/services/abnormal/abnormal_index要求QQ用户输入QQ号码和密码进行登录验证，如果用户输入QQ号码和密码均正确，则解除限制成功。此时监控系统就能够成功实现对通信内容的监控记录。

（4） 当QQ再次登录通信时，其通信内容就得被监控记录。


三、监控系统设置QQ监控的具体步骤.6568

三、监控系统设置QQ监控的具体步骤

本功能已经经过数万客户测试检验，在同一单网段的局域网内完全能够监控QQ聊天内容，如果试用客户还需要测试，建议先拿自己QQ先在两台机器上做测试。监控单位内部其他QQ需要一定步骤，不要急于求成，也不要一次性进行大范围QQ监控（因为要解除限制一次，人多了大家会怀疑），更不要告诉员工在使用本软件。

（1）测试注意事项：

使用本功能前，务必能保证系统监控正常，尤其能监控其他主机的QQ和Web上网记录。具体请参考《快速安装测试步骤doc》。如果网关（路由器）做了IP-MAC进行了绑定防ARP，建议临时取消。

测试的时候，尽量暂时关闭防火墙和安全软件，以免防火墙等影响测试效果。测试成功后，再开启安全软件。

（2）点击主界面“QQ监控” [image] 按钮，出现下图所示的主机列表界面，在要监控QQ聊天内容的左边主机列表打勾（试用版本最多只能选择 8台主机）。右下正确选择监控模式，然后点击“更新按钮”即可。

（3）成功更新配置后，上面步骤选择主机上的QQ就不能发送消息，如果其发送消息，大约几分钟后就会自动离线，然后上线。 这个时候，监控系统会强制要求登录QQ进行“解除限制”，如下图所示。

被监控电脑点击“解除限制”按钮后，会访问http://aq.qq.com/cn/services/abnormal /abnormal_index腾讯安全中心网站，如下图所示。

要求用户输入QQ号码、密码和验证码，点击“登录”，如果输入的QQ号码和密码以及验证码正确，则会返回成功解除限制界面。

如果输入的QQ号码和密码或验证码不正确，则会返回错误提示界面，要求用户继续登录。

如果用户不进行QQ解除限制或者错误输入QQ号和密码，下一次QQ登录的时候仍然提示他要解除限制才能使用QQ。

特别说明：如果个别员工知道了本系统功能可以截获密码和密钥，可能不会输入QQ号码和密码去登录。

对于我们监控系统强制QQ弹出的“解除限制”界面，根据我们统计，QQ用户在不知道被监控的情况下，绝大部分会对这是腾讯在要求他解除限制深信不疑，所以基本都会输入正确密码，（软件试用测试人员当然知道我们系统功能了，所以想法就不一样了。比如尝试假密码等等）。

用户输入正确的密码和QQ号解除限制后，只要用户不更改密码，监控系统不会再要求用户去解除限制QQ了，实际监控中，很少有用户改QQ密码，相当于对大部分用户，一次解除限制处理，系统就永久监控其QQ了。

（4）用户“解除限制”成功后，就会重新登录QQ，监控系统这个时候已经自动获取了其通信密钥，所以聊天过程就可以自动解密了。


四、怎样判断监控QQ成功.14471

四、怎样判断监控QQ成功

在监控监控系统中，点击“记录查询”按钮或者双击左边主机列表，查询出某个主机某段时间的内的监控记录，若出现有下图所示登录限制信息和密码信息，说明系统成功监控这个QQ的聊天内容了。否则监控系统需再次强制用户重复上述“解除限制”步骤。

请仔细看上图的成功步骤包括：

（1） 某个QQ号码登录上线，向其发送登录限制命令。

（2） Web浏览部分，用户访问腾讯安全中心http://aq.qq.com/cn/services/abnormal/ abnormal_index进行QQ号码解除限制登录。

（3） 记录下用户在Web网页里面输入的QQ号和密码，密码部分我们只显示3位，其余部分做了隐藏处理，用***表示。

（4） QQ再次登录，如果监控到了“成功获取QQ号的解密密钥，就可以监控其聊天内容了”，表示以后这个QQ聊天就可以自动监控了。

其中首先观察是否有上面的（3）和（4）步骤，这两个相当关键，是整个系统解密的关键，应当首先观察是否有这两个步骤。如果有这两个步骤，说明前面的步骤一切正常，如果没有，然后才检查前面相应的步骤。


五、聊天记录重复解决方法.18006

五、聊天记录重复解决方法

如果使用主界面菜单－辅助工具－交换机环境监控，监控产生的QQ聊天记录可能是双倍，这种情况很正常，因为监控机本身就是潜在的网关，要中转通信，因而数据就多了一倍，聊天记录可能是重复的。这种情况解决方法是：

点击主界面【监控选择】按钮，找到监控机本身，把前面的勾去掉即可，也就是不监控本机。

如果采用镜像交换机或者HUB进行监控，一般不存在这种现象，所以试用的时候可以不管，串接镜像交换机或者HUB后，聊天记录就不会再重复。


六、怎样查看QQ聊天内容.19057

六、怎样查看QQ聊天内容

获取了QQ密码和密钥，成功监控QQ聊天内容后，有以下两种方式可以查看QQ聊天内容：

（一） 点击监控软件主界面菜单－数据管理－QQ聊天记录查看器，出现如下图所示的界面，推荐使用。

界面左边列表：表示当前已经监控到聊天内容的员工QQ号码，点击左边QQ号码，右上出现这个员工和其他人的聊天文件信息，可以按照最近聊天时间、文件大小、QQ号码等排序，查看一目了然。（默认按照时间日期排序，这样很方便查看XX员工最新的聊天内容）

鼠标点击右上记录， 右下则显示他们的聊天内容。QQ聊天记录管理器还可以把员工QQ号码和姓名进行对应，设置后，左边列表则显示为姓名，查看更方便。

（二）在监控系统主界面鼠标双击下图所示的“QQ和ICQ聊天”记录，如标题为“本次UDP方式上线累计发送X信息…..”

如果这个QQ号有聊天记录了，则会自动打开Windows资源管理器，鼠标双击右边窗口的文件即可看QQ聊天内容，如下图所示。

技巧提示：如果是Windows XP系统，建议在Windows资源管理器里面，先点击菜单－查看－详细信息。 然后，再点击菜单－工具－文件夹选项，选择中间的【查看】，点击【应用到所有文件夹】。

这样就很容易对文件时间、大小进行排序，从而很方便查看最新日期的QQ聊天内容。也可以利用Windows资源管理器进行关键字搜索等功能。


七、结束语.23723

七、结束语

本软件为正规商业软件，拥有国家软件产品登记和计算机软件著作权，也符合公安部2005年第82号令对联网单位上网监控的要求。

在单位网络系统内监控员工上网行为是法律法规完全允许的，但由于QQ密码会涉及到众多隐私权问题，所以本公司开发的系统不显示获取的密钥(码)，也谢绝任何单位和个人要求我们提供显示密钥(码)技术。